Contribute
Register

El Capitan Beta with Dell XPS 13 9343 (Early 2015 Model)

Status
Not open for further replies.
Joined
Jun 3, 2013
Messages
15
Motherboard
Dell 9343
CPU
i5-5200U
Graphics
HD 5500
Mobile Phone
  1. Android
  2. iOS
Check BIOS version, and BIOS settings.

So, I was just about to give up for the day and was turning on all my settings such as c state and virtualization back on when i hit apply and when I exited my drive was still plugged in and happened to auto boot like i had it set up to do and bam! it doesn't stick at that error anymore, and boots right into the os installer! Right now I am typing this on my successful hackintosh! Right now my BIOS settings are not set to what OP said to do... but that made it boot for me. Everything seems to work right now volume wifi graphics only thing that doesn't would be brightness buttons. but it is bright enough and seems to be on auto or something. Thank you all! Ill continue testing and everything I am sure I will run into some issue down the line.
 
Joined
Apr 2, 2013
Messages
420
Motherboard
Dell XPS 13 (9360)
CPU
i7-8550u (8th Generation) Kalby Lake - R
Graphics
Intel UHD 620
Mac
  1. MacBook Pro
So, I was just about to give up for the day and was turning on all my settings such as c state and virtualization back on when i hit apply and when I exited my drive was still plugged in and happened to auto boot like i had it set up to do and bam! it doesn't stick at that error anymore, and boots right into the os installer! Right now I am typing this on my successful hackintosh! Right now my BIOS settings are not set to what OP said to do... but that made it boot for me. Everything seems to work right now volume wifi graphics only thing that doesn't would be brightness buttons. but it is bright enough and seems to be on auto or something. Thank you all! Ill continue testing and everything I am sure I will run into some issue down the line.


Glad you got it working! Yes, this machine seems to need a BIOS refresh on occasion. Keep us posted.
 
Joined
Jun 13, 2015
Messages
25
Motherboard
Dell XPS 13" 9343 UHD \ Z77-UD3H
CPU
i7-5500U \ i5-3570k
Graphics
Intel HD 5500 \ HD7950
So, I was just about to give up for the day and was turning on all my settings such as c state and virtualization back on when i hit apply and when I exited my drive was still plugged in and happened to auto boot like i had it set up to do and bam! it doesn't stick at that error anymore, and boots right into the os installer! Right now I am typing this on my successful hackintosh! Right now my BIOS settings are not set to what OP said to do... but that made it boot for me. Everything seems to work right now volume wifi graphics only thing that doesn't would be brightness buttons. but it is bright enough and seems to be on auto or something. Thank you all! Ill continue testing and everything I am sure I will run into some issue down the line.

How is your touchpad working?
 
Joined
Jan 26, 2016
Messages
55
Since I have achieved my goals (everything working, except Webcam, no serial id which is kind of unlucky), I'll try to start making a guide to install and patching things but I expect nothing in a week or two, and also keep in mind that maybe in this upcoming guide, there will be something that might not be working and I cannot tell what is causing it (i don't promise).

By the way, anyone has successfully installed applehda patch? it's obviously annoying when the sound disappears.

and, anybody want to upload applehda which can be found in the S/L/E ? thanks ! (I lost it moment ago :( )
 
Joined
Apr 2, 2013
Messages
420
Motherboard
Dell XPS 13 (9360)
CPU
i7-8550u (8th Generation) Kalby Lake - R
Graphics
Intel UHD 620
Mac
  1. MacBook Pro
I works and is pretty similar to how tracking worked in windows. Gestures are not working at all.

What gestures do you want? Have you configured them in the keyboard preference pane (shortcuts)? I had to define the gestures before they could be used.
 
Joined
Apr 2, 2013
Messages
420
Motherboard
Dell XPS 13 (9360)
CPU
i7-8550u (8th Generation) Kalby Lake - R
Graphics
Intel UHD 620
Mac
  1. MacBook Pro
Since I have achieved my goals (everything working, except Webcam, no serial id which is kind of unlucky), I'll start making a guide to install and patching things but I expect nothing in a week or two, and also keep in mind that maybe in this upcoming guide, there will be something that might not be working and I cannot tell what is causing it.

By the way, anyone has successfully installed applehda patch? it's obviously annoying when the sound disappears.

and, anybody want to upload applehda which can be found in the S/L/E ? thanks ! (I lost it moment ago :( )

I've tried on several occasions to patch AppleHDA. Each time with success except the fact the sound would stop a short while after boot and never come back until a reboot. Tried with codeccommander as well. I've reverted back to voodoohda every time. I will revisit this again, but not sure what to do differently.
 
Joined
Apr 2, 2013
Messages
420
Motherboard
Dell XPS 13 (9360)
CPU
i7-8550u (8th Generation) Kalby Lake - R
Graphics
Intel UHD 620
Mac
  1. MacBook Pro
I'm trying again at patching AppleHDA for this machine to use, instead of voodooHDA. I think I'm making progress, but I'm still running into a wall with the sound stopping a short while after being booted. I have patched the native AppleHDA kext and patched DSDT with layout 3, installed codec commander and RealtekALC kext in EFI/Clover/Kexts/Other

Attached is my ioreg. Any guidance is welcome. Thanks!

View attachment MacBook Air.zip
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I'm trying again at patching AppleHDA for this machine to use, instead of voodooHDA. I think I'm making progress, but I'm still running into a wall with the sound stopping a short while after being booted. I have patched the native AppleHDA kext and patched DSDT with layout 3, installed codec commander and RealtekALC kext in EFI/Clover/Kexts/Other

Attached is my ioreg. Any guidance is welcome. Thanks!

View attachment 179037

Patched AppleHDA does not work from Clover/kexts. Must be installed to the system volume.
 
Status
Not open for further replies.
Top