Contribute
Register

El Capitan Beta with Dell XPS 13 9343 (Early 2015 Model)

Status
Not open for further replies.
Joined
Jun 3, 2013
Messages
15
Motherboard
Dell 9343
CPU
i5-5200U
Graphics
HD 5500
Mobile Phone
  1. Android
  2. iOS
Try my EFI folder, just replace your EFI folder with this one on your EFI partition of the USB stick

Its a no go still crashes with the "+++++++++++++++++++". This doesn't make any sense. The only major difference between our pc's is the resolution.
 
Joined
Jun 13, 2015
Messages
25
Motherboard
Dell XPS 13" 9343 UHD \ Z77-UD3H
CPU
i7-5500U \ i5-3570k
Graphics
Intel HD 5500 \ HD7950
RehabMan, I tried the GFX0 to IGPU renaming patch on dsdt file but it just gives a panic crash(I think it's called?)

Photo: http://imgur.com/vIY2asK
 
Joined
Jun 13, 2015
Messages
25
Motherboard
Dell XPS 13" 9343 UHD \ Z77-UD3H
CPU
i7-5500U \ i5-3570k
Graphics
Intel HD 5500 \ HD7950
Its a no go still crashes with the "+++++++++++++++++++". This doesn't make any sense. The only major difference between our pc's is the resolution.

Try a different USB and/or different port, the issue could also be with the installer
 
Joined
Jun 3, 2013
Messages
15
Motherboard
Dell 9343
CPU
i5-5200U
Graphics
HD 5500
Mobile Phone
  1. Android
  2. iOS
Try a different USB and/or different port, the issue could also be with the installer

Tried both sides with three different drives... I dont know maybe I will retry downloading el capitan.app only thing i could think would be wrong really.
 
Joined
Jun 13, 2015
Messages
25
Motherboard
Dell XPS 13" 9343 UHD \ Z77-UD3H
CPU
i7-5500U \ i5-3570k
Graphics
Intel HD 5500 \ HD7950
RehabMan,
Ok I think I did the DSDT patch and PM SSDT, I haven't patched any original SSDTs yet.

Opening Utilities folder and applications from dock is still a bit laggy, but touchscreen, brightness control and everything else seems to be working. I've attached IOReg
 

Attachments

  • XPS.ioreg.zip
    1.5 MB · Views: 57
Joined
Jun 13, 2015
Messages
25
Motherboard
Dell XPS 13" 9343 UHD \ Z77-UD3H
CPU
i7-5500U \ i5-3570k
Graphics
Intel HD 5500 \ HD7950
I've given up for now, I got everything mostly working but the trackpad glitchiness was killing it for me, together with OS having a chance not to boot for the first time due to unknown reasons and sound not working from time to time. It's just sad because I hate Windows for its scaling issues.

Thanks everyone for help, hopefully with time some genius will come up with a guide on how to get everything fully working coz I'm not smart enough to figure it out on my own haha
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Its a no go still crashes with the "+++++++++++++++++++". This doesn't make any sense. The only major difference between our pc's is the resolution.

Check BIOS version, and BIOS settings.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
RehabMan,
Ok I think I did the DSDT patch and PM SSDT, I haven't patched any original SSDTs yet.

Opening Utilities folder and applications from dock is still a bit laggy, but touchscreen, brightness control and everything else seems to be working. I've attached IOReg

There is a problem with SMBIOS ("MacBookAir6"?), but X86PlatformPlugin is loaded, so CPU PM looks to be good (you still have to test it with AppleIntelInfo).

IGPU PM is not implemented.
 
Status
Not open for further replies.
Top