Contribute
Register

El Capitan (10.11.6) won't boot unless No Cache active.

Joined
Jun 8, 2016
Messages
2
Hi to you all!

I am quite new with Hackintoshs. I have tried to read and learn as much as possible, but still I am not understanding 100% of how everything works. So sorry if my question is unintelligent at some point.

So I had a very difficult time installing El Capitan: everything went smoothly until I installed Nvidia web drivers. After that a fiasco of prohibited-sign-logins came and I lost almost a week to it trying to resolve it. I then solved it with some tips and mainly with a borrowed config.plist. Sometimes it booted, sometimes not, but mostly not.

Then a very strange thing happened: since I have dualboot, every time I left Windows running and it updated, the next time I came to the office (where I have my Hackintosh) an El Capitan welcome screen was waiting for me with a successful boot. So every time after windows there was a successful El Capitan boot. After some experimenting I also discovered that if I need a successful boot I need to do the following - some steps may be unnecessary, but this worked every time:

- SHUT DOWN (not restart),
- choose Windows,
- mount EFI and do something inside in Win (adding then deleting sg in plist, then saving)
- then reboot into El capitan with -nv_disable=1

After I have found a fix for nvidia I managed to boot with Nvidia drivers too this way (but not in a normal way)

And then finally I discovered that I can shorten the whole process by simply turning caches off. This way I was able to add sound and imessage to my problematic Skylake config. Maybe caches were the problem all along the way and not the USB or Nvidia as I thought.

The message without cache off is:

OsxAptioFixDrv: Starting overrides for System/Library/CoreServices/boot.efi
Using relic block: no, hibernate wake: no
Error allocating XX pages at XXX alloc type 2
Couldn't allocate runtime area
Boot failed, sleeping for 10 seconds before exiting


the same with OsxAptioFix2Drv (tried both)

Sometimes a black screen ad restart instead of the message. These two were interchanging.


My config is:

MSI Z170-A PRO,
Intel Core i7-6700K 4000MHz 8MB LGA1151
GeForce GTX TITAN X, 12GB GDDR5 (384 Bit), HDMI, DVI, 3xDP,
Kingston 32GB DDR4 2400MHz Kit(2x16GB) HyperX Fury Black Series,
Sandisk 256GB 2,5" SATA3 Z400s Series for Mac,
Toshiba 480GB 2,5" SATA3 Q300 Series for Win,
FSP 600W 12cm Hyper 600,
Corsair Carbide Series 400R Black


So my question is:

Is there something wrong with booting always without cache?
Are there some suggestions on how can I repair it to boot normally?

Thanks in advance!

PS: after I get in the office I will post my plist and maybe some screenshots or other files you guys may request.
 
Joined
May 12, 2011
Messages
2,637
Motherboard
GA-X99M-Gaming 5
CPU
Intel Core i7-5930K
Graphics
MSI GTX 970 Gaming 4G
Mac
MacBook Pro
Mobile Phone
Android
Probably wouldn't have problem if you used the correct boot flags... (nv_disable=1) not (-nv_disable=1), same for (nvda_drv=1)...
 
Last edited:
Joined
Jun 8, 2016
Messages
2
sorry, I made the mistake only here in the description. On the Hack it is right. Also the flags are set by clover in the beginning and they also do not work.
 
Top