Contribute
Register

Eject Button in ML

Status
Not open for further replies.
Joined
Jan 26, 2012
Messages
118
Motherboard
GA-Z68A-D3H-B3
CPU
Intel i7 2600K Sandy Bridge
Graphics
NVIDIA GeForce GTX 660
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Thanks for the reply! I don't think this is a issue with the kexts. This is somethings else very pesky. Just RW, Play , and FW down work in itunes.
 
Joined
Nov 9, 2010
Messages
46
Motherboard
Asus Sabertooth 55i
CPU
Intel i7 860 @3.6GHz
Graphics
MSI GTX 760 Gaming
Mac
  1. MacBook Air
Classic Mac
Mobile Phone
  1. iOS
Ok, I have slightly changed each of the kexts in order to try to make them have priority while loading. You can give either of these new kexts a try to see if that works for you. I didn't see a problem with your DSDT, but if it still doesn't work, we can try putting your SATA device-id directly into the DSDT to see if that helps.

Dil83

Thank you very much Dil83! Your help is greatly appreciated! I'not home right now but I'll check these kext out tomorrow and let you know if they work for me.
 
Joined
Jun 20, 2010
Messages
20
Motherboard
Gigabyte P55M-UD2
CPU
i7 860
Graphics
EVGA 9800GT 1GB
Mac
Classic Mac
Mobile Phone
just installed AHCI_3rdParty_SATA.kext and everything works great now... :) Thanks!
 
Joined
Dec 19, 2010
Messages
263
Motherboard
Gigabyte GA-Z77X-UD5H - F16
CPU
i7-3770K
Graphics
HD4000
Mobile Phone
  1. iOS
Can someone try erasing a DVD-RW with Disk Utility (Especially with a Sony Optiarc) and see what happens to the disk name in the list once it is ejected?
 
Joined
Nov 9, 2010
Messages
46
Motherboard
Asus Sabertooth 55i
CPU
Intel i7 860 @3.6GHz
Graphics
MSI GTX 760 Gaming
Mac
  1. MacBook Air
Classic Mac
Mobile Phone
  1. iOS
Just installed the new IOAHCIBlockStorageInjector.kext and now DVD-Player and Eject work like a charm. As many people had this problem, this Injector would definitely be a nice addition to the new MultiBeast. Thanks again!
 
Joined
Dec 19, 2010
Messages
263
Motherboard
Gigabyte GA-Z77X-UD5H - F16
CPU
i7-3770K
Graphics
HD4000
Mobile Phone
  1. iOS
Ok, I have slightly changed each of the kexts in order to try to make them have priority while loading. You can give either of these new kexts a try to see if that works for you. I didn't see a problem with your DSDT, but if it still doesn't work, we can try putting your SATA device-id directly into the DSDT to see if that helps.

Dil83

I just noticed my ASMedia SATA III interface was showing up as eSATA which I assume means you took the info from the AHCI_3rdParty_SATA.kext eSATA kext?
 
Joined
Jan 9, 2011
Messages
319
Motherboard
ASUS Rampage III Extreme
CPU
W3680
Graphics
HD 7950
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
I just noticed my ASMedia SATA III interface was showing up as eSATA which I assume means you took the info from the AHCI_3rdParty_SATA.kext eSATA kext?

Actually, I accidentally uploaded the AHCI_3rdParty_SATA.kext that I have custom tailored to my system specifically.

Sorry about that!

Dil83

Here is the original one from MultiBeast with the DVD drive fix added. Everyone who downloaded AHCI_3rdParty_SATA.kext from my last post should re-download from here and reinstall. I omitted a lot of chipset info from the kext that didn't pertain to my system when I tailored it, so please dowload this latest one and use it instead. I also updated my other posts with the correct AHCI_3rdParty_SATA.kext, sorry about the mistake!
 

Attachments

  • AHCI_3rdParty_SATA.kext.zip
    2.3 KB · Views: 704
Joined
Jul 24, 2010
Messages
65
Motherboard
Intel NUC NUC7i5BNH (ESXi Host)
Graphics
Integrated/On-Board Graphics
Mac
  1. MacBook Pro
Actually, I accidentally uploaded the AHCI_3rdParty_SATA.kext that I have custom tailored to my system specifically.

Sorry about that!

Dil83

Here is the original one from MultiBeast with the DVD drive fix added. Everyone who downloaded AHCI_3rdParty_SATA.kext from my last post should re-download from here and reinstall. I omitted a lot of chipset info from the kext that didn't pertain to my system when I tailored it, so please dowload this latest one and use it instead. I also updated my other posts with the correct AHCI_3rdParty_SATA.kext, sorry about the mistake!

Thanks for posting the kext. This solved the problem for me! Now I can use the eject button and the dialog comes up when I insert a blank disc. Cheers...
 
Joined
Dec 19, 2010
Messages
263
Motherboard
Gigabyte GA-Z77X-UD5H - F16
CPU
i7-3770K
Graphics
HD4000
Mobile Phone
  1. iOS
Thanks again for the prompt attention!

Is it right I still see "Burn Support : Unsupported" in Disk Utility?

If I then Eject the disk inserted it changes to the second attachment.
 

Attachments

  • Screen Shot 2012-07-31 at 21.25.04.png
    Screen Shot 2012-07-31 at 21.25.04.png
    118.4 KB · Views: 416
  • Screen Shot 2012-07-31 at 21.28.16.png
    Screen Shot 2012-07-31 at 21.28.16.png
    114.5 KB · Views: 331
Joined
Aug 21, 2011
Messages
27
Motherboard
Gigabyte GA-EP45-DS3
CPU
Q9550
Graphics
GT640
@ dil83

Thanks for your fix! i am using a JMicron PCIe Card as eSATA Controller for my external SATA drives. How can i keep my external SATA drives showing up as external Drives? (orange Icons + ejectbutton)? Is this possible via plist edit?

(It's a JMB363 Card)
 
Status
Not open for further replies.
Top