Contribute
Register

Eject Button in ML

Status
Not open for further replies.
Joined
Jan 9, 2011
Messages
319
Motherboard
ASUS Rampage III Extreme
CPU
W3680
Graphics
HD 7950
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
Ok thanks, I will take a look when I get home (Real life getting in the way again!).

This is the file just downloaded...

That is the correct file. The only things I can think of are: It isn't loading properly; You have another kext injecting information for the SATA controller; Or your DSDT is interfering with it. I assume you make sure to repair permissions and rebuild caches when installing in S/L/E, OR repair permissions and rebuild mkext when installing in /Extra/Extensions?? I personally like to use "Kext Wizard" to do all that for me. Like I said, you can upload your DSDT and I can take a look at it if you think it's possibly the problem.

Dil83
 
Joined
Nov 9, 2010
Messages
46
Motherboard
Asus Sabertooth 55i
CPU
Intel i7 860 @3.6GHz
Graphics
MSI GTX 760 Gaming
Mac
  1. MacBook Air
Classic Mac
Mobile Phone
  1. iOS
Hi,

I followed the guide and installed the kext with Kext Wizard. The provided IOAHCIBlockStorageInjector.kext doesn't seem to change the DVD to an internal drive, as the player still doesn't start after installation and the Eject-Button doesn't work either. Permissions where repaired and caches rebuild.

Could you have a look at my DSDT.aml if it ist conflicting with the kext? You can download it here: http://www.maroder.de/files/DSDT.zip

That would be really great!
 
Joined
Jan 9, 2011
Messages
319
Motherboard
ASUS Rampage III Extreme
CPU
W3680
Graphics
HD 7950
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
Hi,

I followed the guide and installed the kext with Kext Wizard. The provided IOAHCIBlockStorageInjector.kext doesn't seem to change the DVD to an internal drive, as the player still doesn't start after installation and the Eject-Button doesn't work either. Permissions where repaired and caches rebuild.

Could you have a look at my DSDT.aml if it ist conflicting with the kext? You can download it here: http://www.maroder.de/files/DSDT.zip

That would be really great!

Ok, I have slightly changed each of the kexts in order to try to make them have priority while loading. You can give either of these new kexts a try to see if that works for you. I didn't see a problem with your DSDT, but if it still doesn't work, we can try putting your SATA device-id directly into the DSDT to see if that helps.

Dil83
 

Attachments

  • AHCI_3rdParty_SATA.kext.zip
    2.3 KB · Views: 711
  • IOAHCIBlockStorageInjector.kext.zip
    2 KB · Views: 584
Joined
Jul 13, 2011
Messages
269
Motherboard
Z370 Aorus Gaming 7-OpenCore
CPU
i9-9900K
Graphics
RX 580
I've used the two kext's from Lion (AppleAHCIPort and IOAHCIFamily) and now have both Optiarc's working.
Temp solution, I know.
I've made a backup of the originals though.

UPDATE!
I've just put those original two ML kexts back in and installed your latest modified AHCI_3rdParty from the previous post and it now seems to be working!
A much better solution to use your modified kext because updates shouldn't affect it.
Nice work!
 
Joined
Jul 9, 2011
Messages
38
Motherboard
Z77-DS3H
CPU
Intel Core i7-2600K
Graphics
HD3000
Mac
Classic Mac
Mobile Phone
  1. Android
yeah the fix works perfectly... i have z68x-ud3h-b3 and apple original wired keyboard...
 
Joined
Jan 26, 2012
Messages
118
Motherboard
GA-Z68A-D3H-B3
CPU
Intel i7 2600K Sandy Bridge
Graphics
NVIDIA GeForce GTX 660
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Same issue along with iTunes controls ;/ . Trying fix
 
Joined
Dec 19, 2010
Messages
272
Motherboard
Gigabyte GA-Z77X-UD5H - F16
CPU
i7-3770K
Graphics
HD4000
Mobile Phone
  1. iOS
Ok, I have slightly changed each of the kexts in order to try to make them have priority while loading. You can give either of these new kexts a try to see if that works for you. I didn't see a problem with your DSDT, but if it still doesn't work, we can try putting your SATA device-id directly into the DSDT to see if that helps.

Dil83

Working great now here along with ICH10 showing in System Information, many thanks!

EDIT: Can someone try erasing a DVD-RW with Disk Utility (Especially with a Sony Optiarc) and see what happens to the disk name in the list once it is ejected?
 
Joined
Jan 26, 2012
Messages
118
Motherboard
GA-Z68A-D3H-B3
CPU
Intel i7 2600K Sandy Bridge
Graphics
NVIDIA GeForce GTX 660
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Not working... I see AHCIinjector.kext in S/L/E Should I remove that too?



EDIT GOT WORKING THANKS!!!!

Now I just need play rewind and FF to work ( F7 F8 F9)
 
Status
Not open for further replies.
Top