Contribute
Register

Eglobal S200 Nuc Intel i7 8750H / Mini PC Compatible?

Joined
Jun 4, 2020
Messages
11
Motherboard
C236
CPU
8850H
Graphics
UHD630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
And after this, your system runs with full graphic acceleration or with vga mode? If you open the system overview you have more then 8mb Ram for the UHD630?
My graphic acceleration is OK. VideoProc shows the hardware acceleration is on. The system info shows the graphic is UHD 630 2048MB
 
Last edited:
Joined
Apr 15, 2019
Messages
147
Motherboard
S200 Eglobal
CPU
i7-8850H/C230
Graphics
UHD630
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
Ok, the process is the same experience (=bad) like the previous update. it took for ages and without screen.

Looks again like a framebuffer issue, so will try to revert back to 10.15.4 and need to figure out how this should be patched to get into 10.15.5 with screen.
 
Joined
Apr 26, 2020
Messages
18
Motherboard
Eglobal S200
CPU
i7 8850
Graphics
IGFX630
Ok, the process is the same experience (=bad) like the previous update. it took for ages and without screen.

Looks again like a framebuffer issue, so will try to revert back to 10.15.4 and need to figure out how this should be patched to get into 10.15.5 with screen.
My best try before now was without hardware support for the UHD630. The Update went smooth and with screen. that version is now my try and error version for efi settings. and the best, it lays on an external usb-drive, so i need only one reboot for 10.15.4 to come back alive .
 
Joined
Apr 15, 2019
Messages
147
Motherboard
S200 Eglobal
CPU
i7-8850H/C230
Graphics
UHD630
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
My best try before now was without hardware support for the UHD630. The Update went smooth and with screen. that version is now my try and error version for efi settings. and the best, it lays on an external usb-drive, so i need only one reboot for 10.15.4 to come back alive .
Smart. I thought to have fixed the problem, but not the case. Seems a lot of people have it with the uhd630, looks like we need to change ID for the IGPU and find the right index etc for framebuffer. https://github.com/dortania/OpenCore-Desktop-Guide/issues/53
One comment there:‘Multiple users have reported that changing the platform id from 07009B3E to 00009B3E was necessary after the 10.15.5 update as the screen would just be black.’ If it is just the ID then it’s easy, but I have my doubts since I used this ID before to get back in 10.15.4.

For me DP also doesn’t work at the moment unfortunately.

the strange thing is that I reproduced the patch to match Shumbola’s patch in clover, his machine is now on 10.15.5 without issues, so don’t really get it.
 
Last edited:
Joined
Apr 15, 2019
Messages
147
Motherboard
S200 Eglobal
CPU
i7-8850H/C230
Graphics
UHD630
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
I'm back on 10.15.4 thanks to Time-Machine :) Easy backup. I'l first fix the framebuffer on this version and then move over to 10.15.5 and then to Opencore 0.5.9.
 
Joined
Apr 21, 2019
Messages
134
Motherboard
Eglobal S200
CPU
i7-8750H
Graphics
UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I'm back on 10.15.4 thanks to Time-Machine :) Easy backup. I'l first fix the framebuffer on this version and then move over to 10.15.5 and then to Opencore 0.5.9.
After using OpenCore for a while do you see any advantage over Clover, if any?
 
Joined
Apr 15, 2019
Messages
147
Motherboard
S200 Eglobal
CPU
i7-8850H/C230
Graphics
UHD630
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
After using OpenCore for a while do you see any advantage over Clover, if any?
I didn't use Clover for a long time on this machine, results are probably similar. In my opinion Clover is a bit messy to work with, Opencore is more straigth forward and the experience is cleaner but the learning curve is quite steep to begin with. Opencore also looks a bit less forgiving, but the main issues I had is with the IGPU which for the UHD630 is not uncommon for a lot of systems. Since the S200 is mainly a laptop in terms of components it is also sometimes less straightforward to work with or patch, but this is similar in Clover I would say.
 
Joined
May 29, 2020
Messages
22
Motherboard
S200 eGlobal
CPU
i7 8750H
Graphics
Intel UHD 630
Mac
  1. Mac mini
In OC 0.5.9 "vault" value need to be "optional" ?
Someone could share a working OC 0.5.9 config.plist just to compare some values ?
 
Last edited:
Joined
Apr 15, 2019
Messages
147
Motherboard
S200 Eglobal
CPU
i7-8850H/C230
Graphics
UHD630
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
In OC 0.5.9 "vault" value need to be "optional" ?
Someone could share a working OC 0.5.9 config.plist just to compare some values ?
I’m not there yet, still struggling with framebuffer issue on this machine. I ordered a mini DP to Dp cable to get rid of the headache HDMI is giving me.
 
Joined
Jun 4, 2020
Messages
11
Motherboard
C236
CPU
8850H
Graphics
UHD630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I’m not there yet, still struggling with framebuffer issue on this machine. I ordered a mini DP to Dp cable to get rid of the headache HDMI is giving me.
maybe you could roll back two Kexts of video or change AAPL,ig-platform-id to 00009B3E to fix it
ref:https://www.insanelymac.com/forum/t...a-z370n-wifi-i7-8700k-uhd-630-catalina-10155/

Replace AppleIntelCFLGraphicsFramebuffer.kext in /S/L/E with 10.15.4 AppleIntelCFLGraphicsFramebuffer.kext

  1. sudo spctl --master-disable
  2. sudo mount -uw /
  3. sudo killall Finder

    Replace the kext
  1. sudo chown -v -R root:wheel /System/Library/Extensions
  2. sudo touch /System/Library/Extensions
  3. sudo chmod -v -R 755 /Library/Extensions
  4. sudo chown -v -R root:wheel /Library/Extensions
  5. sudo touch /Library/Extensions
  6. sudo kextcache -i /
 

Attachments

  • 10.15.4.zip
    1.4 MB · Views: 16
Top