Contribute
Register

EFI Agent v1.3.2 (menu bar utility)

Joined
Jun 22, 2020
Messages
25
Motherboard
Gigabyte Aorus B360 Gaming 3
CPU
i7-9700K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. iOS
I use hackintool to mount and show disks etc. Does this tool has any additional features?
 

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,994
Motherboard
GB Z490 Vision G
CPU
i9 10850K OC @ 5.2 GHz
Graphics
Vega 64 LC + HD 630
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
I use hackintool to mount and show disks etc. Does this tool has any additional features?

@tech1eguy,

EFI Agent is basically the same "Disks" module from Hackintool but runs as a menu bar utility/icon and uses minimal resources meaning that it's always there if you need it without having to load an app every time you want to mount/unmount a volume.

Very handy if you work a lot with EFI partitions (or need to mount/un-mount any volume for that matter)

Cheers
Jay
 
Last edited:
Joined
Jul 11, 2012
Messages
462
Motherboard
Gigabyte GA Z68XP-UD3
CPU
i7 3770
Graphics
GT 210
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. Android
@tech1eguy,

EFI Agent is basically the same "Disks" module from Hackintool but runs as a menu bar utility/icon and uses minimal resources meaning that it's always there if you need it without having to load an app every time you want to mount/unmount a volume.

Very handy if you work a lot with EFI partitions (or need to mount/un-mount any volume for that matter)

Cheers
Jay
Hi Jay!
As I mentioned in a former post, I have no contextual menu for mount/unmount, neither in EFI Agent nor in Hackintool: is this feature supposed to work in El Capitan (my current OS) or only in recent OSes? :confused:
 

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,994
Motherboard
GB Z490 Vision G
CPU
i9 10850K OC @ 5.2 GHz
Graphics
Vega 64 LC + HD 630
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
I have no contextual menu for mount/unmount, neither in EFI Agent nor in Hackintool: is this feature supposed to work in El Capitan (my current OS) or only in recent OSes? :confused:

@Nodarkthings,

I'm not sure why you have no context menu for mount/unmount, thats an issue that i have not personally seen, it's possible that it could be because you running an older version of MacOS as El Capitan pre-dates the release of both EFI Agent and Hackintool.

Best bet would be to direct your question to @headkaze, who should be able to confirm the situation and if it's possible help you debug the issue.

Cheers
Jay
 
Joined
Jun 20, 2014
Messages
1,017
Motherboard
Gigabyte Aero 15X v8-BK4K4P
CPU
i7-8750H
Graphics
UHD 630 / GTX 1070
Hi Jay!
As I mentioned in a former post, I have no contextual menu for mount/unmount, neither in EFI Agent nor in Hackintool: is this feature supposed to work in El Capitan (my current OS) or only in recent OSes? :confused:
The context menu only shows when you right-click an item in the "Partition Scheme" list. It will not show up if you right-click an item in the "EFI Partitions" list.
 
Joined
Jul 11, 2012
Messages
462
Motherboard
Gigabyte GA Z68XP-UD3
CPU
i7 3770
Graphics
GT 210
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. Android
The context menu only shows when you right-click an item in the "Partition Scheme" list. It will not show up if you right-click an item in the "EFI Partitions" list.
Thanks but this doesn't work, I've tried multiple times, everywhere in the "Partition Scheme" list. :( Are you sure it works in 10.11? I've tried in a clean account too, with no other menu app or whatever...
 
Joined
Jun 20, 2014
Messages
1,017
Motherboard
Gigabyte Aero 15X v8-BK4K4P
CPU
i7-8750H
Graphics
UHD 630 / GTX 1070
Thanks but this doesn't work, I've tried multiple times, everywhere in the "Partition Scheme" list. :( Are you sure it works in 10.11? I've tried in a clean account too, with no other menu app or whatever...
I've not tested in 10.11. Try running Hackintool from Terminal and see if you get an exception error when you right-click the "Partition Scheme" list. If not I don't know what the problem is but most likely it's a change in the API I'm unaware of.
 
Joined
Jul 11, 2012
Messages
462
Motherboard
Gigabyte GA Z68XP-UD3
CPU
i7 3770
Graphics
GT 210
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. Android
I've not tested in 10.11. Try running Hackintool from Terminal and see if you get an exception error when you right-click the "Partition Scheme" list. If not I don't know what the problem is but most likely it's a change in the API I'm unaware of.
Done. Nothing happens and nothing shows in the Console or Terminal. Checked with my Magic Mouse (in case it's something with my trackball), same result.
Checked in Mojave: all works in EFI Agent as well as in Hackintool.
I think we can assume it doesn't work in 10.11. ;)
 
Top