Contribute
Register

Easy Yosemite Clover USB Installer

Status
Not open for further replies.
Joined
May 12, 2011
Messages
2,594
Motherboard
GA-X99M-Gaming 5
CPU
i7-5930K
Graphics
GTX 970
Mac
  1. MacBook Pro
Classic Mac
  1. Color Classic
Mobile Phone
  1. Android
Yosemite Final - Clover USB Installer.

* This process assumes you are familiar with Clover...

Format a 8GB+ USB with GUID partition mapping and name it Install.
Insure the OS X Yosemite.app is in your Application folder.

In terminal run the following script.

Code:
sudo /Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume  /Volumes/Install --applicationpath /Applications/Install\ OS\ X\ Yosemite.app --nointeraction

This will take several minutes so be patient, the script will notify you when complete.

install.png

Now Install Clover r2696 (or newer) to the Install USB. Clover r2953 or newer Recommended!
Copy FakeSMC and Network kexts to /EFI/Clover/kexts/10.10 (you’ll have to create the 10.10 folder}
Boot USB to Clover, highlight "Install OS X Yosimite" and hit the spacebar, choose "with injected kext”
and install Yosemite. Re-boot to USB and select your SSD or HD, hit the spacebar and again
choose “with injected kext” to complete the installation.

Install Clover to your boot drive. install your kexts to S/L/E or use Clover to inject kexts from EFI/Clover/kexts/10.10
Done


Please post Clover questions here.

Thanks Clover dev team. Clover

-------------------------------------------------------------

EDIT:
For anyone having a problem with this process:

You might try using the HFSPlus rather than VBoxHfs-64, link below. Also be certain you're booting from a USB 2.0 port.

https://www.dropbox.com/s/3vt9cptg86xuxvf/HFSPlus.efi.zip?dl=0

EDIT: you might also try the latest Clover version r2957

https://www.dropbox.com/s/xh53hy6ex0...7.pkg.zip?dl=0 as it contains a new version of VBoxHfs-64.efi
 
Joined
Nov 22, 2012
Messages
27
Motherboard
OSX 10.10 Yosemite
CPU
Core 2 Quad Q8400
Graphics
MSI GeForce GTX 650 OC 1Gb
Mac
Classic Mac
Mobile Phone
  1. iOS
Trying this right now!:)

Edit 1: If your mac is running in any language other than english, modify the script with the proper name for the installer app, otherwise it won't work.
 
Joined
Jun 12, 2013
Messages
15
Motherboard
GA-H97M-D3H
CPU
i5-4690
Graphics
RX570 (HD4600)
Working script:

Code:
sudo /Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume  /Volumes/Install --applicationpath /Applications/Install\ OS\ X\ Yosemite.app --nointeraction
 
Joined
May 12, 2011
Messages
2,594
Motherboard
GA-X99M-Gaming 5
CPU
i7-5930K
Graphics
GTX 970
Mac
  1. MacBook Pro
Classic Mac
  1. Color Classic
Mobile Phone
  1. Android
Clover is not giving me the option to install "with injected kexts".

I only see an option to install "without injected kexts"

Any ideas?
That's because Clover determined Fake was in S/L/E. Just boot normally then...
 
Joined
Feb 21, 2014
Messages
6
CPU
Intel i5 4670k
Graphics
EVGA GTX 760
Mac
Classic Mac
Mobile Phone
Working script:

Code:
sudo /Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume  /Volumes/Install --applicationpath /Applications/Install\ OS\ X\ Yosemite.app --nointeraction

This script is not working for me.

"sudo: /Applications/Install OS X Yosemite.app/Contents/Resources/createinstallmedia: command not found"

This is the error I am getting in Terminal
 
Joined
Jun 18, 2012
Messages
1
Motherboard
pc
CPU
intel
Graphics
nvidia
Mac
Classic Mac
Mobile Phone
Clover does not seem to be able to boot it. Clover starts but when try to boot installer, nothing happens... or do you have to have real mac for this?
 
Joined
Feb 1, 2013
Messages
22
Motherboard
MSI Z87-G45 GAMING
CPU
i7 4770k
Graphics
AMD Radeon 7870
Mac
Classic Mac
Mobile Phone
Clover does not seem to be able to boot it. Clover starts but when try to boot installer, nothing happens... or do you have to have real mac for this?

same thing happens to me I get to the boot screen, try to hit enter on the "yosemite installer" and nothing happens. When I hit space there wasn't an option for "with injected kexts" only "without"
 
Joined
May 12, 2011
Messages
2,594
Motherboard
GA-X99M-Gaming 5
CPU
i7-5930K
Graphics
GTX 970
Mac
  1. MacBook Pro
Classic Mac
  1. Color Classic
Mobile Phone
  1. Android
I have retested this process twice again, once using a Kingston USB 8gig and another with a PNY USB 16gig. They both work quite nicely here on a Asus Z87 Gryphon, Asus Z97M-Plus, and a AsusZ97I-Plus. Without more info, this is like fixing something that's not broke... If you can provide any more info I'll continue to test...

You might try using the HFSPlus rather than VBoxHfs-64, link below. Also be certain you're booting from a USB 2.0 port.

https://www.dropbox....us.efi.zip?dl=0

EDIT: you might also try the latest Clover version r2957

https://www.dropbox.com/s/xh53hy6ex0mirff/Clover_v2k_r2957.pkg.zip?dl=0 as it contains a new version of VBoxHfs-64.efi
 
Joined
Mar 29, 2011
Messages
848
Motherboard
ASRock X99 Extreme6
CPU
E5-2690 v4
Graphics
Radeon VII
Boot USB to Clover, highlight your Install USB, hit the spacebar, choose “with injected kext”
Install Yosemite. Boot to USB again and select your Yosemite HD or SSD "with injected kexts" to complete the installation.

Not quite right. When you boot the second time and it completes the installation, you still select "Install OS X Yosemite" from the USB, not the hard drive. In my case, it was the only option to choose.
 
Status
Not open for further replies.
Top