Contribute
Register

[Easy Guide] ML: UEFI HDMI Audio

Status
Not open for further replies.

toleda

Moderator
Joined
May 19, 2010
Messages
22,934
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
I have to say I am pretty much stunned by this work.
Thanks.
The ssdt complier problem is just that, different compilers do different things; the binary is valid. The interoperability credit goes to Nvidia, NVCAP instead of framebuffers and wildcard device-id verification.
 
Joined
Sep 23, 2011
Messages
78
Motherboard
I didn't read
CPU
the RULES
Graphics
so ignore me
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
i ve a questio can i fix hdmi audio in my gt210en using this instruction ?
i have a p67a ud4 b3, cpu i3 2100 graphics GT210en silent
thanks.
 
Joined
May 14, 2011
Messages
10
Motherboard
ASUS P8P67 DELUXE (REV 3.0)
CPU
Intel Core i7-2600K Sandy Bridge 3.4GHz (3.8GHz Turbo Boost) LGA 1155
Graphics
EVGA 01G-P3-1351-KR GeForce GTS 450
Mac
Classic Mac
Mobile Phone
Please help guys!

Specs:

ASUS P8PO67 DELUXE REV 3 BIOS 2103
Intel Core i7 2600-k
nVidia GT430

Install osX with User DSDT, ALC889, and AppleIntelCPUPowerManagement.

I followed the instructions here with the uefi1 patch, but got an error. After reboot I still have no audio. Can someone take a look and see what I did wrong? Thanks!!

https://www.dropbox.com/sh/zso271sjwzrhj1r/qpOCUwR5_e
 

toleda

Moderator
Joined
May 19, 2010
Messages
22,934
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Joined
May 14, 2011
Messages
10
Motherboard
ASUS P8P67 DELUXE (REV 3.0)
CPU
Intel Core i7-2600K Sandy Bridge 3.4GHz (3.8GHz Turbo Boost) LGA 1155
Graphics
EVGA 01G-P3-1351-KR GeForce GTS 450
Mac
Classic Mac
Mobile Phone
Thanks for the help! Which slot should it be in?
 
Joined
Feb 13, 2011
Messages
6
Motherboard
10.8.4
CPU
i7 2600K @ 42GHz
Graphics
EVGA GTX650 TI
Mac
Classic Mac
Mobile Phone
Hi Toleda!

Nice work here, greeting from Brazil!

Could you help me please ?

I follow this guide to have dual video cards and HDMI working, now I have HDMI works on Nvidia card, but onboard video (HD3000) not working, no kext load.

Here is my procedure and files:

MB: Gigabyte GA-Z68XP-UD3 (REV. 1.0)
BIOS: UEFI U1J (2013/03/06)
CPU: Intel Core I7 2600K @ 4.2 GHz
COOLER: Akasa Venom (AK-CCX4002HP V2)
RAM: Kingston 2x4GB 1600Mhz (KHX1600C9D3X2K2_8GX)
VGA: EVGA GTX650 TI 1GB (01G-P4-3652-KR)
HDD: WD Caviar Black 640GB (WD6402AAEX) @ SATA 0
PSU: Corsair 600W (CMPSU-600CXV2)

SEQUENCE:

Setup UEFI Bios:
-Load Optimised Defaults
-SATA Mode Selection AHCI
-Init Display First IGFX
-Internal Graphics Enabled
-Internal Graphics Memory Size 64Mb
-DVMT Total Memory Size MAX
-XHCI Hand Off Enabled
-EHCI Hand Off Enabled
-High Precision Event Timer Enabled


-Clean install 10.8.4 using Unibeast
-Restart
-Boot via Unibeast pendrive


-Install Multibeast 5.4.3
-User DSDT or DSDT-Free Installation
-Audio Realtek ALC889 With DSDT
-Disk 3rd Party eSATA
-FakeSMC v.5.2.725 Plugins
-HWMonitor Application
-USB 3.0 - Universal
-Realtek - Lnx2Mac RealtekRTL81xx v0.0.90
-Boot Options 1080p Display
-Boot Options GraphicsEnabler=No
-System Definitions Mac mini 5,1
-SSDT Sandy Bridge Core i7

This is my org.chameleon.Boot.plist
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>GenerateCStates</key>
<string>Yes</string>
<key>GeneratePStates</key>
<string>Yes</string>
<key>GraphicsEnabler</key>
<string>No</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>darkwake=0</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>Timeout</key>
<string>2</string>
<key>UseKernelCache</key>
<string>Yes</string>
<key>Graphics Mode</key>
<string>"1920x1080x32"</string>
</dict>
</plist>


Using "[Guide] ML-uefi-hdmi_audio_dsdt_edits_v2.0 .pdf"

-MaciASL/File/New from ACPI/DSDT

-Patch / UEFI-Clean Compile
-Compile: 1 Warning: Line 11504 Code 1099 Unknown reserved name (_WDG)

-Patch Desktop-HD4K/HD3K/AMD/Nvidia-A3
-Compile: 1 Warning: Line 11504 Code 1099 Unknown reserved name (_WDG)

-Save /Extra/DSDT.aml
-Restart

-Disk Utility - Repair Disk Permissions
-Restart

GTX650 HDMI Audio and video works, but onboard HD3000 no, showing spdisplays_display (no kext loaded - device ID 0x0122).
 

Attachments

  • Archive.zip
    963.1 KB · Views: 71

toleda

Moderator
Joined
May 19, 2010
Messages
22,934
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
I follow this guide to have dual video cards and HDMI working, now I have HDMI works on Nvidia card, but onboard video (HD3000) not working, no kext load.
The dsdt edits appear correct. The IOReg shows no HDMI audio and the dsdt is not installed.

This step was not done:
22. MaciASL/File/Save As... /ACPI Machine Language Binary/Extra/dsdt.aml (add extension)

Reply with an IOReg with the dsdt installed.
 
Joined
Feb 13, 2011
Messages
6
Motherboard
10.8.4
CPU
i7 2600K @ 42GHz
Graphics
EVGA GTX650 TI
Mac
Classic Mac
Mobile Phone
Thanks for your quick reply!

I repeated the steps and installed the DSDT in /Extra folder. But same things

Attached IOReg with the dsdt.aml installed
 

Attachments

  • IOReg with DSDT.zip
    668.2 KB · Views: 80
Status
Not open for further replies.
Top