Contribute
Register

[Easy Guide] ML: UEFI HDMI Audio

Status
Not open for further replies.
Joined
Jul 30, 2012
Messages
10
Motherboard
Asus H81M-plus
CPU
Intel Celeron G1820
Graphics
nVidia GT620
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
I installed VodooHDA for audio ALC662 that works well and now I find 4 HDMI audio outputs and a single but still works with the audio icon is not adjustable, I extracted the dsdt with windows and filled with 2 patches applied.
View attachment Archivio2.zip
 

toleda

Moderator
Joined
May 19, 2010
Messages
22,935
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
I installed VodooHDA for audio ALC662 that works well and now I find 4 HDMI audio outputs and a single but still works with the audio icon is not adjustable, I extracted the dsdt with windows and filled with 2 patches applied.
View attachment 64848
You do not need any dsdt edits for Voodoo. I have never used Voodoo. This thread is for AppleHDA HDMI audio. Your post is off topic.
 
Joined
Jul 30, 2012
Messages
10
Motherboard
Asus H81M-plus
CPU
Intel Celeron G1820
Graphics
nVidia GT620
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
My answer is not off-topic because you asked me to turn on the sound, which is the internal ALC662 and I downloaded the kext, I thought it was first necessary to enable this and then the audio hdmi, maybe I misunderstood me, pci video card instead as I have a gigabyte geforce 210, what should I do to do to make good the audio hdmi? I'm interested in this.
 

toleda

Moderator
Joined
May 19, 2010
Messages
22,935
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
My answer is not off-topic because you asked me to turn on the sound,
I asked you to enable audio. You did without using AppleHDA.kext. Voodoo/Voodoo HDMI audio is off topic.
 
Joined
Sep 2, 2011
Messages
211
Motherboard
GA-Z170N-Gaming 5
CPU
I7-6700K
Graphics
EVGA GTX 980 Ti FTW
Thank you, Toleda! I appreciate the work you do. I followed your guide and now have HDMI audio working on my latest machine.

Asus P8Z77-M > Gigabyte 6850 (Lotus FB) > Asus VE278 monitor > Line out from monitor to 2.1 speaker system.

I would have normally been satisfied without HDMI audio, but the popping from the ALC887 onboard sound prompted me to find another solution.

Thank you for the guide and for your MacIASL patch source!
 
Joined
Jul 30, 2013
Messages
48
Motherboard
GIGABYTE GA-Z77-DS3H
CPU
i3-3245
Graphics
PNY GTX 650 1GB
Mac
Classic Mac
Mobile Phone
Hi. I am trying to get HDMI audio working on my GA-Z77-DS3H (i3-2540). I am using the instructions at the beginning of this thread. However I am stuck on #1, lol.

Copy Extra/dsdt.aml to Desktop

Extra/dsdt.aml doesn't seem to exist on my system. I selected no dsdt on my
multibeast 5.4.3. I am probably just looking past something, but would appreciate any help. Thanks.

EDIT: Sorry, somehow I missed the sticky just below this. So I figured out how to do this using the instructions there.
 
Joined
Jul 30, 2013
Messages
48
Motherboard
GIGABYTE GA-Z77-DS3H
CPU
i3-3245
Graphics
PNY GTX 650 1GB
Mac
Classic Mac
Mobile Phone
It works! :headbang:Turns out the instructions right here were exactly what I needed. Thanks for your hard work!

Motherboard: GA-Z77-DS3H
Firmware Version: F9
Processor: i3-3245
Graphics: Intel HD 4000 Realtek ALC887
OS: 10.8.4
 
Joined
May 27, 2010
Messages
2,381
Motherboard
Dell Optiplex 9030 All in One
CPU
i5-4690K
Graphics
HD 4600
Mac
  1. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
:clap:

I have to say I am pretty much stunned by this work.

I have been playing with my new Haswell board (Zotac H87 ITX) and as the graphics are not yet working - I am on the temporary 10.8.4 method - I am using my old GT 240 card on HDMI. I used the MaciASL patch you provided assuming it would not work on such an old Desktop GPU and then on reboot I found my HDMI audio was working. No hassle, no fuss just working.

Bear in mind too that my DSDT does not even have Device (GFX0) in it, as that is buried in an SSDT which has compile errors. SO I am amazed this works.

Again, thanks.
 
Status
Not open for further replies.
Top