Contribute
Register

Dual boot with Sierra and UNRAID

Joined
Jan 16, 2014
Messages
1
Motherboard
GA- Z77 D3H
CPU
I7 3770K
Graphics
GTX 760
Mac
Classic Mac
Mobile Phone
I have a special setup at the moment where I use my main powerful computer as a NAS and occasionally as an image/video editing device or gaming pc.
I'm running Sierra (hackingtosh) and I'm using the latest version of the Clover bootloader.
For NAS I'm using UNRAID.

UNRAID has EFI support since version 6.4, I'm running 6.5. I can boot from the UNRAID USB Flash drive using UEFI (when pressing down F12 in the beginning). However I can't seem to start the UNRAID EFI boot partition from Clover.

Clover can recognise UNRAID as a Linux OS but when I select it it only shows the Linux icon and nothing ever boots.

I checked the forum for people trying to dual boot with UNRAID but all the posts are for UNRAID with legacy boot. Now that they have EFI boot I can't find anything on the matter.

I downloaded the Clover Configurator and tried selecting the UNRAID partition as the first partition to boot, I set GUI options Linux, Kernel and Legacy to true. I set the default loader in Boot section to /EFI/boot/bootx64.efi.

Nothing seems to work! I would like Clover to auto boot into UNRAID and have the option during boot to boot into my Sierra partition. I know UNRAID can do GPU passthrough and all but my CPU is a 3770k i7 and my motherboard is a Gigabyte z77-UH3 so I don't have support for IOMMU groups and thus no GPU passthrough. So if I want to use my device for editing the only option is to boot an actual OS, not a VM.

I added a picture with the contents of the EFI partition and the current settings.

Has anyone tried to do this dual boot yet? It has to be possible! It's just a linux distro on a USB Flash drive and it has a EFI boot folder.

Thanks to anyone who took the time to read this =)
 

Attachments

Top