Contribute
Register

Dual boot Win 10 & Sierra - Sierra suddenly hangs at loading screen

Joined
Nov 6, 2017
Messages
30
Motherboard
ASUS ROG Maximus IX Hero
CPU
Intel i7-7700k
Graphics
EVGA GeForce GTX 1080 Ti SC2
Mac
MacBook Pro
Mobile Phone
Android
Hi all, I recently UEFI installed Win 10 on my Hackintosh desktop on a separate drive to my Sierra install following this guide: https://pastebin.com/DxEufkVp

I could boot into both OS's from my mobo boot menu by pressing F8 at startup. It was all working great for a few days, but then suddenly OS X started hanging at the loading bar.

OS X DOES boot when the Win 10 drive is unplugged.

I can't explain what happened. I had been installing drivers on Win 10, copying files over from one OS to the other using an ExFAT drive, booting them both alternately. I also switched around the boot order in the BIOS. I did nothing that seemed suspect at all.

Does anyone know why this is happening?
 
Joined
Nov 6, 2017
Messages
30
Motherboard
ASUS ROG Maximus IX Hero
CPU
Intel i7-7700k
Graphics
EVGA GeForce GTX 1080 Ti SC2
Mac
MacBook Pro
Mobile Phone
Android
I seem to have fixed this. For posterity, what I had apparently done was change the boot order, which was:

Windows Boot Manager (P6: ST4925935)
UEFI OS (M2: Samsung SSD 960 EVO 500GB)
M2: Samsung SSD 960 EVO 500GB

to:

UEFI OS (M2: Samsung SSD 960 EVO 500GB)
Windows Boot Manager (P6: ST4925935)
M2: Samsung SSD 960 EVO 500GB

Obviously what I was trying to do was make it so OS X would be the default boot. What I didn't realise was that putting the Windows boot in between the two Samsung 960 EVO boots (both referring to the same OS, but presumably representing the EFI partition and the OS itself) seemed to have messed up the OS X boot. I finally got what I wanted by doing this:

UEFI OS (M2: Samsung SSD 960 EVO 500GB)
M2: Samsung SSD 960 EVO 500GB
Windows Boot Manager (P6: ST4925935)

Problem solved (I think)!
 
Top