Contribute
Register

Dual Boot Lion And XP?

Status
Not open for further replies.
Joined
Apr 4, 2011
Messages
35
Motherboard
GA-Z77N-WIFI
CPU
I7
Graphics
Built-In
I am trying to dual boot Lion and XP using 2 drives
The first drive (listed as the boot drive in the BIOS) is loaded with Lion and Multibeast 4.02. The second drive with XP. My boot screen shows Lion and XP as boot options. If I choose Lion everything works as expected and the system boots into Lion. If I choose XP I get a blank screen and flashing cursor.
To boot XP I need to go to my bios boot screen and choose the XP drive.

I'm assuming Chimera is having an issue with XP. Is there away around this?

Thanks
BTW The second drive with XP was added after my Lion install. I then had to go back and reinstall Multibeast to enable lion to boot off the H/D.
 
Joined
Mar 10, 2011
Messages
12
Motherboard
Gigabyte GA-Z68X-UD4-B3
CPU
i5-2400K
Graphics
GT 240
I had similar issue with Windows 7, but I choose the default system partition in chimera, and it booted with no problems. I'm not sure about windows xp though. :mrgreen:
 
Joined
Sep 17, 2011
Messages
58
Motherboard
Mavericks 10.9, Mt Lion 10.8, Lion 10.7.4
CPU
i5 2500K x 3
Graphics
Radeon HD 6xxx
Mac
Classic Mac
Mobile Phone
  1. iOS
I am having problems setting up a dual boot myself. I took an existing machine running Windows 7 64 and have successfully set it up running Lion 10.7.1.

Lion and Windows are setup on separate drives, with the machine currently booting off of the Lion drive. Both drives are present in Chimera but when I attempt to boot off the Windows drive, it starts the loading windows screen, followed by a quick blue screen of death flash and then the cpu resets itself.

I know the Windows drive is in working order because if I change the bios settings back to mobo default and change the boot drive to the windows drive, it fires up without a problem. I have to run check dump on windows to find the trouble code. Any insight would be much appreciated.
 

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
23,225
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
ahallasjr said:
I am trying to dual boot Lion and XP using 2 drives
The first drive (listed as the boot drive in the BIOS) is loaded with Lion and Multibeast 4.02. The second drive with XP. My boot screen shows Lion and XP as boot options. If I choose Lion everything works as expected and the system boots into Lion. If I choose XP I get a blank screen and flashing cursor.
To boot XP I need to go to my bios boot screen and choose the XP drive.

I'm assuming Chimera is having an issue with XP. Is there away around this?

Thanks
BTW The second drive with XP was added after my Lion install. I then had to go back and reinstall Multibeast to enable lion to boot off the H/D.
First, you need to enable AHCI in the WinXP. It is not enabled by default and your XP drive will not boot unless you either change the SATA ports in BIOS back to IDE or enable AHCI. See http://expertester.wordpress.com/2008/0 ... indows-xp/ for a how-to-do-it guide.
 
Joined
Sep 17, 2011
Messages
58
Motherboard
Mavericks 10.9, Mt Lion 10.8, Lion 10.7.4
CPU
i5 2500K x 3
Graphics
Radeon HD 6xxx
Mac
Classic Mac
Mobile Phone
  1. iOS
SUCCESS! Woooooooo! :headbang: G g g genius! Thank you for your help, I have been trying to research this for a few days. I wish there would have been a hey don't forget about this foundational piece of information on one of the guides. I am running Windows 7 tho, not XP. Here is the MS KB article to load AHCI drivers in 7: http://support.microsoft.com/kb/922976
 
Status
Not open for further replies.
Top