Contribute
Register

DSDT Help Needed: Lenovo Thinkstation D20

Status
Not open for further replies.
Joined
Sep 15, 2013
Messages
20
Motherboard
Lenovo D20
CPU
2x X5650
Graphics
nVidia 670 4GB
Mac
Classic Mac
Mobile Phone
Hi all,

First post here. Long time Mac user, but I'm new to the hackintosh scene. Just got a Lenovo Thinkstation D20, 2x Xeon X5650, 48G ECC RAM, nVidia GTX 670 4GB. I've done the requisite searching and googling, which means I've:

1. Downloaded Unibeast and made the bootable USB for Mountain Lion
2. Generated a copy of my raw (unpatched) DSDT
3. Downloaded Multibeast
4. Downloaded MaciASL and looked into patching the DSDT

However, all the reading I've done on patching a DSDT points to downloading the patch from a repo and then applying it in MaciASL. I cannot locate a patch for the DSDT (I've searched tonymacx86 and other sites), or a pre-patched DSDT for the Lenovo Thinkstation D20 anywhere, so I am confused as to where to go from here.

I am attaching a copy of my unpatched DSDT file to this post. I'll take what help I can get, but what I'd appreciate even more than simply sending me a patched file would be for someone to teach me to fish here- as in how to go about patching the DSDT in MaciASL when no patch currently exists. However, if you don't have time and just want to send me a patch / patched DSDT, I won't complain. :)

Thanks in advance, guys!

Vik
 

Attachments

  • dsdt.aml.zip
    15.1 KB · Views: 293
Joined
Sep 15, 2013
Messages
20
Motherboard
Lenovo D20
CPU
2x X5650
Graphics
nVidia 670 4GB
Mac
Classic Mac
Mobile Phone
bump...any help would be greatly appreciated.
 
Joined
Sep 15, 2013
Messages
20
Motherboard
Lenovo D20
CPU
2x X5650
Graphics
nVidia 670 4GB
Mac
Classic Mac
Mobile Phone
bump...again, any help would be greatly appreciated.
 
Joined
Sep 15, 2013
Messages
20
Motherboard
Lenovo D20
CPU
2x X5650
Graphics
nVidia 670 4GB
Mac
Classic Mac
Mobile Phone
Joined
Sep 15, 2013
Messages
20
Motherboard
Lenovo D20
CPU
2x X5650
Graphics
nVidia 670 4GB
Mac
Classic Mac
Mobile Phone

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,101
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi all,

First post here. Long time Mac user, but I'm new to the hackintosh scene. Just got a Lenovo Thinkstation D20, 2x Xeon X5650, 48G ECC RAM, nVidia GTX 670 4GB. I've done the requisite searching and googling, which means I've:

1. Downloaded Unibeast and made the bootable USB for Mountain Lion
2. Generated a copy of my raw (unpatched) DSDT
3. Downloaded Multibeast
4. Downloaded MaciASL and looked into patching the DSDT

However, all the reading I've done on patching a DSDT points to downloading the patch from a repo and then applying it in MaciASL. I cannot locate a patch for the DSDT (I've searched tonymacx86 and other sites), or a pre-patched DSDT for the Lenovo Thinkstation D20 anywhere, so I am confused as to where to go from here.

I am attaching a copy of my unpatched DSDT file to this post. I'll take what help I can get, but what I'd appreciate even more than simply sending me a patched file would be for someone to teach me to fish here- as in how to go about patching the DSDT in MaciASL when no patch currently exists. However, if you don't have time and just want to send me a patch / patched DSDT, I won't complain. :)

Thanks in advance, guys!

Vik

Have you installed ML yet? There is no need to do anything with DSDT until you get to the point to discover an issue that might be fixed by DSDT.
 
Joined
Sep 15, 2013
Messages
20
Motherboard
Lenovo D20
CPU
2x X5650
Graphics
nVidia 670 4GB
Mac
Classic Mac
Mobile Phone
Update: I've tried to install ML and the problem I'm running into is I can't get it to boot. Config again is:
- Lenovo Thinkstation D20
- 2x Xeon X5650
- 48G ECC RAM (UDIMMs)
- nVidia GTX 670 4GB


BIOS Settings:
- Vt-D = Disabled
- Wake on LAN = Disabled
- HPET- no settings available in BIOS
- SATA = native AHCI mode (using Intel chipset, not Marvel SAS)
- Tried booting from rear USB ports instead of front, no change

With GUI boot and no boot args, it just hangs on the white/grey Apple screen. Here's a list of all boot args I've tried, along with the last line(s) of verbose boot (I tried these based on some searching of the forums and some googling):

-v -x GraphicsEnabler=No
- [ PCI configuration end, bridges 11, devices 30 ]


-v -x GraphicsEnabler=No npci=0x2000
- [ PCI configuration end, bridges 11, devices 30 ]


-v -x GraphicsEnabler=No npci=0x2000 cpus=1
- RTC: Only single RAM bank (128 bytes)


-v -x GraphicsEnabler=No npci=0x3000 cpus=1
- RTC: Only single RAM bank (128 bytes)


-v -x GraphicsEnabler=No npci=0x2000 PCIRootUID=0
- RTC: Only single RAM bank (128 bytes)


-v -x GraphicsEnabler=No npci=0x2000 PCIRootUID=1
- [ PCI configuration end, bridges 11, devices 30 ]


-v -x GraphicsEnabler=No npci=0x3000 PCIRootUID=0
- RTC: Only single RAM bank (128 bytes)


-v -x GraphicsEnabler=No npci=0x3000 PCIRootUID=1
- RTC: Only single RAM bank (128 bytes)


-x -v GraphicsEnabler=No npci=x2000 cpus=1 PCIRootUID=0
- [ PCI configuration end, bridges 11, devices 30 ]


-v -x GraphicsEnabler=No npci=0x3000 cpus=1
- RTC: Only single RAM bank (128 bytes)
[ PCI configuration end, bridges 11, devices 30 ]


-v -x GraphicsEnabler=No npci=0x3000 cpus=1 PCIRootUID=1
[ PCI configuration end, bridges 11, devices 29 ]
- RTC: Only single RAM bank (128 bytes)


-v -x GraphicsEnabler=No npci=0x3000 cpus=1 PCIRootUID=0
- RTC: Only single RAM bank (128 bytes)
[ PCI configuration end, bridges 11, devices 30 ]


Any help would be greatly appreciated!
 
Joined
Mar 30, 2012
Messages
1
Motherboard
Sun Ultra 24
CPU
E8600
Graphics
Nvidia
Mac
Classic Mac
Mobile Phone
  1. iOS
I've been playing for some days with trying to get a D20 with the same configuration, minus the graphics card. I'm using a Quadro K4000 for my graphics card.

My thoughts are the board is just too complex, also tried Mavericks and Mountain Lion myself.

Total bummer!
 
Joined
Mar 20, 2013
Messages
1
Motherboard
PC
CPU
AMD64
Graphics
NVIDIA
Mac
Classic Mac
Mobile Phone
  1. iOS
so this hardware isn't recommended to run hackintosh? bummer.. :(
I was hoping to install OS X Yosemite with Clover..
 
Joined
Jul 21, 2012
Messages
36
Motherboard
Lenovo X230t
CPU
i5-3320m
Graphics
Intel HD 4000
Mac
  1. iMac
Mobile Phone
  1. iOS
so this hardware isn't recommended to run hackintosh? bummer.. :(
I was hoping to install OS X Yosemite with Clover..

I've done it. It was a huge pain in the ass, but google every error that hangs the installer. PCIrootuid=1 is your friend. DSMOS has arrived is one of the errors I remember seeing. I have kexts to provide once you're up and running but I've forgotten a bit of the install process.... I nearly tore my hair out to be honest.
 
Status
Not open for further replies.
Top