Contribute
Register

DSDT file for ASUS Prime Z390-P?

Joined
Feb 26, 2019
Messages
3
Motherboard
asus z390-p
CPU
i5-8400 lga1151
Graphics
integrated
Hi all,

I'm having a number of issues with running Mojave on my new ASUS Prime Z390-P Hackintosh.

current GPU is a Nvidia gt 520.

Does anyone have a proper DSDT file for this MB? I tried searching around the forum already, and I can't find it in the DSDT directory under the downloads section. I do not have any experience modifying DSDT files, but downloaded MaciASL to try to modify the DSDT file I pulled from a folder from the EFI partition after holding "F4" during the Clover boot menu appearing - but it also does not have this MB model in it's available patch list.

Some issues I'm having currently:
- integrated GPU not working on HDMI or DP output (have to use older Nvidia card for the moment) would like to be able to use the iGPU if it resolves some weird graphics rendering issues I've been experiencing.

  • Freezes after waking from sleep (not sure if this is a kernel panic, or just graphics freezing)
  • Unplugging monitor via HDMI from Graphics card will also cause same issue as appears after wake from sleep.
  • Restart or shut down doesn't work.
  • USB and sound, ethernet are all working as expected though.

Any thoughts?
 
Joined
Feb 26, 2019
Messages
3
Motherboard
asus z390-p
CPU
i5-8400 lga1151
Graphics
integrated
Sorry mods - I am new to this forum, and looks like there's a better spot for this post in the DSDT section. Feel free to move it, if you see this message. Thanks
 
Joined
Jul 26, 2012
Messages
34
Motherboard
Asus Z390-A Prime
CPU
i7-8700K
Graphics
Vega 64
Mac
iMac, MacBook, MacBook Pro
Classic Mac
iMac, Power Mac, SE
Mobile Phone
iOS
I’ll help if I can.. got bit by the buyers guide on an MSI recommendation earlier.. I’m running a z390-a rather than the p now, but close enough..

I don’t use any sort of custom DSDT or SSDT afaik, just straight up config.plist. Sleep, wake, shutdown, restart, Vega 64, iMessage/BT/handoff/WiFi all just work. I’m using the Vega now but started with the 630, all I needed to do was switch from int to ext (vice versa) in the bios.

1. Not sure what smbios you currently have, but switch to Macmini8,1. It has native iX-8xxx and UHD630.
2. I only use 1 Kext (fakesmc) and my system is pretty close to flawless. Granted, I use external usb audio interfaces and a stock airport/BT card so I don’t need to worry other Kexts or injects. Looks like you have that sorted tho.
3. Don’t use a usb inject all kext. 99% of my rabbit hole issues went away getting rid of that. Just take a little time with the manual and the bios and disable the ports you don’t need. If you find you need a lot of ports, get a usb 3 hub and offload as many as possible to that.
 
Top