Contribute
Register

Does anyone have any success getting to the install screen on a GB X58A UD3R??

Status
Not open for further replies.
Joined
Nov 1, 2011
Messages
124
Motherboard
Gigabyte X58A UD3R (rev 1.0)
CPU
Core i7 950 3.06 Ghz
Graphics
XFX Radeon 6870 HD 1GB
Mac
Classic Mac
Mobile Phone
  1. Android
  2. iOS
I took another look at the thread Ice linked to us, and there might be a fix about editing the framebuffer in the ATI6000Controller.kext. Not sure how this could be done, but if anyone knows of a working solution to fix this kext or get to the installer, let me know! I really really want ML on my rig...
 
Joined
Jun 25, 2011
Messages
79
Motherboard
GA-X58A-UD3R Rev 1.0
CPU
i7
Graphics
8800GT - 550Ti
Mobile Phone
  1. iOS
Dvi

All my ports are DVI (2x2) and like I say, worked natively. I'd almost garantee it being the card now tbh. Ask yourself a question, do you really want to continue using that graphics card?

Good luck with the coding on this if you do but in my honest opinion, pick up a compatible card from eBay or even new if you can and you won't be sorry.
 

Ice

Joined
Sep 20, 2010
Messages
26
Motherboard
Gigabyte GA-Z87X-UD5H
CPU
i7-4770K
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
@blackhawk

Sorry, maybe I should have been more precise. Just follow the directions from the thread I linked. I followed it last night and was able to install ML no problem.
For your convenience here the part I am referring to (thx to Colton328):

Part 1: Setting up the UniBeast Drive
1. Insert your UniBeast Flash Drive into a working Mac. Maybe your MacBook Pro, working Lion installation, etc.
2. Run this command in terminal to unhide files "defaults write com.apple.finder AppleShowAllFiles 1" (copy and paste that into terminal and hit enter)
3. Force Finder to quit. You can do this in activity monitor. It will automatically restart.
4. Open Finder and navigate to your UniBeast Drive
5. Navigate to System/Library/Extensions
6. MAKE A BACKUP OF the kext "ATI6000Controller.kext" and then DELETE it.

Part 2: Booting from your UniBeast Drive
1. Boot from your UniBeast drive like you usually would. Use the command "GraphicsEnabler=No" in order to boot into Mountain Lion Installer
2. Install Mountain Lion as you usually would
3. After installation, bootup Mountain Lion by booting into your flash drive and then booting into ML, using the command "GraphicsEnabler=No"
4. Copy the ATI6000Controller.kext kext to your new desktop
5. Run KextBeast (Download: http://www.tonymacx86.com/downloads.php?do=cat&id=3)
6. Reboot

Good Luck,

Ice
 
Joined
Nov 1, 2011
Messages
124
Motherboard
Gigabyte X58A UD3R (rev 1.0)
CPU
Core i7 950 3.06 Ghz
Graphics
XFX Radeon 6870 HD 1GB
Mac
Classic Mac
Mobile Phone
  1. Android
  2. iOS
@blackhawk

Sorry, maybe I should have been more precise. Just follow the directions from the thread I linked. I followed it last night and was able to install ML no problem.
For your convenience here the part I am referring to (thx to Colton328):

Part 1: Setting up the UniBeast Drive
1. Insert your UniBeast Flash Drive into a working Mac. Maybe your MacBook Pro, working Lion installation, etc.
2. Run this command in terminal to unhide files "defaults write com.apple.finder AppleShowAllFiles 1" (copy and paste that into terminal and hit enter)
3. Force Finder to quit. You can do this in activity monitor. It will automatically restart.
4. Open Finder and navigate to your UniBeast Drive
5. Navigate to System/Library/Extensions
6. MAKE A BACKUP OF the kext "ATI6000Controller.kext" and then DELETE it.

Part 2: Booting from your UniBeast Drive
1. Boot from your UniBeast drive like you usually would. Use the command "GraphicsEnabler=No" in order to boot into Mountain Lion Installer
2. Install Mountain Lion as you usually would
3. After installation, bootup Mountain Lion by booting into your flash drive and then booting into ML, using the command "GraphicsEnabler=No"
4. Copy the ATI6000Controller.kext kext to your new desktop
5. Run KextBeast (Download: http://www.tonymacx86.com/downloads.php?do=cat&id=3)
6. Reboot

Good Luck,

Ice

Thanks for your help Ice. Unfortunately, I tried these steps 2 days ago and I still couldn't get to the installer. I recreated my unibeast drive a couple times, even making a 10 GB partition to do the same thing, but it still reboots. I don't know if it's my USB drive itself though... I'm using an 8 GB Micro SD to USB adapter to do it. It worked just fine for Lion.

In Disk Utility, there's no way to repair permissions on my USB drive. I honestly don't know what else to do!

@snowy0230,

I don't need to upgrade my graphics card, it's less than a year old and I really enjoy using it for my Win7 games. Thanks for the idea though.
 
Joined
Aug 5, 2010
Messages
110
Motherboard
MSI-Z77A-G45
CPU
i5-3570K
Graphics
GTX 650 Ti Boost + HD 4000
Mac
  1. MacBook Air
Classic Mac
Mobile Phone
  1. iOS
Thanks for your help Ice. Unfortunately, I tried these steps 2 days ago and I still couldn't get to the installer. I recreated my unibeast drive a couple times, even making a 10 GB partition to do the same thing, but it still reboots. I don't know if it's my USB drive itself though... I'm using an 8 GB Micro SD to USB adapter to do it. It worked just fine for Lion.

In Disk Utility, there's no way to repair permissions on my USB drive. I honestly don't know what else to do!

@snowy0230,

I don't need to upgrade my graphics card, it's less than a year old and I really enjoy using it for my Win7 games. Thanks for the idea though.

Blackhawk, do you have another spare hdd, you can make Mountain Lion Installation on bootable hard drive without using USB. I never create USB installation.
 
Joined
Apr 8, 2010
Messages
5
Motherboard
Gigabyte X58A-UD3R
CPU
Intel Core i7 920
Graphics
Galaxy GeForce GTX 465
Mac
Classic Mac
Mobile Phone
  1. iOS
I've had no issues besides the standard audio ones with this board from Snow Leopard to Lion and now Mountain Lion. I created a USB drive to install Lion and Mountain Lion with no issues. I'd try with a different video card if possible. As others have posted the 400 and earlier nVidia cards and pre 6000 series ATi don't seem to have issues during install.
 
Joined
Jun 25, 2011
Messages
79
Motherboard
GA-X58A-UD3R Rev 1.0
CPU
i7
Graphics
8800GT - 550Ti
Mobile Phone
  1. iOS
Cool Beans

If you graphics card is worth it's keep then go for it blackhawk. I wasn't too bothered with my rig, I just wanted a bit of beef and something that worked so after a bit of playing about, I decided to go for a tried and tested. I'm sure the answer is out there, Just a case of time and patience.

Good luck!!
 
Joined
Nov 1, 2011
Messages
124
Motherboard
Gigabyte X58A UD3R (rev 1.0)
CPU
Core i7 950 3.06 Ghz
Graphics
XFX Radeon 6870 HD 1GB
Mac
Classic Mac
Mobile Phone
  1. Android
  2. iOS
Still no luck on getting to the install screen... With the ATI6000Controller.kext removed from my unibeast drive, I still can't see the installer with these combinations:

GraphicsEnabler=No
GraphicsEnabler=No AtiConfig=Pithecia

Currently remaking a partition with the updated Unibeast 1.5.2. Will post back with results.

Update: New Unibeast is a bust. Still can't get to the install screen. Even with deleting the ATI6000Controller.kext, newest Multibeast repair permissions, and every possible boot code I've tried in the past. :(
 
Joined
Jan 24, 2012
Messages
12
Motherboard
GA-Z77X-UD5H
CPU
Intel 3770k
Graphics
Nvidia 670 x2
Mac
Classic Mac
Mobile Phone
I have a similar problem as well, same mobo and BIOS, SL was a major b***h to install but I eventually got it working.

ML I can successfully install but once it restarts I cannot get it to boot into the OS, have tried EVERYTHING. I have two (and yes I tried using just ONE) GTX 480's. It shows the apple logo for half a second, then restarts. I've tried with and without iboot (3.3.0) and tried -x -v, PCIROOTUID=1 =0.


I'm tempted to just buy a darn 6870 except it's such a paltry card on the windows side of things.

BTW Im running a 27" ACD via minidisplayport to displayport adaptor, works for the install just fine, can't figure why it doesn't want to boot properly.
 
Joined
Apr 16, 2011
Messages
16
Motherboard
Costomac
CPU
Intel i7 2600k
Graphics
GIGABYTE GV-R687OC-1GD Radeon HD 6870
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
I've also had these problems and a new usb worked for me to get to the ML installer, but my problem is putting the ati6000controller.kext back, I'm using kextbeast and the kext file is on my desktop and I'm using multibeast to repair the permissions but its not working the kext file is greyed out in System/Library/Extensions and have to use GraphicsEnabler=No to boot in
 
Status
Not open for further replies.
Top