Contribute
Register

Solved > Do the Samsung 970 EVO Plus drives work ? New Firmware Available 2B2QEXM7

Joined
Jul 9, 2016
Messages
47
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i7-9700K
Graphics
580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I had the same problem to start with, ie wouldn't boot the USB stick.
The quickest way I found was to just reset the BIOS to Optimised Defaults - after saving the current settings of course.
It then booted the USB firmware updater just fine.
After the update I went back into the BIOS and restored my old settings.
Nice and easy really.

I ended up getting it to work by using an app called Etcher to create the bootable usb. Unetbootin simply wasn’t working.
 
Joined
Apr 27, 2013
Messages
136
Motherboard
GA-Z490 Vision D
CPU
i9-10900K
Graphics
UHD 630
Mac
  1. iMac
I have Samsung NVMe 970 PRO 512GB with StarTech M.2 Adapter x4 PCIe 3.0 installed on Mojave, everything work fine except I'm not happy with the speed: Write 2000mb/s - Read 2900mb/s:)
I didn't see any firmware or drives update for NVMe 970 PRO what can I do, please any advice?
 
Joined
Oct 24, 2019
Messages
1
Hi! I have put a 970 EVO Plus in a 2017 iMac. Before installing I took it to a computer service store who could put the m2 in a windows-computer and upgraded the firmware for me. I paid like $20 for this, as I have no people around who could do it for me. I just have to trust that they made the proper firmware-upgrade. At any rate, this m2 cannot be detected after install, even when I have used Unetbootin and Etcher (sorry about the picture being posted the wrong way)... Could it be hardware-related? I cannot for the life of me figure out why this is happening! I have used equipment (like the recommended Sintech adapter (ST-NGFF2013C)) and procedures described here: https://forums.macrumors.com/thread...rade-pitfalls-and-tips.2177812/#post-27283795

Any suggestions? I cannot see that most people here have trouble in detecting the m2?
 

Attachments

  • IMG_2590.JPG
    IMG_2590.JPG
    1.7 MB · Views: 128
Joined
May 28, 2016
Messages
10
Motherboard
Z370 Aorus Pro
CPU
i7-9700K
Graphics
Vega 64
Hello!
Today I was installing Catalina ( 15.10.1 ) on this SSD --> EVO 970 Plus.
My experience was difficult because I don't have all knowledges about Hackintosh. This is my third computer with Mac Os and I did the installation very well except:
  1. Injection of Vega 64 8GB.
  2. Power off, reboot and sleep.
NOTE: Before update the firmware I had a lot of problems installing Catalina. After this, work fine.
 
Joined
Oct 30, 2019
Messages
3
Motherboard
Asus STRIX Z390-H GAMING
CPU
i9-9900K
Graphics
5700 XT
I can confirm the plus drives work, at least to some extent. My new system has only been up and running for about 48 hours now but so far so good. I did a fresh Mojave install following this guide: https://www.tonymacx86.com/threads/...g-i7-8700k-sapphire-rx580-pulse-build.272572/

The only issue I ran into so far was that I needed to use Display Port rather than HDMI to connect, otherwise the screen just goes black and becomes unresponsive. However, I don't think that's related to this drive. Just something to note.
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
18,904
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Joined
Jun 12, 2011
Messages
24
Motherboard
ASUS ROG Strix Z370-E Gaming
CPU
i9-9900K
Graphics
Vega 56
Mobile Phone
  1. Android
  2. iOS
Do you guys think it is possible to flash the PM981 drive and run it on a Catalina system?
It seems that the PM981 is OEM Samsung 970 EVO Plus?
 
Joined
Jul 13, 2016
Messages
2,706
Motherboard
Gigabyte Z370 Gaming 5
CPU
I9 9900k
Graphics
Vega 64
Mac
  1. Mac mini
  2. Mac Pro
Mobile Phone
  1. iOS
Do you guys think it is possible to flash the PM981 drive and run it on a Catalina system?
It seems that the PM981 is OEM Samsung 970 EVO Plus?

You would need to contact Samsung to find this out, or you could be a test guinea pig.
 
Top