Contribute
Register

Do I need 4 antennas for my BCM94331CD?

Status
Not open for further replies.
Joined
Nov 28, 2016
Messages
4
Motherboard
Gigabyte GA-H110M-A
CPU
i5-6500
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I recently bought a BCM94331CD WiFi/BT card and a PCI-E x1 adapter for it. The adapter only has 3 antennas, while the BCM94331cd has 4 pigtail connectors. I've just connected 3 of them randomly, and left out the other. Bluetooth is working fine, so I've probably connected that antenna correctly, but WiFi is not. At first, it would only pick up a signal 10 feet away as minimum strength, and refused to connect. After changing the port left unplugged, I got more reasonable signal strengths, but I still cannot connect. I have tried with and without brcmfixup.kext along the way, but that hasn't changed anything. So, do I have a software problem, or do I need to buy another antenna? And if I do, what is the cheapest one that doesn't take more than 10 days to ship?

Also, if I need to upload any files or pictures, just let me know.
 
Joined
Jan 29, 2019
Messages
1
Motherboard
ASUS ROG Strix z270i
CPU
Intel Kaby Lake 7700K
Graphics
Saphire Pulse Radeon RX 580
I recently bought a BCM94331CD WiFi/BT card and a PCI-E x1 adapter for it. The adapter only has 3 antennas, while the BCM94331cd has 4 pigtail connectors. I've just connected 3 of them randomly, and left out the other. Bluetooth is working fine, so I've probably connected that antenna correctly, but WiFi is not. At first, it would only pick up a signal 10 feet away as minimum strength, and refused to connect. After changing the port left unplugged, I got more reasonable signal strengths, but I still cannot connect. I have tried with and without brcmfixup.kext along the way, but that hasn't changed anything. So, do I have a software problem, or do I need to buy another antenna? And if I do, what is the cheapest one that doesn't take more than 10 days to ship?

Also, if I need to upload any files or pictures, just let me know.

Can someone please respond to this. I have the same issue after removing the native Wifi/Bluetooth card on my ASUS z270i and replacing it.
 
Joined
Jan 22, 2017
Messages
2
Motherboard
asrock Z97 Anniversary
CPU
i7-4770K OC @ 4.4GHz
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Shalom.
I'm pretty sure to have both bluetooth and wifi working all 4 connectors need to plugged in on the card. i have 2 plugged in and currently have wifi working but not bluetooth so I would imagine the other 2 are for bluetooth meaning you would need all 4 connected to get both bluetooth and wifi.
If i've helped at all I'm happy.
 
Status
Not open for further replies.
Top