Contribute
Register

Solved > DisplayPort not working after Mojave Update

Joined
Dec 15, 2016
Messages
7
Motherboard
MSI Z270-Gaming Pro
CPU
i5-7600K
Graphics
GTX 960
Mac
MacBook Pro
Classic Mac
Power Mac
Mobile Phone
Android, iOS
Hi,

I upgraded my PC with an MSI RX 580 ARMOR Graphics Card (1xDVI, 2xHDMI, 2x DP) after Nvidia doesn't release a driver. The new Graphics Card worked fine in High Sierra, then I installed the update to Mojave.. Now I have a problem: I have four monitors connected (1 DVI, 2 HDMI and 1 DP) and the DP-monitor doesn't get any signal. Why did DP stop working and much more important: How can I fix that?

CPU: Intel Core i5-7600k
Motherboard: MSI Z270 Gaming Pro
RAM: 16 GB DDR4
OS-SSD: Samsung 960 EVO 500GB
 
Joined
Apr 22, 2012
Messages
51
Motherboard
ASRock Z390 Ph-Gam-ITX
CPU
i9-9900K
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
I have the exact same GPU and do not get a signal when booting to Clover. The only way to get it to work is boot with the iGPU and then later once in OSX attaching my 2 4k monitors via DisplayPort to the GPU. Here's a picture of my EFI folder, I'd attach it, but it's a little hefty at 49.5MBs).

EFI-screenshot.png
 
Joined
Dec 15, 2016
Messages
7
Motherboard
MSI Z270-Gaming Pro
CPU
i5-7600K
Graphics
GTX 960
Mac
MacBook Pro
Classic Mac
Power Mac
Mobile Phone
Android, iOS
Problem solved by Changing System Definitions from iMac 17,2 to Mac Pro 6,1, now all Screens are working fine. I tried several system definitions and Mac Pro 6,1 works best. Screenshots of Clover Configurator below.

Bildschirmfoto 2018-11-02 um 23.38.34.png
Bildschirmfoto 2018-11-02 um 23.39.38.png
 
Joined
Sep 21, 2011
Messages
255
Motherboard
laptop dell 7348,dell 7559 UHD...desktop asrock H97M anniversary edition
CPU
laptop-i7 --. 6700HQ..i5-5200U...desktop -i7-4790k
Graphics
intel hd-5500,530 . desktop --palit nvidia gtx 1060 6gb ram
Mac
iMac, MacBook Air, MacBook Pro
Mobile Phone
Android
i have hdmi port working on sapphire RX580 but on display port i got video glitch after boot up from clover menu.. i used simbios imac 18.3 which worked before on mojave ... i got this video glitch when i connect it to my new philips 4k monitor from RMA
 
Joined
Feb 19, 2018
Messages
194
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
I have the exact same GPU and do not get a signal when booting to Clover. The only way to get it to work is boot with the iGPU and then later once in OSX attaching my 2 4k monitors via DisplayPort to the GPU. Here's a picture of my EFI folder, I'd attach it, but it's a little hefty at 49.5MBs).

View attachment 362493
You're Whatevergreen.kext and Lilu.kext are very old versions. Update them to the latest version and all will probably be fine.
 
Joined
Sep 21, 2011
Messages
255
Motherboard
laptop dell 7348,dell 7559 UHD...desktop asrock H97M anniversary edition
CPU
laptop-i7 --. 6700HQ..i5-5200U...desktop -i7-4790k
Graphics
intel hd-5500,530 . desktop --palit nvidia gtx 1060 6gb ram
Mac
iMac, MacBook Air, MacBook Pro
Mobile Phone
Android
i updated whatevergreen , lilu kext to latest version still got video glitch with display port . but not with hdmi port -- mojave 10.14.2
 
Joined
Feb 28, 2013
Messages
10
Motherboard
Asus ROG MAXIMUS XI CODE - 0802
CPU
i9-9900K
Graphics
RX 580
Mac
MacBook, MacBook Air, MacBook Pro
Mobile Phone
iOS
Joined
May 31, 2019
Messages
1
Motherboard
intel
CPU
intel xeon
Graphics
ati hd 7950 3 gb
Hello,

I have a mac pro 5,1 with high sierra with ATI 7950 HD graphic card

then I replaced it with NVidia card 1070 then the screen didn't work till install clover and change a lot of things to let it work on booting and it's work now I return to the old graphics card ATI and upgrade the system to mojave
now am getting 2 issue

1-would not boot directly to MAC logo

2-display port not working on the HDMI

how could I return everything like how it was before like booting normally without clover screen

and fix the display booting issue

excuse my poor knowledge still learning from you guys

any advice, please.
 
Joined
Sep 20, 2017
Messages
1
Motherboard
ASUS TUF Z270 Mark 1
CPU
i7-7700k
Graphics
GTX 1060 - RX 580
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Top