Contribute
Register

Display brightness stuck on very low brightness level after wake up

Status
Not open for further replies.
Joined
Jun 7, 2012
Messages
57
Motherboard
ASUS P7P55D-E
CPU
Intel i5 760
Graphics
Sapphire Ati Radeon 5570
Mac
Classic Mac
Mobile Phone
ok.

In the following days I'll receive a supported WiFi card, so I'll fix it.

About USB3.....I tried to use OS-X-Generic-USB3 but I had problem with USB3 hard-drive, the laptop didn't want to mount them....
Probably you have the solution :)
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,477
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
ok.

In the following days I'll receive a supported WiFi card, so I'll fix it.

About USB3.....I tried to use OS-X-Generic-USB3 but I had problem with USB3 hard-drive, the laptop didn't want to mount them....
Probably you have the solution :)

GenericUSBXHCI.kext should be avoided as should PXHCD.

Usually AppleUSBXHCI.kext (included by the OS X installer) can be made to work with Intel XHCI(USB3).
 
Joined
Jun 7, 2012
Messages
57
Motherboard
ASUS P7P55D-E
CPU
Intel i5 760
Graphics
Sapphire Ati Radeon 5570
Mac
Classic Mac
Mobile Phone
If I don't install PXHCD.kext or GenericUSBXHCI.kext, all USB ports (three 2.0 and one 3.0) don't work, they don't mount hard-drive or pen-drive.

An AppleUSBXHCI.kext problem related to my laptop? Unfortunately my VAIO's bios is locked.....Maybe editing the kext should be useful
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,477
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
If I don't install PXHCD.kext or GenericUSBXHCI.kext, all USB ports (three 2.0 and one 3.0) don't work, they don't mount hard-drive or pen-drive.

An AppleUSBXHCI.kext problem related to my laptop? Unfortunately my VAIO's bios is locked

Try with FakePCIID_XHCIMux.kext or the "multiplex" patch (never both).
 
Joined
Jun 7, 2012
Messages
57
Motherboard
ASUS P7P55D-E
CPU
Intel i5 760
Graphics
Sapphire Ati Radeon 5570
Mac
Classic Mac
Mobile Phone
I fixed the USB 3.0 problem.

I deleted PXHCD.kext, then I installed FakePCIID.kext and FakePCIID_XHCIMux.kext but with them I could only mount hard-drive from USB 2.0, USB 3.0 didn't want to mount hard-drive.

So I opened Clover configurator and I injected the Intel device-id 0x1e31 in "devices" --> "XHCI", then I saved and rebooted.

Now I can mount USB 3.0 hard-drive, they appear mounted on USB-superspeed bus in system information. Tonight I want to test the transfer rate
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,477
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I fixed the USB 3.0 problem.

I deleted PXHCD.kext, then I installed FakePCIID.kext and FakePCIID_XHCIMux.kext but with them I could only mount hard-drive from USB 2.0, USB 3.0 didn't want to mount hard-drive.

So I opened Clover configurator and I injected the Intel device-id 0x1e31 in "devices" --> "XHCI", then I saved and rebooted.

Now I can mount USB 3.0 hard-drive, they appear mounted on USB-superspeed bus in system information. Tonight I want to test the transfer rate

Intel XHCI is already natively supported. No need to inject device-id.

To get USB3 speed, you need USB3 devices plugged into USB3 port.
 
Joined
Jun 7, 2012
Messages
57
Motherboard
ASUS P7P55D-E
CPU
Intel i5 760
Graphics
Sapphire Ati Radeon 5570
Mac
Classic Mac
Mobile Phone
If I plug USB3 devices in the USB3 port without inject Intel XHCI, the USB3 port doesn't mount USB3 devices
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,477
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
If I plug USB3 devices in the USB3 port without inject Intel XHCI, the USB3 port doesn't mount USB3 devices

No idea really what exactly you mean by "inject Intel XHCI"... There is no such Clover option.

Post ioreg (without the "inject Intel XHCI"): http://www.tonymacx86.com/audio/58368-guide-how-make-copy-ioreg.html. Please, use the IORegistryExplorer v2.1 attached to the post! DO NOT reply with an ioreg from any other version of IORegistryExplorer.app.

Post EFI/Clover folder.

Provide the config.plist with "inject Intel XHCI" and without.
 
Status
Not open for further replies.
Top