Contribute
Register

Discussion on installing Mac OS System on HP elitedesk 800 G5 GM GPU rx560 mini model! imac19.1

Joined
May 2, 2019
Messages
29
Motherboard
intel z370
CPU
intel I7 9700
Graphics
adm rx560
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 128K
Mobile Phone
  1. iOS
I need to go, but will look again tomorrow. Good luck with the graphics patches. Be sure to read this entire post, since I added some stuff. I like your patience and persistence. Good work.
Do as you say, but it's the same as before. There's no difference between OC boot and OC boot!
 

Attachments

  • config.plist
    9.4 KB · Views: 7
  • 12.10.19.1.ioreg
    3.8 MB · Views: 8
Joined
Sep 22, 2011
Messages
1,315
Motherboard
HP EliteDesk 800 G5 Mini
CPU
I7-9700
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Do as you say, but it's the same as before. There's no difference between OC boot and OC boot!
Please try the attached config.plist. In it, I changed AAPL,ig-platform-id to the one I recommended here and I applied some CLOVER graphics properties from this patch.
 

Attachments

  • config.plist.zip
    3.3 KB · Views: 9
Joined
May 2, 2019
Messages
29
Motherboard
intel z370
CPU
intel I7 9700
Graphics
adm rx560
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 128K
Mobile Phone
  1. iOS
Please try the attached config.plist. In it, I changed AAPL,ig-platform-id to the one I recommended here and I applied some CLOVER graphics properties from this patch.
I tried to use clover to boot myself, and now I can successfully enter the system WhateverGreen.kext Remove it, and then select change gfx0 to igpu and change pegp to gfx0 in the configuration file. After restarting, you can enter the system. I attach my EFI.
I'll try the configuration file you sent me later.
I tried to guide Big Sur, and it didn't work!
Do I want to upgrade clover
 

Attachments

  • 19.1-clover-EFI.zip
    2.4 MB · Views: 9
Joined
Sep 22, 2011
Messages
1,315
Motherboard
HP EliteDesk 800 G5 Mini
CPU
I7-9700
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
I tried to use clover to boot myself, and now I can successfully enter the system WhateverGreen.kext Remove it, and then select change gfx0 to igpu and change pegp to gfx0 in the configuration file. After restarting, you can enter the system. I attach my EFI.
I'll try the configuration file you sent me later.
I tried to guide Big Sur, and it didn't work!
Do I want to upgrade clover
So it's working without WhateverGreen, renaming PEGP > GFX0 and renaming GFX0 > IGPU?

If that's the case and you are happy with the way it works, I think you have solved the problem on your own! If you want to run Big Sur, I think you should switch back to OpenCore and repeat what you did for CLOVER: remove WhateverGreen, rename PEGP > GFX0 and rename GFX0 > IGPU.
 
Joined
May 2, 2019
Messages
29
Motherboard
intel z370
CPU
intel I7 9700
Graphics
adm rx560
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 128K
Mobile Phone
  1. iOS

Attachments

  • clover-19.1.ioreg
    5.3 MB · Views: 6
Joined
Sep 22, 2011
Messages
1,315
Motherboard
HP EliteDesk 800 G5 Mini
CPU
I7-9700
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
How to use clover to guide Big Sur?
How do I set up clover?
I would recommend that you switch back to OpenCore to run Big Sur. After you switch back to Open Core, you should be able to apply your renames and remove WhateverGreen to duplicate your CLOVER configuration.
 
Joined
May 2, 2019
Messages
29
Motherboard
intel z370
CPU
intel I7 9700
Graphics
adm rx560
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 128K
Mobile Phone
  1. iOS
I would recommend that you switch back to OpenCore to run Big Sur. After you switch back to Open Core, you should be able to apply your renames and remove WhateverGreen to duplicate your CLOVER configuration.

Boot with OC, error occurred​

HID:Legacy shim 2​

 
Joined
Sep 22, 2011
Messages
1,315
Motherboard
HP EliteDesk 800 G5 Mini
CPU
I7-9700
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS

Boot with OC, error occurred​

HID:Legacy shim 2​

You've already booted OC successfully - what happened? Please post your config.plist with each request for help.

I think this is a USB problem. Are you using the correct USBPorts.kext for your iMac19,1?

@lydahai Sometimes when switching from CLOVER to OC (or OC to CLOVER), I have found it best to clear NVRAM.
 
Last edited:
Top