Contribute
Register

Disable ATI card detection

Joined
Apr 10, 2012
Messages
1
Mac
Classic Mac
Mobile Phone
Hello guys,

My system: GA-Z68MA-D2H-B3, I7-2600K, Samsung SSD.
Everything works perfectly, GraphichEnabler=yes works well with the integrated Intel HD3000.

Unfortunately, when I insert my new ATI HD7850 PCI-E card to the system, it won't boot with "GraphichEnabler=yes" option, because it tries to use the unsupported ATI card too.
The error messges is: "Memory allocation error: Addr: 0x0, Szie 0x3ff1970, File: ati.c, Line 1557. This is a non recoverable error! System HALTED!!!"

I don't want to use ATI HD7850 in OSX86, Intel HD3000 is enough for me. Is there any way to disable the ATI initialization in Chimera to avoid this problem?
 
Joined
Jan 9, 2011
Messages
273
Motherboard
MacPro 5,1
CPU
X5660
Graphics
Radeon 280X
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. iMac
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
There must be a way to use GraphicsEnabler=no, and use a DSDT injection for the HD3000.
Use the search option of the forum...

Hope you can fix it!

Greetz
 
Joined
Mar 2, 2012
Messages
8
Motherboard
MACPRO i7
CPU
intel i7-3820
Graphics
Gigabyte AMD RADEON HD 7870
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
Mobile Phone
  1. Android
  2. iOS
  3. Other
tavcsor said:
Hello guys,

My system: GA-Z68MA-D2H-B3, I7-2600K, Samsung SSD.
Everything works perfectly, GraphichEnabler=yes works well with the integrated Intel HD3000.

Unfortunately, when I insert my new ATI HD7850 PCI-E card to the system, it won't boot with "GraphichEnabler=yes" option, because it tries to use the unsupported ATI card too.
The error messges is: "Memory allocation error: Addr: 0x0, Szie 0x3ff1970, File: ati.c, Line 1557. This is a non recoverable error! System HALTED!!!"

I don't want to use ATI HD7850 in OSX86, Intel HD3000 is enough for me. Is there any way to disable the ATI initialization in Chimera to avoid this problem?


being insane with my new Gigabyte Radeon HD 7870... still googling for anything possibilities to make this Card working.. cheers..
 
Joined
Jan 24, 2012
Messages
102
Motherboard
10.7.5
CPU
i7 2600k
Graphics
HD5670
Mac
Classic Mac
Mobile Phone
dont i get the point, am i missing something ?

you plug a card into your system, that you want now, to be disabled ?
whats if you disable it manually by plugging it off your computer ?
 
Joined
Jan 9, 2011
Messages
273
Motherboard
MacPro 5,1
CPU
X5660
Graphics
Radeon 280X
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. iMac
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
westwaerts said:
dont i get the point, am i missing something ?

you plug a card into your system, that you want now, to be disabled ?
whats if you disable it manually by plugging it off your computer ?

Might be shocking to you, but there are people who use multiple OSes :eek:
 
Joined
Mar 2, 2012
Messages
8
Motherboard
MACPRO i7
CPU
intel i7-3820
Graphics
Gigabyte AMD RADEON HD 7870
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
Mobile Phone
  1. Android
  2. iOS
  3. Other
yeah finally i got desktop with AMD RADEON HD 7870 but not completly working... crossing finger then...:)
 
Joined
Mar 30, 2012
Messages
2
Motherboard
Asrock Z68M-USB3
CPU
Intel i5 2500K
Graphics
Sapphire HD7850
Mac
Classic Mac
  1. iBook
Mobile Phone
  1. Other
Any progress on this?

I also want to disable HD7850 in OSX.
In Windows 7, I would use Virtu-Lucid. So no need to swop plugs.
 
Joined
Dec 1, 2011
Messages
3
Motherboard
Gigabyte Z68-UD3H-B3
CPU
i5 2500k
Graphics
ATI Gigabyte 6950
Mac
Classic Mac
Mobile Phone
Im also interested in this as I have a 6950 which i use for gaming in windows but want to only use the built in intel hd 3000 graphics for my hackintosh
 
Joined
Jan 24, 2011
Messages
1
Motherboard
OS X Lion 10.7.4
CPU
Intel i7 3770
Graphics
GT220 + HD4000
Mac
Classic Mac
Mobile Phone
tavcsor said:
Hello guys,

My system: GA-Z68MA-D2H-B3, I7-2600K, Samsung SSD.
Everything works perfectly, GraphichEnabler=yes works well with the integrated Intel HD3000.

Unfortunately, when I insert my new ATI HD7850 PCI-E card to the system, it won't boot with "GraphichEnabler=yes" option, because it tries to use the unsupported ATI card too.
The error messges is: "Memory allocation error: Addr: 0x0, Szie 0x3ff1970, File: ati.c, Line 1557. This is a non recoverable error! System HALTED!!!"

I don't want to use ATI HD7850 in OSX86, Intel HD3000 is enough for me. Is there any way to disable the ATI initialization in Chimera to avoid this problem?

Have you tried to set your iGPU as the main gpu and disabling the multimonitor option in
your Bios after installing the card and before booting to mac os (you can get those settings back for virtu mvp prior to booting in to windows). Although this setting may be called differently or be entirely missing from your bios (I have familiarity only with the uefi bios of the asus's z77 boards and the old bioses (Core 2 duo age) :) )
 
Joined
Jan 17, 2011
Messages
2
Mac
Classic Mac
Mobile Phone
hey!

i'm currently facing the same problem (although having a different system, z77x-ud5h, intel hd graphics 4000 / ati hd 7850). i've been researching for many days now but i couldn't find a solution yet ..

i already tried to disable the pci-e slot via dsdt editing, problem is that chimera seems to detect the ATI card before loading the dsdt file. maybe some chimera source editing would help? i have no idea .. did you guys already find a solution?

greets :)
 
Top