Contribute
Register

Direct Update to macOS Sierra using Clover

Joined
Feb 19, 2011
Messages
93
Motherboard
Gigabyte Z97-UD5H
CPU
i7 4790k
Graphics
GTX 1070
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Mine is doing the same, I used terminal to create the installer, hangs 3 quarter of the way with spinning beachball.

Then installed El Cap successfully to do the update method but when i reboot to the Sierra installer it gets to the exact same point with the spinning beachball.

Screen doesn't blackout, progress bar and apple logo still remain.
Anybody else had this issue and been successful getting past it?


GA-Z170X-UD5 TH
6700K
GTX970
Did you try booting without cache and kext, selected from the clover menu by pressing space bar at boot up.
 
Last edited:
Joined
Jun 26, 2012
Messages
4,096
Motherboard
Z170 Deluxe
CPU
i5-6600K
Graphics
GTX 970
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
  2. Other
Can I update from Yosemite to Sierra with this method?
Can I copy everything from S/L/E to EFI/Clover/kexts/Others ?
Please fill in your profile as required by the Rules, it should include Motherboard make and model, CPU model and graphics card or IGPU. Once you've filled out your profile are you using Chimera or Clover as your bootloader?
 
Joined
Oct 7, 2012
Messages
122
Motherboard
ROG Maximus XII Hero Wi-Fi
CPU
i9-10900K
Graphics
RX 6900XT
Mac
  1. MacBook
Hey guys I just noticed on my Skylake build, that I have no kexts in my 10.11 folder at all! Is this normal? I've had it for a couple of months now so I cant remember the initial install phase, but surely you;d need at least FakeSMC? FWIW this Skylake build is pretty much rock solid? I'm a bit scared to put kexts in my /k/e folder just in case it messes with something?
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
25,876
Motherboard
Lenovo ThinkStation p700
CPU
2x E5-2620 V3
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Hey guys I just noticed on my Skylake build, that I have no kexts in my 10.11 folder at all! Is this normal?
Yes

I've had it for a couple of months now so I cant remember the initial install phase, but surely you;d need at least FakeSMC?
FakeSMC.kext is probably in your /Library/Extensions or /System/Library/Extensions.
The installer does not access either of those locations so you should put FakeSMC.kext in /EFI/CLOVER/kexts/Other.
This will also enable you to use the Recovery partition too.

I'm a bit scared to put kexts in my /k/e folder just in case it messes with something?
No idea what that is.
 
Joined
Jul 19, 2016
Messages
26
Motherboard
MSI B85M Gaming
CPU
Intel Core i5 3.20 GHz 4460 Haswell
Graphics
NVIDIA GeForce GT 730 2GB GDDR5 with integrated Intel HD Graphics 4600
Mac
  1. iMac
Mobile Phone
  1. iOS
Please fill in your profile as required by the Rules, it should include Motherboard make and model, CPU model and graphics card or IGPU. Once you've filled out your profile are you using Chimera or Clover as your bootloader?
Sorry about that. I have filled in my form with all the information. I'm using clover as my bootloader. I have once tried to flawlessly update my yosemite 10.10 to 10.10.5 using app store, and the result was bootscreen restart loop. I have never tried anything and stuck with the 10.10 ever since.
 
Last edited:
Joined
Jun 26, 2012
Messages
4,096
Motherboard
Z170 Deluxe
CPU
i5-6600K
Graphics
GTX 970
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
  2. Other
Sorry about that. I have filled in my form with all the information. I'm using clover as my bootloader. I have once tried to flawlessly update my yosemite 10.10 to 10.10.5 using app store, and the result was bootscreen restart loop. I have never tried anything and stuck with the 10.10 ever since.
Thanks for filling out your profile, it will help us help you. Yes you should be able to update direct using this guide. Be sure to follow the instructions in Post#1, updating Clover and FakeSMC.kext before you update. Also ensure you've backed up your data, even better to make a bootable clone of your working installation drive.
 
Joined
Jul 19, 2016
Messages
26
Motherboard
MSI B85M Gaming
CPU
Intel Core i5 3.20 GHz 4460 Haswell
Graphics
NVIDIA GeForce GT 730 2GB GDDR5 with integrated Intel HD Graphics 4600
Mac
  1. iMac
Mobile Phone
  1. iOS
Thanks for filling out your profile, it will help us help you. Yes you should be able to update direct using this guide. Be sure to follow the instructions in Post#1, updating Clover and FakeSMC.kext before you update. Also ensure you've backed up your data, even better to make a bootable clone of your working installation drive.
Thanks for the reply. I have downloaded the latest clover yesterday.

EFI/Clover/kexts/10.10/
empty here
I know it doesn't matter. I understand that I have to make sure to copy the FakeSMC.kext in EFI/Clover/kexts/Others

But I also use other kexts like some of the voodoo kexts and AtherosE2200Ethernet.kext and maybe more I'm not sure about. My graphics worked out of the box.

But any update or modification I ever did, always caused losing the graphics. I don't know which kexts are used for my graphics. So can I simple copy everything from S/L/E to EFI/Clover/kexts/Others so that I won't have to worry about leaving any kext behind?
 
Joined
Oct 20, 2012
Messages
8
Motherboard
Gigabyte Z370P D3
CPU
i3 8350K
Graphics
RX 580
Mobile Phone
  1. iOS
I'm using a EVGA GTX970 with macOS Sierra build "16A323" and web driver 376.15.10.05f01 with an iMac 17,1 system definition, have you manually edited the graphics device policy through Terminal? This configuration is working for me.
http://www.tonymacx86.com/graphics/161256-solving-nvidia-driver-install-problems.html


Yeah did manually edit the graphics policy didnt work, but used AGDPfix.app and worked like a charm. Now onto getting audio working!

Edit: attached AGDPfix.app in case anyone needs it
 

Attachments

  • AGDPfix.app(1).zip
    79 KB · Views: 96
Joined
Jun 26, 2012
Messages
4,096
Motherboard
Z170 Deluxe
CPU
i5-6600K
Graphics
GTX 970
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
  2. Other
Thanks for the reply. I have downloaded the latest clover yesterday.

EFI/Clover/kexts/10.10/
empty here
I know it doesn't matter. I understand that I have to make sure to copy the FakeSMC.kext in EFI/Clover/kexts/Others

But I also use other kexts like some of the voodoo kexts and AtherosE2200Ethernet.kext and maybe more I'm not sure about. My graphics worked out of the box.

But any update or modification I ever did, always caused losing the graphics. I don't know which kexts are used for my graphics. So can I simple copy everything from S/L/E to EFI/Clover/kexts/Others so that I won't have to worry about leaving any kext behind?
Install your ethernet Kext and FakeSMC only to EFI/Clover/Kexts/Others. Make a back up folder of your used kexts on the desktop. The graphics kexts are included in macOS Sierra. You shouldn't need to do anything different to your graphics injection that is not already been done in Yosemite. Once you get macOS Sierra installed you can then use KextBeast to install your Voodoo kexts. I'm not sure if audio will work you may have to update your drivers.
 
Top