Contribute
Register

Direct Update to macOS Sierra using Clover

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,400
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
HD 4600 / RX 580
@livingJAZZ, please update your profile (personal details) with your Motherboard, CPU and iGPU or Graphics Card.
If you have a prebuilt computer enter make and model instead of motherboard.
The Rules said:
Profiles are mandatory so that others can assist you.
 
Joined
Feb 23, 2013
Messages
23
Motherboard
Gigabyte Z68Xp-UD3P
CPU
i5 > Need model # > See Rules!
Graphics
GT 710
@livingJAZZ, please update your profile (personal details) with your Motherboard, CPU and iGPU or Graphics Card.
If you have a prebuilt computer enter make and model instead of motherboard.
@BreBo Yes Sorry!!! Now done! I hope that with the components that I have I can do an update from 10.8 to 10.12 (Sierra) without losing data?? Thanks Again
 
Last edited:
Joined
Aug 18, 2016
Messages
15
Motherboard
Asus Z170i Pro Gaming
CPU
i7
Graphics
GTX 950
Mac
  1. iMac
Hey Guys, i directly upgraded my Setup with this Thread and it worked great. I just had no Sound after the Upgrade. But this is not hard to fix.
 
Joined
Apr 15, 2017
Messages
7
Motherboard
Gigabyte z97-HD3
CPU
i7 4790K
Graphics
GTX 970
Mac
  1. iMac
Mobile Phone
  1. iOS
5. When Clover boot screen appears, choose Boot macOS Install option (Example: Boot macOS Install from Macintosh HD). Choosing your system drive will go back to your previous installation without updating. Press spacebar to enter Boot Options and choose Without Caches option and/or Inject Kexts option then Boot Mac OS X with selected options.
Hi, im trying this but im stuck at "gIOsceenlockstate 3, hs 0, bs 0, sm 0x0" during installation process. So it wont finish of the installation. I have lilu and whatevergreen kext in my EFI, but booted macOS install without inject kext. Should i try to run installer with kext or do some one have any suggestions?

(i have El Capitan 10.11.2 running on a imac 14.2 sysdef.)

UPDATE:
I ran installation with inject kext and it installed fine.
 
Last edited:
Joined
May 3, 2012
Messages
3
Motherboard
GA-H77-DS3H
CPU
Intel Core i5 3750k
Graphics
EVGA nVidia GTX560 SE
Mac
Classic Mac
Mobile Phone
  1. iOS
So, I tried to venture out to do the upgrade (from El Cap to Sierra). It started the install. However, when it rebooted all I see now is the clover boot loader with no system drive to boot from at all. I am not sure what I did wrong here. But, there are no options to “boot from Mac OS” or previous os or anything. Only boot options menu, options, restart and exit (oh and a shell option). Is there anything I can do to get this back at all?

I tried putting in a Sierra USB drive to boot up and see if there was something diskutils would show me but it didn’t even have my boot drive on there at all. Only thing I could see were my other data drives, etc. There was one drive that was 500gb that I “think” may have been the original El Cap system drive but I am not sure. It says it is unformatted.

Any help would be greatly appreciated (I knew I should not have attempted this upgrade after having a steady El Capitan system for so long....ugh.....). Thanks!
Did you ever solve this issue? I'm running into the exact same problem now.
 
Top