Contribute
Register

Direct clean install 10.14.4 on NUC8i7BEH with minimal tweaks [10.14.5 Success]

Joined
Jun 14, 2019
Messages
3
Motherboard
Intel NUC8i7BEB (J72688-303)
CPU
Intel Core i7-8559U
Graphics
Intel IrisTM Plus Graphics 655
Normally as 10.14.5 update worked smoothly,
Hi, I got my NUC today, the BIOS is v64, I upgrade to v71
then install 10.14.5 without problem.
The 32GB RAM & UMAX 1TB PCIe M.2 also works fine.
Thanks for your great intro.
 
Joined
Jul 19, 2010
Messages
83
Motherboard
Intel NUC8i7BEH2
CPU
i7-8559U
Graphics
Iris Plus 655
Mac
MacBook Air
Mobile Phone
iOS
Hi everyone, I wanted to ask for your feedback on a couple of things, hopefully you've experimented a little like myself.

a) I am still getting the yellow front-panel LED working intermittently, i.e. not everytime and not every reboot. Does your NUC's HDD yellow LED works all the time? And if yes, how did you manage it? I have personally loaded mine with both NVMe and SSD as storage but... can't figure out what's wrong. Perhaps BIOS v56 has an issue.

b) Do you have fan RPM readings in any of monitoring tools available?

This feature is directly dependent on FakeSMC's plugins on older hacks. On my old NUC, the plugin org.hwsensors.driver.LPCSensors detects OK my Nuvoton NCT6776F chipset that controls the fan, and I get readings. Do you have managed this yet?

Intel's motherboard documentation shows that our NUC8ixBEHx uses the ITE IT8987E-VG chipset (ID = 0x8987) but doesn't seem to be detected by plugins, as it's rather new.

Despite FakeSMC being available for a long time, it seems abandonware (the original one) and I have not found a build that's maintained so far (like RehabMan's repository) except HWSensors3 effort over at SourceForge.

3) For this reason above, I tried VirtualSMC and plugins as a total replacement to FakeSMC (be careful) as they are a pretty recent project that's bound to evolve much more but no support for our ITE chipset yet. Have anyone been using it? Is it stable for you? Latest version v1.0.4 causes my system to become unstable, though...

You can find VirtualSMC at https://github.com/acidanthera/VirtualSMC
You can find HWSensors3 at https://sourceforge.net/projects/hwsensors3.hwsensors.p/

Please be sure you know what you do if you experiment using VirtualSMC, you need to totally remove FakeSMC and its plugins and read their instructions on how to install VirtualSMC.

Thanks!
 
Last edited:
Top