Contribute
Register

Desperate X99 SLI PLUS + Intel 6850K owner, looking for a solution for "memory allocation" error

Joined
Oct 30, 2016
Messages
47
Motherboard
MSI X99S-SLI-PLUS
CPU
Intel i7-6850K
Graphics
GeForce GT 740
Mac
MacBook Pro
Mobile Phone
Android, iOS
Hey folks,

I've lost countless days and nights trying to "convince" my hackintosh to - at least! - start the installation.

Tried all possible combinations between these files:
  • OsxAptioFixDrv-64.efi
  • OsxAptioFix2Drv-64.efi
  • OsxAptioFix2Drv-free2000.efi
  • Test2.efi
  • Test2-2016.efi
I've also tried:
  • this
  • boot with "npci=0x2000 cpus=1 busratio=32"
  • CsrActiveConfig "0x67" in config.plist + npci=0x2000 cpus=1 busratio=32 + FakeCPUID=0x040672 and FakeCPUID=0x040674
  • also tried to boot with -x GraphicsEnabler=Yes UseKernelCache=No
I think I've read all topics on this forum. Still NOTHING. I'm still getting that "memory allocation" error.

I have no idea what I'm doing wrong or how to fix this. I will be VERY grateful if somebody would give me a hint.

Thank you very much!
 
Last edited:
Joined
Jul 16, 2012
Messages
44
Motherboard
Asus Zen Book UX430UA
CPU
i7 8550
Graphics
620 UHD
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS, Other
There are many solutions to your hardware in this forum and I have posted on several.

I have a Broadwell-E like yours.

1. Make sure you have the latest version of clover installed on your boot usb stick.
2. darkwake=0, dart=0 npci=3000
3. To get it past the ++++++++++++++++ / Memory Allocation Failure Error

Make sure you only have the min required drivers in the drivers64UEFI folder.

For me, this was the only three files I had in the folder.

OsxAptioFix-2000.efi,
FSInject.efi
HFSPlus-64.efi

Use the USB3 Ports

There is a IOPCIFamily Kext to Patch for 5960X - look it up on google or this forum - apply it.
Also apply the USB Fix as needed.

GRAPHICS RELATED:
Depending on the nVidia cards add nv_disable=1.
IN THE BIOS/EFI - PLEASE ENABLE (YES ENABLE) CSR COMPATIBILITY MODE - (This is for when you install the nvidia web drivers and your display sleeps on boot). Using CSR compatibility mode will prevent your display to go to sleep mode on boot.
 
Joined
Oct 30, 2016
Messages
47
Motherboard
MSI X99S-SLI-PLUS
CPU
Intel i7-6850K
Graphics
GeForce GT 740
Mac
MacBook Pro
Mobile Phone
Android, iOS
1. Make sure you have the latest version of clover installed on your boot usb stick.
Should I manually patch Clover or just go with the default UniBeast?

There is a IOPCIFamily Kext to Patch for 5960X - look it up on google or this forum - apply it.
I'm having a i7-6850K. Or aren't you talking about CPU?

Thank you so much for your advice!
 
Joined
Oct 30, 2016
Messages
47
Motherboard
MSI X99S-SLI-PLUS
CPU
Intel i7-6850K
Graphics
GeForce GT 740
Mac
MacBook Pro
Mobile Phone
Android, iOS
There are many solutions to your hardware in this forum and I have posted on several.

I have a Broadwell-E like yours.

1. Make sure you have the latest version of clover installed on your boot usb stick.
2. darkwake=0, dart=0 npci=3000
3. To get it past the ++++++++++++++++ / Memory Allocation Failure Error

Make sure you only have the min required drivers in the drivers64UEFI folder.

For me, this was the only three files I had in the folder.

OsxAptioFix-2000.efi,
FSInject.efi
HFSPlus-64.efi
Same error: Couldn't allocate runtime area. Any hints?
 
Joined
Mar 15, 2017
Messages
1
Motherboard
ASUS X99-A
CPU
Intel Core i7-6900K
Graphics
MSI GTX-960
I'm having a memory allocation error on an Intel i7 6900k, any headway you make would be much appreciated.
 
Top