Contribute
Register

Dell XPS 8930 High Sierra Guide 10.13.6 (Nvidia 1050Ti)

Joined
May 29, 2018
Messages
39
Motherboard
Dell XPS 8930
CPU
i7-8700
Graphics
RX 580
This model comes with a power supply of 460W. The maximum power consumption of the RX 580 is 185W for most models. The PSU's recommendation is 500W, so it should be enough. The RX 590 requires a little more, since its consumption is on average 215W or more.

I do not have access to my PC now to be able to confirm, but according to that matter in pcworld (here), that same PSU comes in models with GTX 1080 and its limit is 225W.
Problem is the OEM GPU doesn’t have the connectors for the rx580 which requires dedicated power supply.

Size still matters. The 260mm cards would go over my NVMe SSD so I’m not sure if that’s a good idea. Maybe a Sapphire Pulse is more appropriate, but then heat dissipation would be another issue. ATI is just not a very efficient graphics chip imo.
 
Joined
May 29, 2018
Messages
39
Motherboard
Dell XPS 8930
CPU
i7-8700
Graphics
RX 580
Hi Dandelionclock

I finally got around to doing a bit of testing - this is what I did

My original install followed your original guide and has been working well but I have been unable to upgrade to mojave because of the NVIDIA 1050 Ti

I recently got a MSI Radeon RX 560 with 4gb ram, which I tested in a real mac pro with mojave and it seemed to work fine. I chose this card because it didnt need any additional power connection (like the NVIDIA card that comes with the XPS 8930)


I cloned my existing hard drive (high sierra) onto a new SSD and after removing the NVIDIA drivers, I followed these steps in your mojave guide (#15)

  • Remove IntelGraphicsFixup, NvidiaGraphicsFixup, and Shiki from /Library/Extentions. These have been replaced with WhateverGreen
  • Install WhateverGreen with KextBeast or Clover Configurator
The MSI Radeon card isn't big, but it was a snug fit inside the dell case. Ultimately the card was just the right size and there were no problems putting everything back together

The machine booted up perfectly back in to high sierra and I just let the computer upgrade itself via the app store and all seems OK so far

I didnt make any changes to the files in the EFI folder from the original install - everything seems to be working just as it did when the original NVIDIA card was in the machine
Mind if you upload your configuration plist? I got myself an RX580 and I’m having trouble with the IGPU. It seems 10.14.4 broke something but I haven’t had time to look into it very deeply.
 
Joined
Jan 31, 2011
Messages
103
Motherboard
Dell XPS 8930
CPU
i7 8700
Graphics
UHD 630 / Radeon RX 560
Mac
iMac, MacBook, Mac Pro
Classic Mac
iBook, Power Mac
Mind if you upload your configuration plist? I got myself an RX580 and I’m having trouble with the IGPU. It seems 10.14.4 broke something but I haven’t had time to look into it very deeply.
will do - i am not able to get in front of my dell machine at the moment, probably till tomorrow
however, in the meantime - i literally did not change a thing from your original guide for high sierra...i am on 10.44 as well and the 560 seems to be working ok (or i havent noticed anything that was broken since i swapped the graphics cards and updated to mojave)

will upload the config later or tomorrow
 
Joined
May 29, 2018
Messages
39
Motherboard
Dell XPS 8930
CPU
i7-8700
Graphics
RX 580
Thanks. My upgrade process had some problems so I ended up creating a usb installer with unibeast and installed over my existing HS.

Some people were saying apple changed something in 10.14.4 that causes problem with UHD 630 and whatever green. I cannot keep SMBIOS 18,3, and that causes me to lose hardware accelleration
 
Joined
May 29, 2018
Messages
39
Motherboard
Dell XPS 8930
CPU
i7-8700
Graphics
RX 580
will do - i am not able to get in front of my dell machine at the moment, probably till tomorrow
however, in the meantime - i literally did not change a thing from your original guide for high sierra...i am on 10.44 as well and the 560 seems to be working ok (or i havent noticed anything that was broken since i swapped the graphics cards and updated to mojave)

will upload the config later or tomorrow
I ended up wiping my drive completely and did a Mojave’s clean install. Worked on first try. Must have been some old kext messing up my upgrade.
I’ll start a new thread in the Mojave forum later to document my steps. Basically it’s a much simpler version of this since rx580 pretty much works out of the box..
 
Joined
Jan 31, 2011
Messages
103
Motherboard
Dell XPS 8930
CPU
i7 8700
Graphics
UHD 630 / Radeon RX 560
Mac
iMac, MacBook, Mac Pro
Classic Mac
iBook, Power Mac
I ended up wiping my drive completely and did a Mojave’s clean install. Worked on first try. Must have been some old kext messing up my upgrade.
I’ll start a new thread in the Mojave forum later to document my steps. Basically it’s a much simpler version of this since rx580 pretty much works out of the box..
excellent news dandylionclock - i am glad it worked for you. let me know if you still need my config (i am guessing probably not now) and I will upload later today

on a related note, did you have any trouble physically fitting the card into the case? which version of the rx580 did you end up getting?
 
Joined
May 29, 2018
Messages
39
Motherboard
Dell XPS 8930
CPU
i7-8700
Graphics
RX 580
excellent news dandylionclock - i am glad it worked for you. let me know if you still need my config (i am guessing probably not now) and I will upload later today

on a related note, did you have any trouble physically fitting the card into the case? which version of the rx580 did you end up getting?
Thanks a lot again. I think I’m good. I let migration assistant ran overnight to recover my time machine backup. All looks good.

I ended up getting the Sapphire Nitro+. Length wise it’s just enough. It will go over my NVMe drive but I’ve seen pictures of other XPS 8930 owners doing the same so I suppose it’s alright. Height wise though you would need to drill out the triangular piece of metal underneath the power supply unit or you won’t be able to swing the PSU back in place. Pretty easy to do.

Now I am more concerned about cooling because the 580 can be a furnace. It also effectively partition the entire case into two halves, blocking airflow. I may have to add a fan somewhere if I play graphics-intensive games on it.
 
Joined
Jan 31, 2011
Messages
103
Motherboard
Dell XPS 8930
CPU
i7 8700
Graphics
UHD 630 / Radeon RX 560
Mac
iMac, MacBook, Mac Pro
Classic Mac
iBook, Power Mac
just out of interest, how difficult/practical or impractical would it be to take the motherboard out of the dell case and put it in to a bigger box?
 
Joined
May 29, 2018
Messages
39
Motherboard
Dell XPS 8930
CPU
i7-8700
Graphics
RX 580
just out of interest, how difficult/practical or impractical would it be to take the motherboard out of the dell case and put it in to a bigger box?
Now I’m stuck in a boot loop because APFSDiverLoader in clover cannot locate APFS.efi from my fusion drive, and I need the system to boot up in order to get 10.14.4’s APFS.efi, so I’m in a catch-22
 
Top