Contribute
Register

Dell XPS 7590 FHD (Nearly Complete)

Joined
Dec 16, 2019
Messages
15
Motherboard
Dell XPS 7590
CPU
i9-9980HK
Graphics
GTX 1650
Mac
  1. MacBook Pro
Alright I got mostly everything working,
Hi pmdevita, I reading up on your posts since I'm also new to this.
Can you please specify what's still not working?
 
Joined
Dec 16, 2019
Messages
15
Motherboard
Dell XPS 7590
CPU
i9-9980HK
Graphics
GTX 1650
Mac
  1. MacBook Pro
After a lot of reading (first time doing this), i got it working with Bavariancake's EFI without problems.
I got DELL XPS 7590 i9 with Nvidia GTX 1650 and Killer AX1650. For the wifi, just for testing now i purchased TP4 usb link and works like a charm. Ill think about buying a DW1380. Apart of what @pmdevita said, i confirm that Thunderbolt is working with 2 monitors connected through a belkin dock (one with usb-c and another to DP)
Also, Goodix Fingerprint is not working, i did not find how to set it up.

edit: laptop screen turns off as it only supports 2 monitors at the same time.

Update: laptop screen works along with the other two monitors after going back from suspense
Hi Diguezz, it seems I'm not the only one with the same model as you have.
Do you care to put your guide online?
And which things are still not working properly?
 
Joined
Dec 16, 2019
Messages
15
Motherboard
Dell XPS 7590
CPU
i9-9980HK
Graphics
GTX 1650
Mac
  1. MacBook Pro
After a lot of reading (first time doing this), i got it working with Bavariancake's EFI without problems.
I got DELL XPS 7590 i9 with Nvidia GTX 1650 and Killer AX1650. For the wifi, just for testing now i purchased TP4 usb link and works like a charm. Ill think about buying a DW1380. Apart of what @pmdevita said, i confirm that Thunderbolt is working with 2 monitors connected through a belkin dock (one with usb-c and another to DP)
Also, Goodix Fingerprint is not working, i did not find how to set it up.

edit: laptop screen turns off as it only supports 2 monitors at the same time.

Update: laptop screen works along with the other two monitors after going back from suspense
Hi Diguezz, it seems I'm not the only one with the same model as you have.
Do you care to put your guide online?
And which things are still not working properly?
 
Joined
Dec 22, 2019
Messages
3
Motherboard
Dell 9570
CPU
9750h
Graphics
1650
Hi Diguezz, it seems I'm not the only one with the same model as you have.
Do you care to put your guide online?
And which things are still not working properly?
Hi Kineticone have you try to install hackintosh on that XPS 7590 4k working? for me it's not working it's just loop boot at the boot installtion, and now i don't know what to do?
 
Joined
Dec 16, 2019
Messages
15
Motherboard
Dell XPS 7590
CPU
i9-9980HK
Graphics
GTX 1650
Mac
  1. MacBook Pro
Hi Kineticone have you try to install hackintosh on that XPS 7590 4k working? for me it's not working it's just loop boot at the boot installtion, and now i don't know what to do?
Hi seyhadot,
Not yet, since it's my only laptop, I can't risk erasing win, without having a complete unusable device.
Hence, the question above.
 
Joined
Feb 17, 2020
Messages
2
Motherboard
Dell XPS 7590
CPU
i7-9750H
Graphics
GTX 1650
Hello,

I would like to circle back to this thread if possible... I have been trying a vanilla install of Mojave on my laptop (4k touch model), and have run into the same problems with many different EFI folders. On boot of the installer, a kernel panic hits after "failed loading /sbin/launchd errno2". I have tried Bavariancake, LuletterSoul, and sevendaye's EFI folders, each time to no avail. If anyone has success with this, please let me know. Thanks!
 
Joined
Jul 4, 2013
Messages
103
Motherboard
HP EliteDesk 800 G5 mini | Dell XPS 15" 7590
CPU
i5 9600 | i7 9750H
Graphics
UHD 630 | Iris Plus 655
Hello,

I would like to circle back to this thread if possible... I have been trying a vanilla install of Mojave on my laptop (4k touch model), and have run into the same problems with many different EFI folders. On boot of the installer, a kernel panic hits after "failed loading /sbin/launchd errno2". I have tried Bavariancake, LuletterSoul, and sevendaye's EFI folders, each time to no avail. If anyone has success with this, please let me know. Thanks!
I needed to change the NVMe Drive because if this reason. With the SK Hynix that came with my laptop, I couldn't Boot the installer. Changed It with a Crucial P1 and working flawlessly. Check the model of your Drive in BIOS to see If It is compatible with hackintosh.
 
Joined
Feb 17, 2020
Messages
2
Motherboard
Dell XPS 7590
CPU
i7-9750H
Graphics
GTX 1650
I needed to change the NVMe Drive because if this reason. With the SK Hynix that came with my laptop, I couldn't Boot the installer. Changed It with a Crucial P1 and working flawlessly. Check the model of your Drive in BIOS to see If It is compatible with hackintosh.
I do have the SK Hynix one... I had hoped this would not be an issue, but so much for that. I really don’t want to scrap my windows install and such, but I do have another smaller drive hanging around. I will try with that to see if it works. In the meanwhile, if anyone finds fixes to support the 512 from Hynix please let me know. I am desperate :lol:. Thanks.

also, if anyone knows where to find what NVMe drives are compatible please reply.
 
Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
21,502
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I do have the SK Hynix one... I had hoped this would not be an issue, but so much for that. I really don’t want to scrap my windows install and such, but I do have another smaller drive hanging around. I will try with that to see if it works. In the meanwhile, if anyone finds fixes to support the 512 from Hynix please let me know. I am desperate :lol:. Thanks.

also, if anyone knows where to find what NVMe drives are compatible please reply.
 
Joined
Feb 28, 2020
Messages
4
Motherboard
Dell XPS 15 7590 FHD
CPU
i7-9750H
Graphics
GeForce GTX 1650 (4GB GDDR5)
I've been trying to install your setup among the most popular ones (bavariancake, LuletterSoul..) and I got always a kernel panic during installation. Also tried with Catalina and Mojave and both with the same problem.

My dell xps config:
Dell XPS 15 7590 i7-9750H
16GB RAM
SSD SK Hynix pc601 512GBgot i
GeForce(R) GTX 1650 / Intel UHD Graphics 630

I suspect that it might be because os the SSD is not compatible but I don't know how to confirm that. Also this is the output when installing just before getting the kernel panic
Code:
Kernel Extensions in backtrace:
com.apple.iokit.IONVMeFamily(2.1)
dependency: com.apple.driver.AppleMobileFileIntegrity(1.0.5)
dependency: com.apple.iokit.IOPCIFamily(2.9)you 
dependency: com.apple.driver.AppleEFINVRAM(2.1)
dependency: com.apple.iokit.IOStorageFamily(2.1)
dependency: com.apple.iokit.IOReportFamily(47)

I've disabled secure boot in bios and using AHCI mode.

Any chance you guys can point me to the right direction please?

[EDIT]
Finally I got it, I'm typing now from my hackintosh it was necessary to change the ssd as the hynix is not compatible so I bought a crucial P1 1TB and it works out the box. Mac os detected my laptop as an i9 which is a bit weird so I still have to start polishing until fixing those details. BTW thanks @pmdevita for sharing your clover folder it's a good start, I've included https://github.com/acidanthera/NVMeFix with the hope of having optimized power management for the ssd
 

Attachments

  • Captura de pantalla 2020-02-28 a las 19.44.20.png
    Captura de pantalla 2020-02-28 a las 19.44.20.png
    3.2 MB · Views: 36
Last edited:
Top