Contribute
Register

Dell XPS 15 9570 MacOS Mojave

Feartech

Moderator
Joined
Aug 3, 2013
Messages
12,558
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
Android
Thanks, that worked also pretty well. System boots now from external USB-SSD with Mojave on it.

Which way do I have to go now to get some stuff optimized?

Working:
OnBoard Audio/Mic
Bluetooth is ON and works with a mouse, but can't be switched OFF

Stuff I would like to fix:
UHD630 shows 31 MB VRAM ... how can I check if QE is working, guess it isn't .. any chance?
Display offers 3840x2160 and 1920x1080, but in UHD it doesn't scale text or UIView attachment 402602View attachment 402603View attachment 402604View attachment 402605
if your wifi is intel, then you will need to replace the hardware

for your graphics:
make sure lilu and whatevergreen kexts are installed

Use this tool and upload your problem reporting files:
 
Joined
Dec 27, 2013
Messages
8
Motherboard
Dell XPS 15 9570-1.8.1
CPU
i7-8750H
Graphics
UHD 630, GTX 1050 Ti
Classic Mac
Power Mac
Mobile Phone
Android
Hi there,

tried some things, installed the latest Whatevergreen 1.2.8 on HD in /L/E ... still get UHD with 31 MB VRAM

I use the Bluetooth Pan to get Internet via my mobile and did two problem reporting zips ( debug_31946 is with system dun in txt ) from the tool (see attachment).

Would be happy to get QE activated and full VRAM.

Another question I have is about Clover ... how do I change the size so that the 4k screen shows everything a little larger before I boot?

Thanks a lot guys!
 

Attachments

Joined
Dec 20, 2018
Messages
325
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
i7-8700K OC 5GHz
Graphics
GTX 1080 Ti & UHD 630
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Hi there,

tried some things, installed the latest Whatevergreen 1.2.8 on HD in /L/E ... still get UHD with 31 MB VRAM

I use the Bluetooth Pan to get Internet via my mobile and did two problem reporting zips ( debug_31946 is with system dun in txt ) from the tool (see attachment).

Would be happy to get QE activated and full VRAM.

Another question I have is about Clover ... how do I change the size so that the 4k screen shows everything a little larger before I boot?

Thanks a lot guys!
you need Lilu and need to boot with -cdfon flag and might also need lilucpu=9 boot flag. also, did you disable the 1050ti? also, it is recommended that you patch the Framebuffer to boost vram to 2048mb when using 4k screen. you also may need to enable HIDPL to get correct resolution enabled.
 
Joined
Sep 12, 2018
Messages
18
Motherboard
Dell XPS 15 9570 - Clover
CPU
i7-8750H/CM246
Graphics
GTX 1050 Ti - UHD 630. 1920 x 1080
Mac
MacBook Pro
@NicolasGT: you can try out my rebuilt ALC299 for XPS13 9370. #31
It still doesn't work for me, I used your ALC299 but I guess it's different for my 15" xps 9570.
did you use 58 as the layout-id? I can only get it to work with 72, this enables the main system speakers, microphone but the headphone jack has no amplification and is barely audible.

Anyone with tips for getting amplification on the headphone jack?

Thanks
 

Top