Contribute
Register

Dell XPS 15 9570 i7 8750H - Sleep issues, power consumption

Joined
Apr 20, 2017
Messages
13
CPU
I5 6400HQ
Graphics
Intel HD 530+nVidia 950m
Hello,
I have an XPS 15 9570 with an i7 8750H, 16GB RAM, 4K screen and Kingston A1000 NVMe SSD. I have Mojave installed and have been able to fix a few things so far (iGPU acceleration, brightness control, sound, etc working), but i'm left with a few issues which I don't know how to fix:

- Sleep: When I put the laptop to sleep, it will either wake up but with a completely black screen (no backlight), or it will not wake up at all and crash.

- Brightness control: Brightness control works, however it feels like the range is limited: seems like brightness control under macOS ranges from 1% (minimum brightness - no backlight off) to around 50% max brightness. Don't know where or how I can fix this, however this isn't an immediate issue as this display is very bright anyways.

- Power consumption: I think that the CPU has correct power management (On idle, it stays often at 800MHz, and will jump up whenever there is relevant load) however it seems that power consumption on idle in macOS is higher than under Windows.

With the Intel Power Gadget installed on both macOS and Windows, I can see that on macOS the machine idles at 800MHz and PKG (Package Power)'s lowest value is around 1.5W, whereas on Windows, the machine idles at slightly higher frequencies yet has an overall Package Power minimum value of 0.5W. Whilst the difference between 1.5W and 0.5W may not seem like much, keep in mind that this is 3x more power consumption in idle under macOS! On macOS, besides the PKG values in Intel Power Gadget, there is Core and DRAM values - Core seems to hover as low as 0.3W but DRAM consistently stays around 0.9 or higher.

Some things to note that could potentially be a factor:

- Killer 1535 (Unsupported) WiFi card still installed in machine - waiting on replacement DW1560

Currently on SMBIOS MacbookPro 15,2. Tried 15,1 as well as I thought it would be a closer fit however there was no impact, positive or negative, so I went back to 15,2.

Attached my Clover folder and IOREG.

Thanks in advanced.
Hello, I have the same laptop (Dell XPS 15 9570). Can you or someone please help me with the installation? I could not find an easy-to-follow or complete guide. I have some experience but not that much so I would appreciate any kind of help especially from those who have the same laptop. :)

Thank you
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,974
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hello, I have the same laptop (Dell XPS 15 9570). Can you or someone please help me with the installation? I could not find an easy-to-follow or complete guide. I have some experience but not that much so I would appreciate any kind of help especially from those who have the same laptop. :)

Thank you
Follow the Clover guide linked from the FAQ.
http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html

Although you should read the FAQ for an overview of issues, the Clover guide is linked from the first question: "Q. Where do I start?", just after the bold face "Clover Guide".
Here is a direct link, just to be clear:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

Also, your profile must be filled out with complete details as requested in the FAQ, again under "Q. Where do I start?". All seven details requested are equally important.

And if you have an issue (after following the guide), or on any other problem, you must provide a detailed description of the problem including information that helps us understand what you're doing. Always attach "Problem Reporting" files as per FAQ.
http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html
The required files and data are fully detailed in the last question in the FAQ:
"Q. What are typical "Problem Reporting" files?"
 
Top