Contribute
Register

Dell XPS 13 9380 installation story and issues

Status
Not open for further replies.

Feartech

Moderator
Joined
Aug 3, 2013
Messages
25,934
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I removed AppleALC since it wasn't working. I don't believe the audio chipset (Realtek ALC3271) is supported. Do you have any suggestions on how my config file should be set up to get it working?

I keep the kexts in the Off folder as a backup but I prefer to have them in Library/Extensions. Any reason that would cause issues?
according to post 1, then you will have to use VoodooHDA instead

you should still have essential kexts in clover/kexts/other for upgrades

 
Joined
Apr 30, 2020
Messages
33
Motherboard
Dell XPS 9700 (OpenCore)
CPU
i7-10875H
Graphics
UHD 630, 1980x1200
according to post 1, then you will have to use VoodooHDA instead

you should still have essential kexts in clover/kexts/other for upgrades


I'll look into that post, thanks!

Yes, I tried VoodooHDA as well. Unfortunately, couldn't get it to work either. captainR0bbo seemed to figure out how to get it working but I haven't been able to.
 
Joined
Sep 19, 2019
Messages
14
Motherboard
Dell XPS 13 9380
CPU
i7-8565U
Graphics
UHD 620
Mac
  1. MacBook Pro
I'll look into that post, thanks!

Yes, I tried VoodooHDA as well. Unfortunately, couldn't get it to work either. captainR0bbo seemed to figure out how to get it working but I haven't been able to.
Each time i booted it defaulted to headphones as the default output device for audio (which didn't work). I had to manually change it to the speadkers. Can you check if you audio output device is set to the speakers?
 
Joined
Apr 30, 2020
Messages
33
Motherboard
Dell XPS 9700 (OpenCore)
CPU
i7-10875H
Graphics
UHD 630, 1980x1200
I was able to update to Catalina 15.4 and then updated to 15.5. As far as I can tell, everything is still working.

I needed the SSDT-EC patch to get the update to install and boot. I also ran into errors as the install continued. I simply hit restart and continued selecting the install drive in Clover as if no errors had happened. The installs eventually were successful despite the errors.

I tested Sidecar and it works using a wired connection, though I couldn't figure out how to make it work wireless.
I still haven't tackled audio. Will post back when I do.
 
Last edited:
Joined
May 16, 2020
Messages
2
Motherboard
Dell XPS 13 9380
CPU
Intel i5-8265u
Graphics
Intel UHD 620
I was able to update to Catalina 15.4 and then updated to 15.5. As far as I can tell, everything is still working.

I needed the SSDT-EC patch to get the update to install and boot. I also ran into errors as the install continued. I simply hit restart and continued selecting the install drive in Clover as if no errors had happened. The installs eventually were successful despite the errors.

I tested Sidecar and it works using a wired connection, though I couldn't figure out how to make it work wireless.
I still haven't tackled audio. Will post back when I do.

That is awesome! Would you be willing to share your EFI? I have the same specs and can tweak as needed. Thanks!
 
Joined
Apr 30, 2020
Messages
33
Motherboard
Dell XPS 9700 (OpenCore)
CPU
i7-10875H
Graphics
UHD 630, 1980x1200
Sure. I think I did earlier in the thread, but here's another copy that's hopefully organized a bit better. I installed my kexts in the Library/Extensions folder but you should be able to leave them in the Kexts/Other folder on the EFI partition.
 

Attachments

  • Clover For Upload 2.zip
    6 MB · Views: 58
Joined
Oct 22, 2020
Messages
1
Motherboard
xps-9380
CPU
i7-8565u
Graphics
hd620
Mobile Phone
  1. Android
Status
Not open for further replies.
Top