Contribute
Register

Dell Precision M6800 Workstation Hackintosh Guide

Joined
May 9, 2014
Messages
6
Motherboard
Dell Precision M6800
CPU
i7-4910MQ
Graphics
K3100M
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
if it is optimus then only your intel graphics will work

Use this tool and upload your problem reporting files:
I've installed that tool by following instructions and generated the report. (attached)
 

Attachments

  • debug_10558.zip
    236.5 KB · Views: 27
Joined
May 9, 2014
Messages
6
Motherboard
Dell Precision M6800
CPU
i7-4910MQ
Graphics
K3100M
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
TY very much Precision M6800. Your EFI folder not only allowed me to clean install Mojave on my M6800 (I've been trying, since before it's release to public), but also worked in my High Sierra & allowed me to upgrade to Mojave (always failed blackscreen prior). Both installations worked AOK with exception of getting the Audio to work, but I'm certain that other fixes will pop up eventually. I did try your Audio fix in the clean 1st (failed), then the upgrade afterwards, since it's Audio worked AOK prior to the upgrade, but still no device shows up.
View attachment 362509

Update: NVM. I got'er done on a clean install & using MultiBeast-High-Sierra-Edition-10.4.0 to install the Audio & Lilu.

Thanks again Precision M6800. Your success led me to mine. I'm very pleased with the faster startup than was in High Sierra. I prolly had it too garbaged up with unnecessary kexts.

which EFI folder you replaced? from "EFI Dell Precision" or "Final EFI 30 Nov Fix"
 

Attachments

  • Screen Shot 2019-06-02 at 2.50.51 PM.png
    Screen Shot 2019-06-02 at 2.50.51 PM.png
    76.1 KB · Views: 164
Last edited:
Joined
Sep 4, 2011
Messages
16
Motherboard
Dell Precision 7730-Clover
CPU
E-2186M
Graphics
P3200 + UHD P630, 1920x1080
MODIFIED (Final Update 30 Nov 2018)

For Mojave and High Sierra


Here's my final EFI update for Dell precision m6800 with alots of fixes and tweaks ; just download and install Nvidia web driver for High Sierra

- Fully working everything audio , Bluetooth, Ethernet , wifi , mSata , Card reader ....
- Bios Reset fixed
- Brightness Slider
- Optimus Graphic
- Use Intel HD only or Intel HD + Nvidia (if you want Nvidia only then disable Optimus in bios)
- What is missing and doesn't work ?
You tell me
- all fixes files and instructions are included




Thank You ...

NB : this guide will work 99% with any similar model from Dell as M4800 ....

Links for my old EFI is below ; just use it for Nvidia only with Optimus Graphics disabled in Bios

Thank you very much for your effort in making this working, I want to ask though: I have a Dell Precision 7730 and I also suffer from the dreaded "Enable Switchable Graphics" button reset. I wanted to know how you managed to fix it.

Thank you again for your time
 
Joined
Jul 20, 2019
Messages
1
Motherboard
dell int
CPU
i7 4810MQ
Graphics
nvidia quadro k1100M
thanks for your clover, i success full install mac in m4800 but wifi not working, card wifi is intel. what type card wifi in your laptop?
 
Joined
Aug 18, 2019
Messages
3
Motherboard
Dell Precision 7730
CPU
E-2186M
Graphics
Nvidia Quadro P4200
Thank you very much for your effort in making this working, I want to ask though: I have a Dell Precision 7730 and I also suffer from the dreaded "Enable Switchable Graphics" button reset. I wanted to know how you managed to fix it.
Thank you again for your time

Hi mk2soldier. Could you tell me whether you have succeeded in installing macOS (High Sierra/ Mojave) on the Dell Precision 7730, and if so, what's working and what's not?
Needless to say that any pointer/help will be much apprecaited.
Thank you.
 
Joined
Sep 4, 2019
Messages
1
Please help
The installation stuck after the first time i boot from ssd to continue the installation
Do not know what to do
 
Joined
Oct 30, 2019
Messages
14
Motherboard
Dell M4800
CPU
i7-4900MQ
Graphics
HD 4600 & Quadro K2100M
Trying to install on a Dell Precision M4800 with A25 bios and nVidia Quadro K2100.

I used this guide https://www.tonymacx86.com/threads/dell-precision-m6800-workstation-hackintosh-guide.262199/

I replaced the EFI folder on the USB Mojave installation and get to the Clover screen, I choose to install then the Apple logo shows up and a progress bar starts moving slowly. It takes about 15 minutes to finish and then just shows a black screen and doesn't continue.

Does anyone know how to solve this?
 
Last edited:
Joined
Oct 30, 2019
Messages
14
Motherboard
Dell M4800
CPU
i7-4900MQ
Graphics
HD 4600 & Quadro K2100M
Update: after trying it a few more times I noticed that with the EFI mentioned in the guide Mojave gets to the setup screen but the brightness is turned way down so I thought it was a black screen. I can see the language menu (I think) and if I press the arrow buttons it responds but I can't use because I can't see the options
 
Joined
Oct 30, 2019
Messages
14
Motherboard
Dell M4800
CPU
i7-4900MQ
Graphics
HD 4600 & Quadro K2100M
@larynx - if the screen seems "stretched", then you may need to explicitly set DualLink=1 in the clover gfx options to get beyond.

The screen isn't stretched it's extremely dark, I can barely see the options on the screen and it makes it impossible to continue with the setup.
 
Top