Contribute
Register

Dell Precision M6800 Workstation Hackintosh Guide

Joined
May 1, 2019
Messages
53
card reader not work for me:( how can i enable to work? does intel quick sync work for you? on nvidia?
Card reader work
QuickSync doesn't work in Haswell cpu I am not sure
But try

IntelGFX 0x04128086
Ig-platform-id 0x04120004
Check InjectIntel
shikigva=60
 
Last edited by a moderator:
Joined
May 1, 2019
Messages
53
is this for h264:
IntelGFX 0x04128086
Ig-platform-id 0x04120004
Check InjectIntel
shikigva=60

what kext i need to work? is it work with nvidia K4100 i am not use intel hd it's mojave 10.14.4
Add this to config.plist to Fix Card Reader, copy paste code inside clover configurator from my attached plist

Code:
<dict>
                <key>Comment</key>
                <string>SDXC reader</string>
                <key>CustomProperties</key>
                <array>
                    <dict>
                        <key>Disabled</key>
                        <false/>
                        <key>Key</key>
                        <string>device_type</string>
                        <key>Value</key>
                        <string>Media controller</string>
                    </dict>
                    <dict>
                        <key>Disabled</key>
                        <false/>
                        <key>Key</key>
                        <string>model</string>
                        <key>Value</key>
                        <string>O2 Micro SD card reader</string>
                    </dict>
                    <dict>
                        <key>Disabled</key>
                        <false/>
                        <key>Key</key>
                        <string>name</string>
                        <key>Value</key>
                        <string>Reader</string>
                    </dict>
                    <dict>
                        <key>Disabled</key>
                        <false/>
                        <key>Key</key>
                        <string>compatible</string>
                        <key>Value</key>
                        <string>pci14e4,16bc</string>
                    </dict>
to be like that under Device/ Arbitrary in screenshot

Screen Shot 2019-05-01 at 3.08.35 PM.png
 

Attachments

Last edited by a moderator:
Joined
Jul 13, 2012
Messages
30
Motherboard
Dell m6800
CPU
i7-4810MQ
Graphics
Quadro K4100m
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Add this to config.plist to Fix Card Reader, copy paste code inside clover configurator from my attached plist

Code:
<dict>
                <key>Comment</key>
                <string>SDXC reader</string>
                <key>CustomProperties</key>
                <array>
                    <dict>
                        <key>Disabled</key>
                        <false/>
                        <key>Key</key>
                        <string>device_type</string>
                        <key>Value</key>
                        <string>Media controller</string>
                    </dict>
                    <dict>
                        <key>Disabled</key>
                        <false/>
                        <key>Key</key>
                        <string>model</string>
                        <key>Value</key>
                        <string>O2 Micro SD card reader</string>
                    </dict>
                    <dict>
                        <key>Disabled</key>
                        <false/>
                        <key>Key</key>
                        <string>name</string>
                        <key>Value</key>
                        <string>Reader</string>
                    </dict>
                    <dict>
                        <key>Disabled</key>
                        <false/>
                        <key>Key</key>
                        <string>compatible</string>
                        <key>Value</key>
                        <string>pci14e4,16bc</string>
                    </dict>
to be like that under Device/ Arbitrary in screenshot

View attachment 403084
quick sync not enabled and the card reader not work too. i attached my efi folder can u take a look on that? please
 

Attachments

Joined
Jan 16, 2013
Messages
17
Motherboard
Dell M6800 -0CF0TC A00
CPU
i7-4710MQ
Graphics
GTX 965M, 1920x1080
Mobile Phone
Android
I haven't seen this problem here ..... but I will post just in case. I tried all the wireless notebook cards I'd seen mentioned For an M6800) for Mojave and for me none would function. Finally I got an ourlink nano usb (https://www.amazon.com/dp/B011T5IF06/?tag=tonymacx86com-20) and used the driver and install available here (https://github.com/chris1111/Wireless-USB-Adapter-Clover) . This is the most seamless way to use a usb adapter I.e seen and barely seem to differ from being natively supported. I know, of course, using a usb adapter is bad form ...... but when backed in a corner as I felt I was............. this at least seems a more than acceptable way out .....
 
Joined
Mar 18, 2016
Messages
59
Mac
MacBook
Mobile Phone
Android, iOS, Other
Problem still not resolved yet:

I'm trying to run Mojave on my M6800 (specs in signature), and I've run into roadblocks:

1. Dock's USB ports don't do anything. Wasn't an issue in Sierra. Fixed by using my old DSDT and SSDT.
2. When booting, I'm getting "Unsupported CPU", followed by "Unsupported PCH", followed by 4 60 second timeouts from AppleACPICPU.
3. When booting for first setup or after upgrade (tried clean install and upgrade), I'm greeted either by zero output, or no display but backlight on internal screen and no signal on external displays when nv_disable=1 is set. Now I get a black screen with a cursor, and when I press any key the screen flashes.

Have tried a known working ESP from Sierra and your ESP, neither booting past this black screen. I've also tried using Whatevergreen to no avail either.
Have attached an EFI.zip, my current working ESP.
 

Attachments

Joined
May 9, 2014
Messages
7
Motherboard
Dell Precision M6800
CPU
i7-4910MQ
Graphics
K3100M
Mac
MacBook Pro
Mobile Phone
Android, iOS
MODIFIED (Final Update 30 Nov 2018)

For Mojave and High Sierra


Here's my final EFI update for Dell precision m6800 with alots of fixes and tweaks ; just download and install Nvidia web driver for High Sierra

- Fully working everything audio , Bluetooth, Ethernet , wifi , mSata , Card reader ....
- Bios Reset fixed
- Brightness Slider
- Optimus Graphic
- Use Intel HD only or Intel HD + Nvidia (if you want Nvidia only then disable Optimus in bios)
- What is missing and doesn't work ?
You tell me
- all fixes files and instructions are included




Thank You ...

NB : this guide will work 99% with any similar model from Dell as M4800 ....

Links for my old EFI is below ; just use it for Nvidia only with Optimus Graphics disabled in Bios
 
Joined
May 9, 2014
Messages
7
Motherboard
Dell Precision M6800
CPU
i7-4910MQ
Graphics
K3100M
Mac
MacBook Pro
Mobile Phone
Android, iOS
Hi, I've installed Mojave on my dell m6800. and struggling in post installation.
what I've tried so far:
Replaced the EFI folder (from Original EFI) with installed disk EFI folder. result: nothing fixed. (no boot from disk, no wifi, audio, graphics)
I tried multibeast installed UEFI boot, and still not working. result: LAN internet stopped working and keyboard is also stopped, no boot from disk.

Need help to fix Graphics (nVidia k3100M or Intel HD4600) Audio, WiFi(Intel Centrino Ultimate-N 6300 802.11n), and boot from SSD. Thanks!
 

Attachments

Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
11,161
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
Android
Hi, I've installed Mojave on my dell m6800. and struggling in post installation.
what I've tried so far:
Replaced the EFI folder (from Original EFI) with installed disk EFI folder. result: nothing fixed. (no boot from disk, no wifi, audio, graphics)
I tried multibeast installed UEFI boot, and still not working. result: LAN internet stopped working and keyboard is also stoppe, no boot from disk.

Need help to fix Graphics (nVidia k3100M or Intel HD4600) Audio, WiFi(Intel Centrino Ultimate-N 6300 802.11n), and boot from SSD. Thanks!
intel wifi is not supported
 
Joined
May 9, 2014
Messages
7
Motherboard
Dell Precision M6800
CPU
i7-4910MQ
Graphics
K3100M
Mac
MacBook Pro
Mobile Phone
Android, iOS
intel wifi is not supported
Okay, internet is already working via LAN.
but how can I install graphics nVidia k3100m or intel hd4600, audio and fix boot from ssd?
would you please suggest the kexts those I need to install? thanks
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
11,161
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
Android
Okay, internet is already working via LAN.
but how can I install graphics nVidia k3100m or intel hd4600, audio and fix boot from ssd?
would you please suggest the kexts those I need to install? thanks
if it is optimus then only your intel graphics will work

Use this tool and upload your problem reporting files:
 
Top