Contribute
Register

DELL Precision M6600 with Ati Firepro M8900 - 10.9.4 Full Graphics Acceleration !

Status
Not open for further replies.
Joined
Mar 31, 2011
Messages
163
Motherboard
Dell Precision 5820
CPU
W2135
Graphics
WX7100
Dell Precision M6600 with Ati Firepro M8900
Mavericks 10.9.4
I've been testing since 10.9 on and off.
Using vanilla install of mavericks 10.9.4 (no multi beast / boot loader no dsdt etc just unibeast usb for booting )
BOOT FLAGS.... GraphicsEnabler=Yes AtiConfig=Osmunda ( with custom edits for lvds )
I have Ati FirePro M8900M fully recognised in system profiler with
correct naming , correct vram 2gb , correct screen resolution for internal screen and 32-bit colour.
Laptop connected to external monitor via dell dock to dell hdmi monitor - 100% screen res .Both screens working together.
Both external monitor and internal screen are correctly listed in system profiler .
External hdmi screen is perfect.Also tested via sony hdmi tv also perfect.
Only issue I have is laptop screen colour is just slightly washed out - still very readable but not 100% perfect
Also vertical size is correct for laptop screen but horizontally screen seems to be stretched -
Correct from left hand edge but apple dock runs off right hand edge of screen.

Can anyone help with tweaking internal screen to clear up the small issues ?

I've been told this line added to a dsdt may help ....
"@0,display-link-component-bits", Buffer () { 0x06, 0x00, 0x00, 0x00 }

I'm fine with editing custom personalities but not so confident with dsdt's .

Have also come across Switchres x , looks promising but never used it before .

Can anyone suggest a fix I can try ?
 
Joined
Mar 31, 2011
Messages
163
Motherboard
Dell Precision 5820
CPU
W2135
Graphics
WX7100
Try changing the Display Profile in System Preferences -> Display -> Colour to Generic RGB Profile; your screen may look better.

Tried all options in display pref.... hue changes slightly but still washed out
aspect ratio unchanged still only seeing left half of apple dock

On a side note , went ahead and installed latest multi beast but kernel panics at boot , can only boot with -x .
Going to look into clover / chameleon options.
 
Joined
Mar 31, 2011
Messages
163
Motherboard
Dell Precision 5820
CPU
W2135
Graphics
WX7100
Added dsdt with rehab man patch for 1600v900 but unable to boot
chameleon - no boot with or without dsdt
chimera - no boot with without dsdt
clover usb - boot with -x no dsdt

dsdt edits probably not correct - guessing a bit with that
clover config likely incorrect >
set ati true ,intel false
booting from bios , not uefi so maybe thats the problem ?
 
Joined
Mar 31, 2011
Messages
163
Motherboard
Dell Precision 5820
CPU
W2135
Graphics
WX7100
I have no patches for AMD graphics...

Yes, realise that patches are HP but saw a response you made to someone with a Samsung lap. with stretched screen issue.
My dell output over hdmi is perfect but laptop display 1600x900 is stretched similar to the guy with the samy
Colour has a blueish hue also ( only on internal)
With ge=yes and custom osmunda fb I have the amd m8900 correctly recognised in system profiler and both screens
recognised when laptop is docked with multiple resolution options.
Would be great if you could help me get over the line with the screen issue?
I've tried various connector edits , trial and error has got me to here.
I think a custom dsdt may be the answer .
Have extracted dsdt with aida 64 via windows and maciasl via 10.9.4 but
not 100% where to add / edit.
I've been told this line added to a dsdt may help ....
"@0,display-link-component-bits", Buffer () { 0x06, 0x00, 0x00, 0x00 }
It helped the guy who suggested it on an ati 6970m.

Can you say if this might help my setup and where exactly do I place it in my dsdt .
My dsdt only has VID listed , no GFX0 that I can see.

Can copy paste my dsdt if that helps ?
 
Joined
Nov 26, 2014
Messages
15
Motherboard
win8.1
CPU
i7 4800mq
Graphics
HD4600 AMD m6100(HD8950)
Mac
Classic Mac
Mobile Phone
Hi,friend
Can you share your FB.I have the similar card called M6100,i noticed that it's the same FB.
THKS.
Sometimes i can cennect LVDS with injectEDID,you can try.
 
Joined
Mar 31, 2011
Messages
163
Motherboard
Dell Precision 5820
CPU
W2135
Graphics
WX7100
Hi,friend
Can you share your FB.I have the similar card called M6100,i noticed that it's the same FB.
THKS.
Sometimes i can cennect LVDS with injectEDID,you can try.

hi,replied on your other post
 
Joined
May 19, 2014
Messages
11
Motherboard
Dell precision m6600-Asus Sabertoothx79
CPU
i7 2720qm-i7 3930k
Graphics
ati firepro m8900-nvidia gtx680
Mac
Classic Mac
Mobile Phone
hi :)

I own your exact same laptop and am trying to install Yosemite with UniBeast , could you help me by sending me a guide on how to set up everything?
at the end of the installation does not work : internal monitor , audio , trackpad and keyboard ?:banghead:

many thanks
 
Joined
May 19, 2014
Messages
11
Motherboard
Dell precision m6600-Asus Sabertoothx79
CPU
i7 2720qm-i7 3930k
Graphics
ati firepro m8900-nvidia gtx680
Mac
Classic Mac
Mobile Phone
the name and the size of memory of graphic card is right but wont work correctly! i need to plug in a external monitor!
 
Status
Not open for further replies.
Top