Contribute
Register

Dell precesion M7510 with M1000m 4k screen

Joined
Mar 23, 2011
Messages
40
Motherboard
Thinkpad P50, Thinkpad W520
CPU
i7-6820HQ (P50), i7 -2720QM (W520)
Graphics
Intel HD Graphics 530 + Nvidia M1000M (P50), Intel HD Graphics 3000 + Nvidia 1000M (W520)
Hi

My Nvidia M1000M is working well solo mode. (Intel HD530 switched off in bios mode)
except system boot to a black screen. what i do is shut the laptop screen for a few seconds and open it back and get the login screen. is the black screen a sleep mode.
i tried Different SMBIOS 14,1 , 14,2 15,1, and 17,1 with AGDP fix app
other wise everything seems to be working well with the latest Nvidia web drivers. Inject intel or Nvidia is off and GraphicsEnabler=Yes is on

thanks
hi SS2Sameer,

can you list steps you did to enable the nvidia m1000m?
 
Joined
Aug 3, 2011
Messages
34
Motherboard
Gigabyte Z370 Aorus ultra gaming 2.0
CPU
I7, 8700k
Graphics
AMD VEGA64
Mac
MacBook Pro
Mobile Phone
iOS
Hi Juslaw, just logged into the account after many days

use nv_disable=1 to reach desktop if unable to do so. and keep graphics switching off in bios.
just install the nvidia Quadro web drivers as per the OSX version. and apply AGDP fix app before reboot. you should be able to boot to the screen.

if u reach blank screen at end of boot. u can close the lid and open after a few secs. i solved the blank screen part after much here and there, but don't exactly remember how it got solved. will report once fully solved. have the same problem in friends 7510 too.
hope this helps
 
Joined
Aug 3, 2011
Messages
34
Motherboard
Gigabyte Z370 Aorus ultra gaming 2.0
CPU
I7, 8700k
Graphics
AMD VEGA64
Mac
MacBook Pro
Mobile Phone
iOS
And Yes, at end of OS X boot, monitor going to sleep problem has been replicated with Display port and desktop systems with el captain on different desktops systems and laptop all with nvidia quadro cards (different).
 
Joined
Jan 20, 2017
Messages
5
Mac
MacBook
Mobile Phone
Android
Hi Juslaw, just logged into the account after many days

use nv_disable=1 to reach desktop if unable to do so. and keep graphics switching off in bios.
just install the nvidia Quadro web drivers as per the OSX version. and apply AGDP fix app before reboot. you should be able to boot to the screen.

if u reach blank screen at end of boot. u can close the lid and open after a few secs. i solved the blank screen part after much here and there, but don't exactly remember how it got solved. will report once fully solved. have the same problem in friends 7510 too.
hope this helps
Did you make any progress? I also own a laptop with a Nvidia Quadro and an Intel HD530, so just wondering if there is any progress or news on this. Thanks.
 

uar

Joined
Jul 21, 2015
Messages
229
Motherboard
Razer Blade, Clover
CPU
i7-6700HQ
Graphics
HD 530 / GTX 1060, 1920x1080
Mobile Phone
Android
This looks interesting as most laptops comes with Optimus configuration. Did you got M1000M to work? I thought only intel graphics worked on laptops, because of the framebuffer.
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,949
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
This looks interesting as most laptops comes with Optimus configuration. Did you got M1000M to work? I thought only intel graphics worked on laptops, because of the framebuffer.
Nvidia Optimus is not supported.
Your only chance of making Nvidia work is if you can turn off Intel HD to make the Nvidia dedicated.
Read the FAQ.
 
  • Like
Reactions: uar
Top