Contribute
Register

<< Solved >> Dell Inspiron 7586 2-in-1 Intel I7 8565U Black screen after verbose

Joined
Dec 20, 2018
Messages
705
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
i7-8700K OC 5GHz
Graphics
GTX 1080 Ti & UHD 630
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
Still not working persistently, @Feartech any ideas?
try adding the OemTableId for the first 5 acpi patches in your config.plist. I would also try to change your kextloading order. put WEG after Lilu and Virtual. Also in device properties, Framebuffer-con0 should have a busid of '00000000'
 
Last edited:
Joined
Jul 15, 2020
Messages
35
Motherboard
DELL INSPIRON 7586 2-in-1 OC066
CPU
i7-8565U
Graphics
UHD 620, 4K 3840 x 2160
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
try adding the OemTableId for the first 5 acpi patches in your config.plist. I would also try to change your kextloading order. put WEG after Lilu and Virtual. Also in device properties, Framebuffer-con0 should have a busid of '00000000'
Thanks, but I'm giving up on this project since I just found out that connecting to WIFI networks in the shared office space requires a third-party login system that is incompatible with this hackintosh.

The network should prompt for a login, which does not always works, the network connection keeps resetting, I never had this issue on Windows, Pop_OS or my MBP...

I've documented all of my work here: https://github.com/merken/Inspiron7586 (latest EFI is also in there)

Thanks for the support, I'll test newer kexts or patches as they come out, but for now I'm retiring from this project. I'm reinstalling Pop_OS, since it ran stable and had better battery life over Windows.
 
Joined
Jul 15, 2020
Messages
35
Motherboard
DELL INSPIRON 7586 2-in-1 OC066
CPU
i7-8565U
Graphics
UHD 620, 4K 3840 x 2160
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
I noticed the following Kexts had updates recently:

OpenCore 0.6.4
VirtualSMC
Lilu
Whatevergreen
VoodooI2C
...

I've tested the installer with these latest kexts, screen seems to be lit immediately after verbose... This looks promising.

Will try a dual boot install sometime next week.

Verdict at the moment: git clone my repo, update all Kexts (and OpenCore), screen lits up as normal...
 
Joined
Jul 15, 2020
Messages
35
Motherboard
DELL INSPIRON 7586 2-in-1 OC066
CPU
i7-8565U
Graphics
UHD 620, 4K 3840 x 2160
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
Update, I've added the OemTableId with value AAAAAA== (00000000) to all ACPI>Patch entries
Black screen after verbose does not seem to be happening as much as before...

Latest EFI can be found in the repo here: https://github.com/merken/Inspiron7586

Thanks @Mrgeque
 
Joined
Dec 20, 2018
Messages
705
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
i7-8700K OC 5GHz
Graphics
GTX 1080 Ti & UHD 630
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
Joined
Jul 15, 2020
Messages
35
Motherboard
DELL INSPIRON 7586 2-in-1 OC066
CPU
i7-8565U
Graphics
UHD 620, 4K 3840 x 2160
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
A guide is definitively coming :)
I managed to work around the issue I had with the network authentication at work, the WiFi Access Point requires additional login information, which is never prompted on the Hackintosh, but works on my MBP and Samsung Smartphone.

So, I installed HoRNDIS on the Hackintosh in order to share the WiFi from my smartphone over to my Hackintosh via USB. This works, without any speed penalty!

HoRNDIS for Catalina can be found here : https://github.com/jwise/HoRNDIS/issues/102 or via direct download: https://github.com/jwise/HoRNDIS/files/3719733/HoRNDIS-9.2-catalina_install.pkg.zip

Black screen after verbose is not occurring as much as before, this will be incorporated in the guide.
 
Joined
Jul 15, 2020
Messages
35
Motherboard
DELL INSPIRON 7586 2-in-1 OC066
CPU
i7-8565U
Graphics
UHD 620, 4K 3840 x 2160
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
Backlight fix and full guide is available on my Github repo: https://github.com/merken/Inspiron7586

Also, I totally overlooked one critical thing: I kept booting from the OpenCore entry that was added to my UEFI BIOS, not sure what this thing does, but the solution was to boot from the UEFI internal hard drive...

So basically, I had 3 boot options at a certain point:

- OpenCore
- UEFI internal SSD
- UEFI bootable USB (Catalina installer)

Not sure what the OpenCore entry was for, but it was the reason my changes never stuck around, I believe it is a cache of some sort?

I removed the entry from the BIOS and stuck with the SSD UEFI entry, which boots from the macOS drive's EFI partition (obviously).

The OpenIntelWireless drivers (via Airport or ITLWM) are still glitchy, I use the HoRNDIS workaround for this (plugging in my smartphone and tethering the WIFI)

Anyway, I now have a (more or less) functional HackbookPro, thanks to all who contributed!
 
Joined
Jul 15, 2020
Messages
35
Motherboard
DELL INSPIRON 7586 2-in-1 OC066
CPU
i7-8565U
Graphics
UHD 620, 4K 3840 x 2160
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
A quick update to this thread.
I managed to get Big Sur 11.2.2 installed and working on my Dell, details are here: https://github.com/merken/Inspiron7586

The fix for the Big Sur black screen was: latest WhateverGreen kext + this line in the PCI of the GFX entry:
<key>enable-max-pixel-clock-override</key>

<data>AQAAAA==</data>
 
Top