Contribute
Register

<< Solved >> Dell Inspiron 7586 2-in-1 Intel I7 8565U Black screen after verbose

Joined
Jul 15, 2020
Messages
35
Motherboard
DELL INSPIRON 7586 2-in-1 OC066
CPU
i7-8565U
Graphics
UHD 620, 4K 3840 x 2160
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
Hi All,

I've managed to hack my Dell, the specs can be found here:

8th gen Intel i7 8565U with UHD 620 Whiskey Lake (late 2018)

The main issue is that after the verbose (or the apple loader), the screen remains dark (black screen). For minutes...

I can attach an USB C dongle with an HDMI port and a monitor to get myself logged in, the system shows 2 monitors, laptop display and external display.

After a few minutes the screen turns on and functions as normal.

I've tried various configs, but I'm not sure what the exact problem is.

I believe it's either:
- Race condition, certain kexts not loaded soon enough, too late or in the wrong order
- Touch Screen issue? It functions normally after the screen is turned on
- Incorrect framebuffer ? Graphics acceleration is working...
- ?

Please advise...
 
Joined
Jul 15, 2020
Messages
35
Motherboard
DELL INSPIRON 7586 2-in-1 OC066
CPU
i7-8565U
Graphics
UHD 620, 4K 3840 x 2160
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
DSDT attached, I have no idea why it takes 2-3 minutes for my display to be enabled.

Other configurations (platform ids, or device ids) completely break the detection of the laptop panel, I can hook up another USB C HDMI monitor and use that as the main and only display...

So I think I'm on the correct path, but not sure what to do next

Please advise
 

Attachments

  • DSDT.dsl
    1.9 MB · Views: 13

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,575
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
DSDT attached, I have no idea why it takes 2-3 minutes for my display to be enabled.

Other configurations (platform ids, or device ids) completely break the detection of the laptop panel, I can hook up another USB C HDMI monitor and use that as the main and only display...

So I think I'm on the correct path, but not sure what to do next

Please advise
Read FAQ, "Problem Reporting"
 
Joined
Jul 15, 2020
Messages
35
Motherboard
DELL INSPIRON 7586 2-in-1 OC066
CPU
i7-8565U
Graphics
UHD 620, 4K 3840 x 2160
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
[system_profiler SPSerialATADataType|grep TRIM 16 2 0xffffff7f81586000 0x9b000 0x9b000 com.apple.driver.AppleACPIPlatform (6.1) 0EF10B66-B44B-32BB-9CE3-5434F4D40FE1 <15 13 12 8 7 6 5 3 1> 143 1 0xffffff7f863cb000 0x1c000 0x1c000 com.apple.driver.AppleHDAController (283.15) 18E9D42A-B1F4-3332-9D50-EAF28AF632E6 <142 121 101 13 8 7 6 5 3 1> 149 0 0xffffff7f86671000 0xe6000 0xe6000 com.apple.driver.AppleHDA (283.15) 0C7317DB-ED4E-395D-9517-6AEA788732BE <148 143 142 134 121 101 7 6 5 3 1> zsh: no matches found: /System/Library/Extensions/AppleHDA.kext/Contents/Resources/*.zml* 2020-12-01 14:40:57 +0100 Assertion status system-wide: BackgroundTask 0 ApplePushServiceTask 0 UserIsActive 1 PreventUserIdleDisplaySleep 0 PreventSystemSleep 0 ExternalMedia 1 InternalPreventDisplaySleep 1 PreventUserIdleSystemSleep 0 NetworkClientActive 0 Listed by owning process: pid 103(powerd): [0x0000000600088000] 00:16:19 ExternalMedia named: "com.apple.powermanagement.externalmediamounted" pid 103(powerd): [0x0000035800108002] 00:01:23 InternalPreventDisplaySleep named: "com.apple.powermanagement.delayDisplayOff" Timeout will fire in 216 secs Action=TimeoutActionTurnOff pid 146(hidd): [0x0000001000098018] 00:00:00 UserIsActive named: "com.apple.iohideventsystem.queue.tickle serviceID:10000046b name:IOHIDEventDriver product:Keyboard eventType:3" Kernel Assertions: 0x4=USB id=500 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14a00000 owner=IOUSBHostDevice id=501 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14600000 owner=Integrated_Webcam_HD id=502 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14500000 owner=FingerPrint id=503 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14d00000 owner=USB DISK 3.0 id=504 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14400000 owner=USB2.0 Hub id=506 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14000000 owner=USB3.1 Hub id=508 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14430000 owner=USB Receiver Idle sleep preventers: IODisplayWrangler System-wide power settings: Currently in use: standbydelaylow 10800 standby 0 halfdim 1 hibernatefile /var/vm/sleepimage proximitywake 0 powernap 0 gpuswitch 0 disksleep 0 standbydelayhigh 86400 sleep 0 hibernatemode 0 ttyskeepawake 1 displaysleep 0 tcpkeepalive 1 highstandbythreshold 50 lidwake 0

IOREG attached
Patchmagic attached (Archive.zip)

After rebuilding the kextcache, I got: KernelCache ID: 730E8E02ABE833266FDF6E594C98EC7F
 

Attachments

  • dell7586.ioreg
    11 MB · Views: 15
  • Archive.zip
    29 KB · Views: 15

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,575
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
[system_profiler SPSerialATADataType|grep TRIM 16 2 0xffffff7f81586000 0x9b000 0x9b000 com.apple.driver.AppleACPIPlatform (6.1) 0EF10B66-B44B-32BB-9CE3-5434F4D40FE1 <15 13 12 8 7 6 5 3 1> 143 1 0xffffff7f863cb000 0x1c000 0x1c000 com.apple.driver.AppleHDAController (283.15) 18E9D42A-B1F4-3332-9D50-EAF28AF632E6 <142 121 101 13 8 7 6 5 3 1> 149 0 0xffffff7f86671000 0xe6000 0xe6000 com.apple.driver.AppleHDA (283.15) 0C7317DB-ED4E-395D-9517-6AEA788732BE <148 143 142 134 121 101 7 6 5 3 1> zsh: no matches found: /System/Library/Extensions/AppleHDA.kext/Contents/Resources/*.zml* 2020-12-01 14:40:57 +0100 Assertion status system-wide: BackgroundTask 0 ApplePushServiceTask 0 UserIsActive 1 PreventUserIdleDisplaySleep 0 PreventSystemSleep 0 ExternalMedia 1 InternalPreventDisplaySleep 1 PreventUserIdleSystemSleep 0 NetworkClientActive 0 Listed by owning process: pid 103(powerd): [0x0000000600088000] 00:16:19 ExternalMedia named: "com.apple.powermanagement.externalmediamounted" pid 103(powerd): [0x0000035800108002] 00:01:23 InternalPreventDisplaySleep named: "com.apple.powermanagement.delayDisplayOff" Timeout will fire in 216 secs Action=TimeoutActionTurnOff pid 146(hidd): [0x0000001000098018] 00:00:00 UserIsActive named: "com.apple.iohideventsystem.queue.tickle serviceID:10000046b name:IOHIDEventDriver product:Keyboard eventType:3" Kernel Assertions: 0x4=USB id=500 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14a00000 owner=IOUSBHostDevice id=501 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14600000 owner=Integrated_Webcam_HD id=502 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14500000 owner=FingerPrint id=503 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14d00000 owner=USB DISK 3.0 id=504 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14400000 owner=USB2.0 Hub id=506 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14000000 owner=USB3.1 Hub id=508 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14430000 owner=USB Receiver Idle sleep preventers: IODisplayWrangler System-wide power settings: Currently in use: standbydelaylow 10800 standby 0 halfdim 1 hibernatefile /var/vm/sleepimage proximitywake 0 powernap 0 gpuswitch 0 disksleep 0 standbydelayhigh 86400 sleep 0 hibernatemode 0 ttyskeepawake 1 displaysleep 0 tcpkeepalive 1 highstandbythreshold 50 lidwake 0

IOREG attached
Patchmagic attached (Archive.zip)

After rebuilding the kextcache, I got: KernelCache ID: 730E8E02ABE833266FDF6E594C98EC7F
missing your zipped clover or opencore folder
 
Joined
Jul 15, 2020
Messages
35
Motherboard
DELL INSPIRON 7586 2-in-1 OC066
CPU
i7-8565U
Graphics
UHD 620, 4K 3840 x 2160
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
EFI
 

Attachments

  • EFI.zip
    25.9 MB · Views: 23

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,575
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Joined
Jul 15, 2020
Messages
35
Motherboard
DELL INSPIRON 7586 2-in-1 OC066
CPU
i7-8565U
Graphics
UHD 620, 4K 3840 x 2160
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
I changed the platformid, device id to 00009B3E, 9B3E0000
SMBIOS generated for MacBookPro16,1

I've modified it on my USB disk, will boot from there and see if that works

Do I need to clear NVRAM ?
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,575
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I changed the platformid, device id to 00009B3E, 9B3E0000
SMBIOS generated for MacBookPro16,1

I've modified it on my USB disk, will boot from there and see if that works

Do I need to clear NVRAM ?
clearing nvram can help
 
Joined
Jul 15, 2020
Messages
35
Motherboard
DELL INSPIRON 7586 2-in-1 OC066
CPU
i7-8565U
Graphics
UHD 620, 4K 3840 x 2160
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
Ok that worked straight off the bat, rebooting to see if it sticks...

USB C HDMI is not working now, framebuffer issues?
 
Top