Contribute
Register

<< Solved >> Dell Inspiron 5570 Touchpad/Restart Issue

Joined
Dec 20, 2018
Messages
704
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
i7-8700K OC 5GHz
Graphics
GTX 1080 Ti & UHD 630
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
still won't conclude it is working because there is still no signal, but I can mark this thread as solved pertaining to the touchpad and restart issue.
post latest working efi. only reason I said mark as solved because you edit the above post saying everything worked flawlessly
 
Joined
Dec 12, 2019
Messages
40
Motherboard
Dell Inspiron 15" 5570 - OpenCore
CPU
i5-8250U
Graphics
UHD 620, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
post latest working efi. only reason I said mark as solved because you edit the above post saying everything worked flawlessly
latest efi is the previous one i posted. the issue is already solved with restart and touchpad so no need to worry
 
Joined
Dec 20, 2018
Messages
704
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
i7-8700K OC 5GHz
Graphics
GTX 1080 Ti & UHD 630
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
latest efi is the previous one i posted. the issue is already solved with restart and touchpad so no need to worry
delete all values in device properties section of config.plist except
Screen Shot 2021-04-07 at 10.08.02 PM.png
 
Joined
Dec 12, 2019
Messages
40
Motherboard
Dell Inspiron 15" 5570 - OpenCore
CPU
i5-8250U
Graphics
UHD 620, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
delete all values in device properties section of config.plist except
View attachment 514630
Did that, HDMI works now!
I do wanna ask though, since your OC version is 0.6.0, will upgrading break anything or is it safe to do so?

I'm also getting some OCS: No schema for ___ readouts on startup but they don't affect performance and/or startup. Will OC snapshotting get rid of these or will I have to go through and delete them?

EDIT: latest EFI posted. Sleep is still broken but I'm very sure it has to do with proper USB configuration. Working on that.
 

Attachments

  • EFI.zip
    79 MB · Views: 22
Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,634
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Did that, HDMI works now!
I do wanna ask though, since your OC version is 0.6.0, will upgrading break anything or is it safe to do so?

I'm also getting some OCS: No schema for ___ readouts on startup but they don't affect performance and/or startup. Will OC snapshotting get rid of these or will I have to go through and delete them?
compare your config.plist with the sample.plist
 
Joined
Dec 12, 2019
Messages
40
Motherboard
Dell Inspiron 15" 5570 - OpenCore
CPU
i5-8250U
Graphics
UHD 620, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Joined
Dec 20, 2018
Messages
704
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
i7-8700K OC 5GHz
Graphics
GTX 1080 Ti & UHD 630
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
Did that, HDMI works now!
I do wanna ask though, since your OC version is 0.6.0, will upgrading break anything or is it safe to do so?

I'm also getting some OCS: No schema for ___ readouts on startup but they don't affect performance and/or startup. Will OC snapshotting get rid of these or will I have to go through and delete them?

EDIT: latest EFI posted. Sleep is still broken but I'm very sure it has to do with proper USB configuration. Working on that.
use my OC zip from my Big Sur guide it has .6.6 OC. be sure to use the EFI posted under the RESERVED section. just omit the the values you don't need
the guide is found here https://www.tonymacx86.com/threads/...d-620-best-100-simple-setup-continued.308271/
 
Joined
Dec 12, 2019
Messages
40
Motherboard
Dell Inspiron 15" 5570 - OpenCore
CPU
i5-8250U
Graphics
UHD 620, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Joined
Dec 12, 2019
Messages
40
Motherboard
Dell Inspiron 15" 5570 - OpenCore
CPU
i5-8250U
Graphics
UHD 620, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
UPDATE: I upgraded to Big Sur 11.3.1 with Mateo's BigSur EFI (had to make changes to the config.plist+add kexts) and here's a summary of what works/doesn't work/not tested so far. I'll update if anything breaks and/or get fixed. I'm also open to suggestions if any.

WHAT WORKS:
SLEEP (via menu, haven't tried closing display yet closing display works, however both take me directly to desktop, not all the time though this has changed, sleep works properly now but breaks when the laptop goes into hibernate)
RESTART (with help of CPUFriend)
SHUTDOWN
AUDIO (with layout 15)
Brightness
Bluetooth
Ethernet Port
WiFi (old itlwm wasn't working for some reason)
iServices (generated serial for mine, you'll have to provide your own)
USBs (both 2.0 and 3.0/1/2)
Webcam/microphone
Keyboard (incl playback keys etc)
Battery (level is "almost accurate", will have to use coconutBattery to verify since my battery went apescheiße anyway and barely holds charge)
TOUCHPAD/TRACKPAD (disable force click in preferences or else you will have a hard time)
SLEEP via power button, but I won't need it anyway

WHAT DOESN'T WORK:
None

NOT TESTED/INCOMPLETE:
None

The list may be subject to change. I can create a guide about it if needed. Here's the EFI incase anyone needs it. Thank you all for your help!

ANY FURTHER THREADS BY ME WILL BE IN THE BIG SUR LAPTOP SUPPORT SECTION
 

Attachments

  • EFI.zip
    28.3 MB · Views: 17
Last edited:
Top