Contribute
Register

Dell Inspiron 530 - High Sierra

Status
Not open for further replies.
Joined
Feb 6, 2018
Messages
18
Motherboard
Asus Sabertooth Z77
CPU
i7 3770k
Graphics
EVGA GTX 1070
When I enable RAID, I get the same results, OSX will not see any of the drives in they system once I'm in disk utility. Do you still have a copy of the modified BIOS that you used?
 
Joined
Feb 6, 2018
Messages
18
Motherboard
Asus Sabertooth Z77
CPU
i7 3770k
Graphics
EVGA GTX 1070
HI macnb

I have E5450 running on my Dell Inspiron 530 with G33M03 motherboard and I successfully installed high sierra on it and running good using clover and multibeast. Almost everything I need is working. I have Nvidia Geforce 210 graphics card working.

My issue is computer sleeps but wakes up with black screen. Any fix for this issue? I couldn't find fix for wakeup issue anywhere online. I will really appreciate if you can help me find the solution.
Mrokarvi, did you use a modified BIOS as well on your G33M03?
 
Joined
Oct 23, 2010
Messages
969
Motherboard
GA-Z77X-UP5-TH
CPU
i7-3770K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
HI macnb

I have E5450 running on my Dell Inspiron 530 with G33M03 motherboard and I successfully installed high sierra on it and running good using clover and multibeast. Almost everything I need is working. I have Nvidia Geforce 210 graphics card working.

My issue is computer sleeps but wakes up with black screen. Any fix for this issue? I couldn't find fix for wakeup issue anywhere online. I will really appreciate if you can help me find the solution.

I fixed sleep problem by modifying the DSDT.aml.

You can try my attached DSDT.aml (copy it to your EFI/CLOVER/ACPI/Patched folder).

BTW, I also attach my config.plist file (you need to add your own SMBIOS specific values if you are going to use it) but I suggest that you just try the DSDT on it's own first.

Post your IOREG file from IORegistryExplorer.app
 

Attachments

  • Dell-530-DSDT.aml
    13.9 KB · Views: 165
  • MacNB-530-config.plist
    5.6 KB · Views: 246
Joined
Oct 23, 2010
Messages
969
Motherboard
GA-Z77X-UP5-TH
CPU
i7-3770K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
When I enable RAID, I get the same results, OSX will not see any of the drives in they system once I'm in disk utility. Do you still have a copy of the modified BIOS that you used?
That's because the macOS does recognise SATA controller by default. You have to enable it in the DSDT.

Try my DSDT.aml attached above.
 
Joined
Feb 6, 2018
Messages
18
Motherboard
Asus Sabertooth Z77
CPU
i7 3770k
Graphics
EVGA GTX 1070
That's because the macOS does recognise SATA controller by default. You have to enable it in the DSDT.

Try my DSDT.aml attached above.
Sorry for my ignorance, Is the DSDT file supposed to be used with unibeast when making the bootable installation drive? I followed the tutorial on this site and I didn't see a place to inject any files..
 
Joined
Oct 23, 2010
Messages
969
Motherboard
GA-Z77X-UP5-TH
CPU
i7-3770K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Sorry for my ignorance, Is the DSDT file supposed to be used with unibeast when making the bootable installation drive? I followed the tutorial on this site and I didn't see a place to inject any files..
DSDT files are not injected but placed in a folder.
If you created a unibeast clover installer USB with ESP partition then there's an EFI partition on that USB. You need to mount that EFI partition and copy the DSDT.aml file to EFI/CLOVER/ACPI/patched folder.
If you created a unibeast clover installer in legacy mode (without an ESP partition) then there's an EFI folder on the root of that USB. Copy the DSDT.aml file to EFI/CLOVER/ACPI/patched folder.
 
Joined
Feb 6, 2018
Messages
18
Motherboard
Asus Sabertooth Z77
CPU
i7 3770k
Graphics
EVGA GTX 1070
DSDT files are not injected but placed in a folder.
If you created a unibeast clover installer USB with ESP partition then there's an EFI partition on that USB. You need to mount that EFI partition and copy the DSDT.aml file to EFI/CLOVER/ACPI/patched folder.
If you created a unibeast clover installer in legacy mode (without an ESP partition) then there's an EFI folder on the root of that USB. Copy the DSDT.aml file to EFI/CLOVER/ACPI/patched folder.
Done!! I'll test it out when I get home! Thanks, much appreciated!
 
Joined
Oct 9, 2015
Messages
39
Motherboard
Dell Optiplex 9020 SFF
CPU
i5-4750
Graphics
HD 4600
Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
I fixed sleep problem by modifying the DSDT.aml.

You can try my attached DSDT.aml (copy it to your EFI/CLOVER/ACPI/Patched folder).

BTW, I also attach my config.plist file (you need to add your own SMBIOS specific values if you are going to use it) but I suggest that you just try the DSDT on it's own first.

Post your IOREG file from IORegistryExplorer.app

Thanks for the DSDT file. I copied it in (EFI/CLOVER/ACPI/Patched folder), rebooted the system. After the reboot set the sleep time to 1 min, after the sleep it again went to black screen. system seems to boot but screen never comes back. Here is the ioreg files and config file..
 

Attachments

  • iMac-afterDSDT.ioreg
    7 MB · Views: 88
  • iMac-Before-DSDT.ioreg
    6.8 MB · Views: 80
  • config-generate.plist
    13.8 KB · Views: 178
Status
Not open for further replies.
Top