Contribute
Register

Dell Alienware 15 R3

Status
Not open for further replies.
Joined
Apr 22, 2017
Messages
7
Motherboard
AsRock Fatal1ty Z170 Gaming-ITX/ac
CPU
i7 6700k
Graphics
GTX 1070 (Asus Dual)
Mobile Phone
  1. iOS
Yes.
Always worth a try.
I tried installing FakePCIID.kext + FakePCIID_HDMI_Audio.kext and this did not make a difference in making the audio work. I spent several hours trying to get AppleHDA to output sound, but could not get it to work.

I tried VoodooHDA and this worked right away for the speakers with good sound. The only problem is that the headphones do not work now. I'm guessing this is some sort of pin configuration I need to change, but am not sure yet how to do that.
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,014
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I tried installing FakePCIID.kext + FakePCIID_HDMI_Audio.kext and this did not make a difference in making the audio work. I spent several hours trying to get AppleHDA to output sound, but could not get it to work.

You probably have some other mistake.

I tried VoodooHDA and this worked right away for the speakers with good sound. The only problem is that the headphones do not work now. I'm guessing this is some sort of pin configuration I need to change, but am not sure yet how to do that.

Usually AppleHDA preferred over VoodooHDA...
 
Joined
Mar 1, 2011
Messages
28
Motherboard
msi p67a-gd65
CPU
i7-2600k
Graphics
xfx 6870
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Classic Mac
  1. eMac
  2. iBook
  3. iMac
  4. Power Mac
  5. PowerBook
Mobile Phone
  1. Android
  2. iOS
These laptops have MUX built into them. It can be selected in Windows wether to start the machine with discrete enabled or iGPU enabled. As for Audio, I created a proper pinconfig from a codecdump for AppleHDA everything is recognized however there is no sound. I took the same codecdump and applied it to VoodooHDA and have sound and working headphone jack, however jack detection doesn't work. CodecCommander is also needed for headphones to work properly. I am currently using the iGPU on mine, if I want to use the 1060 I boot into windows press F7 (I/D GFX) the machine will restart with the 1060 and choose a second config I made called 'config nvidia'. I need help with letting clover know to drop the "SSDT-Disable_DGPU" when I boot form the config Nvidia.plist otherwise the discrete cpu is still disabled.
 

Attachments

  • 13 r3.zip
    3.2 MB · Views: 103

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,014
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I need help with letting clover know to drop the "SSDT-Disable_DGPU" when I boot form the config Nvidia.plist otherwise the discrete cpu is still disabled.

Use SortedOrder to specify the specific SSDTs to load in each case.
With SortedOrder specified, only those SSDTs will load.
 
Joined
Mar 1, 2011
Messages
28
Motherboard
msi p67a-gd65
CPU
i7-2600k
Graphics
xfx 6870
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Classic Mac
  1. eMac
  2. iBook
  3. iMac
  4. Power Mac
  5. PowerBook
Mobile Phone
  1. Android
  2. iOS
Yes, that worked. Thank You RehabMan
 
Joined
Jun 25, 2015
Messages
1
Motherboard
WIndows 8.1
CPU
I7
Graphics
2gb
Mac
Classic Mac
Mobile Phone
Hi guy, I'm newbie, i have an alienware 15 r3 with i7 7700HQ, GTX 1060, UHD 4k screen, Hynix SSD 500 gb m.2, and 1tb HDD, but i can't boot to install mackintosh :( someone help me pls. I have try to use yours clover config in this post but still stuck in apple logo :(
 
Last edited:

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,014
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi guy, I'm newbie, i have an alienware 15 r3 with i7 7700HQ, GTX 1060, UHD 4k screen, Hynix SSD 500 gb m.2, and 1tb HDD, but i can't boot to install mackintosh :( someone help me pls. I have try to use yours clover config in this post but still stuck in apple logo :(

Follow the Clover guide linked from the FAQ.
http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html

Although you should read the FAQ for an overview of issues, the Clover guide is linked from the first question: "Q. Where do I start?", just after the bold face "Clover Guide".
Here is a direct link, just to be clear:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

Also, your profile must be filled out with complete details as requested in the FAQ, again under "Q. Where do I start?". All seven details requested are equally important.

And if you have an issue (after following the guide), or on any other problem, you must provide a detailed description of the problem including information that helps us understand what you're doing. Always attach "Problem Reporting" files as per FAQ.
http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html
The required files and data are fully detailed in the last question in the FAQ:
"Q. What are typical "Problem Reporting" files?"
 
Status
Not open for further replies.
Top