Contribute
Register

Dell 5290 2 in 1

Joined
Jan 3, 2017
Messages
16
Motherboard
Dell Latitude 5290 2 in 1
CPU
i5-8350U
Graphics
HD 620
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hello,
I have a Dell Latitude 5290 2 in 1 laptop.
I have been following the information from here:
https://github.com/laelsirus/Dell-Latitude-5290-2-in-1-CLOVER

By using this I was able to get almost everything working (including trackpad, audio, graphics acceleration).
I'm running macOS Big Sur 11.2.3 on OpenCore.
Unfortunately, I can't seem to get the Touchscreen to work.
Looking at Hackintool, I don't seem to see the touchscreen there.

Screen Shot 2021-09-21 at 6.48.45 PM.png


I can confirm in Windows the I2C HID Device Properties (SB.PCI0.I2C1.TPL8)
I do have the VoodooI2C.kext and the VoodooI2CHID.kext
Attached is my EFI folder - any help would be greatly appreciated.

Thanks
Michael
 
Joined
Sep 22, 2021
Messages
4
Motherboard
Dell 5290 2 in 1
CPU
i5-8350U
Graphics
UHD 620
Hi Michael,

I can't help personally, but would be really interested in getting a copy of your EFI for my own 5290 2 in 1.
I don't think your EFI attached to your post :)

I can take a look at trying to get the touchscreen working also, as I'm on the same path as you - following on from Laelsirus's guides.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,538
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Hi Michael,

I can't help personally, but would be really interested in getting a copy of your EFI for my own 5290 2 in 1.
I don't think your EFI attached to your post :)

I can take a look at trying to get the touchscreen working also, as I'm on the same path as you - following on from Laelsirus's guides.
 
Joined
Sep 22, 2021
Messages
4
Motherboard
Dell 5290 2 in 1
CPU
i5-8350U
Graphics
UHD 620
Thank you Feartech,

I've read through the Opencore guides and don't have any issues with them, apart from the time commitment at present! I've got a working version of Clover running Catalina but was hoping to get a shortcut on my partially built Opencore Big Sur USB.

@mlavio829 - Apologies for hijacking your post. If I find anything regarding touchpad compatibility on Big Sur I'll update here.
 
Joined
Jan 3, 2017
Messages
16
Motherboard
Dell Latitude 5290 2 in 1
CPU
i5-8350U
Graphics
HD 620
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Oops! Forgot to attach the EFI folder!
 

Attachments

  • EFI.zip
    47.6 MB · Views: 12
Joined
Sep 22, 2021
Messages
4
Motherboard
Dell 5290 2 in 1
CPU
i5-8350U
Graphics
UHD 620
Hi @mlavio829

I've managed to partly fix the touchpad using the files from your EFI.
Your config.plist file had duplicate entries for ACPI patches.

I updated VoodooI2C and VoodooI2CHID to the latest versions, and removed all ACHI patches minus a few essential ones.

Unfortunately, while the touchscreen works with this config, it's no longer detected as a Magic Trackpad 2 and thus multi-touch gestures do not work.

I'm sure this is a simple fix, and something that I've broken along the way but this should prove a good start. Let me know if you manage to fully solve this before me!
 

Attachments

  • EFI.zip
    33.9 MB · Views: 15
Last edited:
Joined
Dec 20, 2018
Messages
704
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
i7-8700K OC 5GHz
Graphics
GTX 1080 Ti & UHD 630
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
try my EFI/ guides could be helpful
 
Joined
Jan 3, 2017
Messages
16
Motherboard
Dell Latitude 5290 2 in 1
CPU
i5-8350U
Graphics
HD 620
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi @mlavio829

I've managed to partly fix the touchpad using the files from your EFI.
Your config.plist file had duplicate entries for ACPI patches.

I updated VoodooI2C and VoodooI2CHID to the latest versions, and removed all ACHI patches minus a few essential ones.

Unfortunately, while the touchscreen works with this config, it's no longer detected as a Magic Trackpad 2 and thus multi-touch gestures do not work.

I'm sure this is a simple fix, and something that I've broken along the way but this should prove a good start. Let me know if you manage to fully solve this before me!
Amazing! The touchscreen works perfectly!
Thank you so much!

Have you noticed sometimes when plugging in a USB Drive, it doesn't always detect it?
I sometimes have to restart the whole computer to get it to work.
 
Joined
Sep 22, 2021
Messages
4
Motherboard
Dell 5290 2 in 1
CPU
i5-8350U
Graphics
UHD 620
Amazing! The touchscreen works perfectly!
Thank you so much!

Have you noticed sometimes when plugging in a USB Drive, it doesn't always detect it?
I sometimes have to restart the whole computer to get it to work.
I didn't use that EFI setup for long, as I couldn't get multi-touch gestures to work (however I only played with it for a minute before going back to Catalina) but I would assume it has something to do with you having both USBInjectAll and USBPorts activated in the kexts folder. The config.plist file wasn't fully optimised so it's likely some conflict here or there.

Out of curiosity, did the touchscreen work with multi touch for you? I want to go with Big Sur and this was the last major bug I saw, but I'm tired of reinstalling over the last few days!
 
Joined
Jan 3, 2017
Messages
16
Motherboard
Dell Latitude 5290 2 in 1
CPU
i5-8350U
Graphics
HD 620
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Ooo ok, I can take a look at that. I thought both USBInjectAll and USBPorts were supposed to be activated. Are you able to post your EFI?
The touchscreen didn't work with multi-touch, but it's working which is the biggest thing!
 
Top