Contribute
Register

Dell 5285 High Sierra

Joined
Jan 9, 2013
Messages
46
Motherboard
Dell Latitude 5285
CPU
i7-7600U
Graphics
Intel HD620
I installed High Sierra on the 5285 tablet. The tablet has the following configuration:

BIOS 1.1.11
i7-7600u @ 2.8 GHz
16GB DDR4
Intel HD 620
Edimax WIFI nano usb

It has an ssd disk that came partitioned GPT with an EFI partition of 500MB and I shrinked the windows 10 partition and created a separate partition for osx. I erased and formatted osx extended journal and installed high sierra. Clover was installed successfully in ESP/EFI partition and both windows and osx boot.

I was able to boot successfully in the osx by only blocking the injection of the Lilu and IntelGraphicsFixup kexts and using an invalid ig-platform-id. So the graphic card doesn't work.

Funny enough, the mouse trackpad/touchpad works, but the keyboard cover doesn't work. I patched the ISOUSBFamily.kext with this:

<key>Generic Keyboard</key>
<dict>
<key>CFBundleIdentifier</key>
<string>com.apple.iokit.IOUSBHIDDriver</string>
<key>HIDDefaultBehavior</key>
<string></string>
<key>IOClass</key>
<string>IOUSBHIDDriver</string>
<key>IOProviderClass</key>
<string>IOUSBInterface</string>
<key>bInterfaceClass</key>
<integer>3</integer>
<key>bInterfaceProtocol</key>
<integer>0</integer>
<key>bInterfaceSubClass</key>
<integer>3</integer>
</dict>

No effect whatsoever. I also disabled the Voodoo kext in the clover, no effect.

Attached is the boot.log and clover folder. Appreciate your help and advice.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,719
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,719
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Thanks, but the DVMT/DVMT-prealloc is already at 128 (as I can read from windows).
You clearly didn't read the FAQ:
IMPORTANT!: Contrary to many of the guides you will read, Windows is NOT a valid way to determine what DVMT-prealloc is set to. There is no correlation, especially with Windows 10.
 
Joined
Jan 9, 2013
Messages
46
Motherboard
Dell Latitude 5285
CPU
i7-7600U
Graphics
Intel HD620
Well, I read the page you pointed me to, but sorry, I missed that FAQ. Appreciate your help and guidance. How can I find out what DVMT I have? I upgraded meanwhile to BIOS 1.3.5
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,719
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Well, I read the page you pointed me to, but sorry, I missed that FAQ. Appreciate your help and guidance. How can I find out what DVMT I have? I upgraded meanwhile to BIOS 1.3.5
If you get KP in the graphics kexts when booting with a valid ig-platform-id, then your DVMT-prealloc is likely only 32mb.
 
Joined
Jan 9, 2013
Messages
46
Motherboard
Dell Latitude 5285
CPU
i7-7600U
Graphics
Intel HD620
I run setup_var 0x180 and the return was 0x03. Would that be 32M? Thanks for your help. Anyways, the keyboard should work regardless of the graphic card right?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,719
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I run setup_var 0x180 and the return was 0x03. Would that be 32M?
You would need to do an IFR extract.

Thanks for your help. Anyways, the keyboard should work regardless of the graphic card right?
If you have a question you must back it up with PR files.

No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Jan 9, 2013
Messages
46
Motherboard
Dell Latitude 5285
CPU
i7-7600U
Graphics
Intel HD620
I was unable to use Bios Backup tool to extract the Bios. It says that it cannot find/detect the bios! It is really strange as I was able to do it on an xps last year. I tried Phoenix tool but the problem is the extraction is incomplete.

I have the full debug files, which I attach below. I am not able to boot with a proper graphics id even patching the DVMT-prealloc. The keyboard is not working, but trackpad and mouse yes and this is bothering me a lot. I use your last VoodooPS2 kext.

Thanks for your help.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,719
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I was unable to use Bios Backup tool to extract the Bios. It says that it cannot find/detect the bios! It is really strange as I was able to do it on an xps last year. I tried Phoenix tool but the problem is the extraction is incomplete.

I have the full debug files, which I attach below. I am not able to boot with a proper graphics id even patching the DVMT-prealloc. The keyboard is not working, but trackpad and mouse yes and this is bothering me a lot. I use your last VoodooPS2 kext.

Thanks for your help.
Your kextcache shows a bunch of kexts patched that should not be patched...

Start over with a fresh install.
See guide:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
 
Top