Contribute
Register

Defective gradients in macOS Catalina 10.15.0 (19A583)

Status
Not open for further replies.
Joined
Jan 23, 2018
Messages
66
Motherboard
GA-a320m S2H
CPU
Ryzen 5 1600 af
Graphics
AMD Radeon RX 470 4gb
Mac
  1. iMac
Mobile Phone
  1. Android
Hi, I need help with the gradients. I have another volume with Mojave 10.14.6 and the graphics are perfect, they don't show any errors. However, Catalina has that defect, even though it is a clean installation. My graphics card is an RX 470 4gb. I have nothing loaded in my config.plist since this card works natively in Mojave. I appreciate helping me solve this.
 

Attachments

  • 1.png
    1.png
    54.4 KB · Views: 163
  • 3.jpg
    3.jpg
    125.6 KB · Views: 198
  • 3.png
    3.png
    18.2 KB · Views: 169
Joined
Aug 21, 2010
Messages
2
Motherboard
MSI Z97 Guard Pro
CPU
i7-4790S
Graphics
RX 570
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. Android
I have the same problem with Rx 570 4gb here.
 
Joined
Apr 27, 2017
Messages
2
Motherboard
ASUS B250
CPU
i5 7500
Graphics
RX 460
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I have the same problem, my hardware is rx 460, 4k 10-bit color display, haswell CPU, I can't solve it for a long time
 

JimmyS

Retired
Joined
Oct 16, 2012
Messages
143
Motherboard
ASUS Prime X299-Deluxe
CPU
i7-7820X
Graphics
Vega 56
Mobile Phone
  1. iOS
See if this works:

1. Turn off SIP.
2. Open Hackintool.
3. Switch to the Tools tab and press "Disable Gatekeeper" to mount the disk in read/write mode.
4. Switch to the Display tab and just export without changing anything. Hackintool creates three files and one folder on the desktop.
5. Drag and drop the folder "DisplayVendorID-xxxx" to /System/Library/Displays/Contents/Resources/Overrides
6. Restart, and remember to turn SIP back on.

You'll find Hackintool here:

Hackintool thread:
 
Joined
Apr 27, 2017
Messages
2
Motherboard
ASUS B250
CPU
i5 7500
Graphics
RX 460
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
See if this works:

1. Turn off SIP.
2. Open Hackintool.
3. Switch to the Tools tab and press "Disable Gatekeeper" to mount the disk in read/write mode.
4. Switch to the Display tab and just export without changing anything. Hackintool creates three files and one folder on the desktop.
5. Drag and drop the folder "DisplayVendorID-xxxx" to /System/Library/Displays/Contents/Resources/Overrides
6. Restart, and remember to turn SIP back on.

You'll find Hackintool here:

Hackintool thread:

Thanks for your detailed reply. Now my display effect has been improved.
I tried putting "xxx. kext" in the "L/E" folder before, but it lost the audio output and didn't always work
 
Joined
Oct 10, 2015
Messages
909
Motherboard
Z370 AORUS Gaming 3
CPU
i5-9600K
Graphics
RX 580
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. iOS
See if this works:

1. Turn off SIP.
2. Open Hackintool.
3. Switch to the Tools tab and press "Disable Gatekeeper" to mount the disk in read/write mode.
4. Switch to the Display tab and just export without changing anything. Hackintool creates three files and one folder on the desktop.
5. Drag and drop the folder "DisplayVendorID-xxxx" to /System/Library/Displays/Contents/Resources/Overrides
6. Restart, and remember to turn SIP back on.

You'll find Hackintool here:

Hackintool thread:
I also posted the similar method a half of year ago.

 

JimmyS

Retired
Joined
Oct 16, 2012
Messages
143
Motherboard
ASUS Prime X299-Deluxe
CPU
i7-7820X
Graphics
Vega 56
Mobile Phone
  1. iOS
I also posted the similar method a half of year ago.

Yes I think this is your method originally. You have my thanks!

I didn't remember where I had learnt this. Fixed the banding issues with my 10bit colour compatible display.
 
Joined
Oct 10, 2015
Messages
909
Motherboard
Z370 AORUS Gaming 3
CPU
i5-9600K
Graphics
RX 580
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. iOS
Yes I think this is your method originally. You have my thanks!

I didn't remember where I had learnt this. Fixed the banding issues with my 10bit colour compatible display.
It should be an issue caused by macOS itself as some Mac users also reported the same. I did some trial and error with their unclear and complicated clues.
 
Status
Not open for further replies.
Top