Contribute
Register

Creative Sound Blaster Audigy 2 working in 10.11

Joined
Nov 26, 2014
Messages
27
Motherboard
ASUS Sabertooth Z87
CPU
Intel Core i7 4770k
Graphics
GeForce GTX 960 ASUS Strix
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
take a look here, i am working on a mod of the driver you used for your audigy 2 card, it simply, makes it better compatible with recent mac os versions and also fixes some issues, another thing is that now the names of the card in the settings is more user friendly Kx audio driver mod [Sound blaster live!, audigy 1/2/4/RX emu edsp]
 
Joined
Jun 9, 2013
Messages
10,964
Motherboard
GA-H77N-WIFI
CPU
Core i7-3770
Graphics
Intel HD 4000
Mac
MacBook, Mac mini
Mobile Phone
Android
Force HPET is not Clover it's Chameleon. I have no idea why it does not say Fix HPET. What does your Config Plist say? Mine has this
<key>ForceHPET</key>
<true/>
Incorrect. FixHPET is for Clover not Chameleon.

Screen Shot 2017-06-05 at 16.08.21.png
 
Joined
Jul 26, 2015
Messages
8
I can confirm that card could not work in some cases.
System can not detect sound card.
When AppleHPET.kext removed card works, however PC goes to reboot in 50-70 seconds.
Removing AppleHPET.kext and/or adding <key>FixHPET_0010</key><false/> to clover-config does not help (PC reboots).
Kind of solution is when AppleHPET.kext installed in CLOVER folder and KxAudioDriver.kext installed in /S/L/E.
System works fine (I was working and playing sound during 11 hours)

It was tested with:
Audio 2 zs
HP Compaq Elite 8300 CMT (with the latest BIOS)
El Capitan (with all latest updates)
Clover (the latest version v2.4k_r4318)
kX-Driver (MOD version by ITzTravelInTime)
DSDT not patched, and generated SSDT for 3770
 
Joined
Jun 9, 2013
Messages
10,964
Motherboard
GA-H77N-WIFI
CPU
Core i7-3770
Graphics
Intel HD 4000
Mac
MacBook, Mac mini
Mobile Phone
Android
I can confirm that card could not work in some cases.
System can not detect sound card.
When AppleHPET.kext removed card works, however PC goes to reboot in 50-70 seconds.
Removing AppleHPET.kext and/or adding <key>FixHPET_0010</key><false/> to clover-config does not help (PC reboots).
Kind of solution is when AppleHPET.kext installed in CLOVER folder and KxAudioDriver.kext installed in /S/L/E.
System works fine (I was working and playing sound during 11 hours)

It was tested with:
Audio 2 zs
HP Compaq Elite 8300 CMT (with the latest BIOS)
El Capitan (with all latest updates)
Clover (the latest version v2.4k_r4318)
kX-Driver (MOD version by ITzTravelInTime)
DSDT not patched, and generated SSDT for 3770
Look at Kernel Panic Log.
AppleHPET shouldn't affect 1155 Ivybridge.
Attach Problem Reporting Files.
 
Joined
Jul 26, 2015
Messages
8
Look at Kernel Panic Log.
AppleHPET shouldn't affect 1155 Ivybridge.
Attach Problem Reporting Files.
*** Panic Report ***
panic(cpu 0 caller 0xffffff7f827747f7): No HPETs available...CPU(s) configured incorrectly

Backtrace (CPU 0), Frame : Return Address
0xffffff81ed99bef0 : 0xffffff80002dab52
0xffffff81ed99bf70 : 0xffffff7f827747f7
0xffffff81ed99bfb0 : 0xffffff80003c95a7
Kernel Extensions in backtrace:
com.apple.driver.AppleIntelCPUPowerManagement(218.0)[042948D8-61E8-3FA5-9292-D1AE9D0EE758]@0xffffff7f8276e000->0xffffff7f82798fff

BSD process name corresponding to current thread: kernel_task
Boot args: kext-dev-mode=1 -v slide=0

Mac OS version:
15G17023

Kernel version:
Darwin Kernel Version 15.6.0: Mon Oct 2 22:20:08 PDT 2017; root:xnu-3248.71.4~1/RELEASE_X86_64
Kernel UUID: C132D1DA-3C39-3F1F-A265-219352AC3C9D
__HIB text base: 0xffffff8000100000

<SKIPPED>

com.kXProject.driver.kXAudioDriver 2.00b0

<SKIPPED>
 
Joined
Jun 9, 2013
Messages
10,964
Motherboard
GA-H77N-WIFI
CPU
Core i7-3770
Graphics
Intel HD 4000
Mac
MacBook, Mac mini
Mobile Phone
Android


*** Panic Report ***
panic(cpu 0 caller 0xffffff7f827747f7): No HPETs available...CPU(s) configured incorrectly

Backtrace (CPU 0), Frame : Return Address
0xffffff81ed99bef0 : 0xffffff80002dab52
0xffffff81ed99bf70 : 0xffffff7f827747f7
0xffffff81ed99bfb0 : 0xffffff80003c95a7
Kernel Extensions in backtrace:
com.apple.driver.AppleIntelCPUPowerManagement(218.0)[042948D8-61E8-3FA5-9292-D1AE9D0EE758]@0xffffff7f8276e000->0xffffff7f82798fff

BSD process name corresponding to current thread: kernel_task
Boot args: kext-dev-mode=1 -v slide=0

Mac OS version:
15G17023

Kernel version:
Darwin Kernel Version 15.6.0: Mon Oct 2 22:20:08 PDT 2017; root:xnu-3248.71.4~1/RELEASE_X86_64
Kernel UUID: C132D1DA-3C39-3F1F-A265-219352AC3C9D
__HIB text base: 0xffffff8000100000

<SKIPPED>

com.kXProject.driver.kXAudioDriver 2.00b0

<SKIPPED>
The KX Driver has a problem.
Most likely that the driver is out of date & the Source Code hasn't been updated.
Wouldn't surprise me that the KX Driver is causing issues with No HPET Available be sure that HPET is set to 64bit in the BIOS may need HPET injected via ACPI with a SSDT injector if FixHPET doesnt work.
 
Joined
Jul 26, 2015
Messages
8
The KX Driver has a problem.
Most likely that the driver is out of date & the Source Code hasn't been updated.
Wouldn't surprise me that the KX Driver is causing issues with No HPET Available be sure that HPET is set to 64bit in the BIOS may need HPET injected via ACPI with a SSDT injector if FixHPET doesnt work.
Sorry, I do not know much about HPET, what do you mean by "HPET is set to 64bit in the BIOS may need HPET injected via ACPI with a SSDT injector"?
As I mentioned, PC reboots even without kx-driver when AppleHPET.kext removed.
Probably, I do not have clover configured correctly for my CPU, however i7-3770 is installed in read iMacs.
 
Top