Contribute
Register

Creative Sound Blaster Audigy 2 working in 10.11

Status
Not open for further replies.
Joined
Jun 9, 2013
Messages
10,736
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. Android
Hi guys i just thought i might throw some insight out there for you guys. Maybe your onboard Audio doesn't work or maybe you're looking for better audio heres a PCI Sound card which works from 10.6 straight to 10.11 it sounds beautiful i actually forgot how well it sounds compared to onboard audio. you can pick up Creative Sound Blaster Audigy 2 quite cheap on eBay its a old sound card but still sounds great :D You need to install the KX driver which has its own built installer for OS X also windows.

Soundblaster_Audigy2_ZS.jpg


Screen Shot 2016-06-09 at 23.36.48.png

Screen Shot 2016-06-09 at 23.36.52.png
 

corei3cpu

Banned
Joined
Oct 20, 2015
Messages
337
Motherboard
HP Intel 6300
CPU
Intel i5-3470
Graphics
Nvidia GT 710, Dual HDMI, 1080p
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Classic
  2. Color Classic
  3. iBook
  4. iMac
  5. Performa
  6. Power Mac
  7. PowerBook
Mobile Phone
  1. iOS
Hi guys i just thought i might throw some insight out there for you guys. Maybe your onboard Audio doesn't work or maybe you're looking for better audio heres a PCI Sound card which works from 10.6 straight to 10.11 it sounds beautiful i actually forgot how well it sounds compared to onboard audio. you can pick up Creative Sound Blaster Audigy 2 quite cheap on eBay its a old sound card but still sounds great :D You need to install the KX driver which has its own built installer for OS X also windows.

View attachment 198692

View attachment 198693
View attachment 198694


Do you have a link to the kexts?

I can't get this to work with my HP 6300 running El capitan.

If I remove Apple HPET.kext the card will work however removing AppleHPET causes my computer to shut down and reboot.

Any Ideas on how to fix this?....
 
Joined
Jun 9, 2013
Messages
10,736
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. Android
Do you have a link to the kexts?

I can't get this to work with my HP 6300 running El capitan.

If I remove Apple HPET.kext the card will work however removing AppleHPET causes my computer to shut down and reboot.

Any Ideas on how to fix this?....

Removing AppleHPET.kext is correct on som HP models. If you have no USB or Ethernet with AppleHPET.kext then you will need to remove it. Have you installed KXDriver?
 

corei3cpu

Banned
Joined
Oct 20, 2015
Messages
337
Motherboard
HP Intel 6300
CPU
Intel i5-3470
Graphics
Nvidia GT 710, Dual HDMI, 1080p
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Classic
  2. Color Classic
  3. iBook
  4. iMac
  5. Performa
  6. Power Mac
  7. PowerBook
Mobile Phone
  1. iOS
Removing AppleHPET.kext is correct on som HP models. If you have no USB or Ethernet with AppleHPET.kext then you will need to remove it. Have you installed KXDriver?

Yes, I installed kxaudio kext and rebuilt cache and rebooted. However it does not want to work unless I remove AppleHPET.kext
However removing AppleHPET.kext causes my computer to shut down and reboot after 3 minutes of use.
 
Joined
Jun 9, 2013
Messages
10,736
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. Android
Yes, I installed kxaudio kext and rebuilt cache and rebooted. However it does not want to work unless I remove AppleHPET.kext
However removing AppleHPET.kext causes my computer to shut down and reboot after 3 minutes of use.

Do you have Fix HPET in config.plist?
 

corei3cpu

Banned
Joined
Oct 20, 2015
Messages
337
Motherboard
HP Intel 6300
CPU
Intel i5-3470
Graphics
Nvidia GT 710, Dual HDMI, 1080p
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Classic
  2. Color Classic
  3. iBook
  4. iMac
  5. Performa
  6. Power Mac
  7. PowerBook
Mobile Phone
  1. iOS
Do you have Fix HPET in config.plist?

When I removed AppleHPET.kexts I did not remove the fixHPET entry in config.plist.
Do you think this could have been a problem?....
 
Joined
Jun 9, 2013
Messages
10,736
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. Android
When I removed AppleHPET.kexts I did not remove the fixHPET entry in config.plist.
Do you think this could have been a problem?....

Yes.
 

corei3cpu

Banned
Joined
Oct 20, 2015
Messages
337
Motherboard
HP Intel 6300
CPU
Intel i5-3470
Graphics
Nvidia GT 710, Dual HDMI, 1080p
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Classic
  2. Color Classic
  3. iBook
  4. iMac
  5. Performa
  6. Power Mac
  7. PowerBook
Mobile Phone
  1. iOS
Remove Fix HPET from config.plist. Then remove AppleHPET.kext.

Yeah, That did not work either. Causes my computer to shut down and reboot.
 
Status
Not open for further replies.
Top