Contribute
Register

creative CA0132

Status
Not open for further replies.
Joined
May 15, 2016
Messages
66
Motherboard
Gigabyte Z170X Gaming 7
CPU
i7 6700
Graphics
Gigabyte GTX 960 G1 Gaming
Classic Mac
  1. Performa
  2. Power Mac
Mobile Phone
  1. Android
Hi. After a bios crash i had to change my motherboard. I switched from z170x gaming 5 to z170x gaming 7.
What is the best solution to have my audio work ? I replaced my AppleHDA patched with AppleHDA (original).
I am with MacOS 10.11.6.
 
Last edited:
Joined
May 15, 2016
Messages
66
Motherboard
Gigabyte Z170X Gaming 7
CPU
i7 6700
Graphics
Gigabyte GTX 960 G1 Gaming
Classic Mac
  1. Performa
  2. Power Mac
Mobile Phone
  1. Android
here is my config plist. By the way, kextbeast doesn't install CodecCommander.kext in my /library/extensions, i tried manually, think i succeed. Where do i put AppleALC ? in EFI/clover/kexts/other or in /system/library/extensions or in /library/extensions ? I have a Lilu is in EFI/clover/kexts/other (for nvidia).
 

Attachments

  • config.plist
    6 KB · Views: 320
Joined
May 15, 2016
Messages
66
Motherboard
Gigabyte Z170X Gaming 7
CPU
i7 6700
Graphics
Gigabyte GTX 960 G1 Gaming
Classic Mac
  1. Performa
  2. Power Mac
Mobile Phone
  1. Android

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,688
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
To rename go here:

Screen Shot 2018-01-13 at 6.33.18 AM.png
 
Joined
May 15, 2016
Messages
66
Motherboard
Gigabyte Z170X Gaming 7
CPU
i7 6700
Graphics
Gigabyte GTX 960 G1 Gaming
Classic Mac
  1. Performa
  2. Power Mac
Mobile Phone
  1. Android
yes i tried but it didn't work at all. So i copied pasted from another plist with gedit but i had an error at boot : error allocating 0x12623 pages at... so i reversed my plist with ubuntu. Clover configator tells me The document “config.plist” is on a volume that does not support permanent version storage.
 
Joined
Nov 1, 2015
Messages
287
Motherboard
GA-Z270X-Gaming 9
CPU
i7-7700K
Graphics
RX 560
With the config.plist you've provided it will definitley not work, if you want to use the AppleALC.kext remove all audio related patches except: HDAS to HDEF. Make sure the AppleHDA is unchanged, for the Gaming7 board you also need the IRQ patches.
Your IOReg can tell us if your config.plist patches are correct.
 
Joined
May 15, 2016
Messages
66
Motherboard
Gigabyte Z170X Gaming 7
CPU
i7 6700
Graphics
Gigabyte GTX 960 G1 Gaming
Classic Mac
  1. Performa
  2. Power Mac
Mobile Phone
  1. Android
Clover configurator does not write HDAS to HDEF, i don't know why. I removed audio patches. Do you have the link for IRQ patches ? Can you modify my config.plist ? here is the last one. Here is my ioreg too.
 

Attachments

  • config.plist
    5.1 KB · Views: 300
  • iMac de Pascal.ioreg
    3.8 MB · Views: 189
Last edited:
Joined
Nov 1, 2015
Messages
287
Motherboard
GA-Z270X-Gaming 9
CPU
i7-7700K
Graphics
RX 560
The IOReg shows me the audio works. Here the config.plist with enabled IRQ fixes, and layout-ID 4 with which you can use multichannel.
 

Attachments

  • config.plist.zip
    2.4 KB · Views: 131
Joined
May 15, 2016
Messages
66
Motherboard
Gigabyte Z170X Gaming 7
CPU
i7 6700
Graphics
Gigabyte GTX 960 G1 Gaming
Classic Mac
  1. Performa
  2. Power Mac
Mobile Phone
  1. Android
Thank you, at second boot your plist was accepted, though i have still no sound and i can't add HDAS to HDEF with clover configurator.
Well, now (sometimes) i have this error :

OsxAptioFix2Drv: starting overrides for /System\Library\CoreServices\boot.efi
using reloc block: no, hibernate wake: no
Error allocating 0x112623 pages at 0x000000001d8c6000 alloc type 2
Couldn't allocate runtime area
Boot failed, sleeping for 10 seconds before exiting...

I remind you i was with a MB z170x gaming 5 and now with the gaming 7.
Here are my /library/extensions.
 

Attachments

  • extensions.png
    extensions.png
    161.3 KB · Views: 269
Last edited:
Joined
Nov 1, 2015
Messages
287
Motherboard
GA-Z270X-Gaming 9
CPU
i7-7700K
Graphics
RX 560
Thank you, at second boot your plist was accepted, though i have still no sound and i can't add HDAS to HDEF with clover configurator.
The HDAS to HDEF patch is there and works.
Well, now (sometimes) i have this error :

OsxAptioFix2Drv: starting overrides for /System\Library\CoreServices\boot.efi
using reloc block: no, hibernate wake: no
Error allocating 0x11c21 pages at 0x0000000xxxxxx alloc type 2
Couldn't allocate runtime area
Boot failed, sleeping for 10 seconds before exiting...
That's another issue, try the OsxAptioFixDrv or the new AptioFix
I remind you i was with a MB z170x gaming 5 and now with the gaming 7.
Here are my /library/extensions.
Do you need SoundFlower?, your IOReg shows me that CodecCommander is not loaded.
Select the first audio output, it should work without CC.
 
Status
Not open for further replies.
Top