Contribute
Register

Creative CA0132 codec discussion (Sound Core3D)

Joined
Nov 1, 2015
Messages
216
Motherboard
GA-Z270X-Gaming 7
CPU
i7-7700K
Graphics
RX 580 Nitro
Because a few users ask if audio is possible with this codec, especially for the GA-Z170X-Gaming 7 mainboard, here some solutions:

Below, a fully patched kext that gives you the default outputs. For headphones and front microphone you can use the attached switcher. Other layouts are also possible.
Why a fully patched kext? because i think it is the easiest way to make audio working. The Gigabyte Gaming 7 users, without a patched DSDT need only the HDAS to HDEF clover-patch.

If you want to use the fully patched kext, remove voodooHDA.kext and HDADisabler.kext, make sure the ACPI audio device name is HDEF (DSDT, SSDT, clover-patch) and layout-id 0.
Install the AppleHDA.kext to /S/L/E and CodecCommander to /L/E

AppleHDA_10.13.1_layout-ID_0.zip




Another solution is: AppleALC + Lilu which use the same resources with different layouts. To get it fully working you have to use the CodecCommander.kext you can download here, install CodecCommander to /L/E.

Layout-ID
1: is for Alienware Laptops.
4: 5.1 is possible with an aggregate device but no front headphones and front mic.
5: only front speakers, headphones and front mic.
6: front and rear speakers, front headphones, rear mic.

If you want to use AppleALC make sure your AppleHDA.kext is untouched, remove voodooHDA.kext and HDADisabler.kext
AppleALC with layout-ID 4 can also be used with the CA0132Switcher to switch to the headphones and front microphone.




It seems that on some systems HPET uses the IRQ which is normally assigned to the audio device. HPET doesn't share IRQs with other devices, which could be a problem in some cases. So try the Clover HPET-fix also recomended FixIPIC, FixRTC, FixTMR.

Any feedback would be useful, thanks

good luck.
 

Attachments

Last edited:
Joined
Dec 29, 2016
Messages
4
Motherboard
Gigabyte Z170X . Gaming 7
CPU
Skylake 6700
Graphics
Asus 1060
Because a few users ask if audio is possible with this codec, especially for the GA-Z170X-Gaming 7 mainboard, here some solutions:

Below, a fully patched kext that gives you the default outputs. For headphones and front microphone you can use the attached switcher. Other layouts are also possible.
Why a fully patched kext?, because i think it is the easiest way to make audio working. The Gigabyte Gaming 7 users, without a patched DSDT need only the HDAS to HDEF clover-patch.

If you want to use the fully patched kext, remove voodooHDA.kext and HDADisabler.kext, make sure the ACPI audio device name is HDEF (DSDT, SSDT, clover-patch) and layout-id 0.
Install the AppleHDA.kext to /S/L/E and CodecCommander to /L/E

AppleHDA_10.13.1_layout-ID_0.zip
CA0132AudioSwitcher.zip


Another solution is: AppleALC + Lilu which use the same resources with different layouts. To get it fully working you have to use the CodecCommander.kext you can download here, install CodecCommander to /L/E.

Layout-ID
1: is for Alienware Laptops.
4: default, 5.1 is possible but no headphones and front mic.
5: only front speakers, headphones and front mic.
6: front and rear speakers, front headphones, rear mic.

If you want to use AppleALC make sure your AppleHDA.kext is untouched and remove voodooHDA.kext and HDADisabler.kext


Any feedback would be useful, thanks

good luck.
I have been attempting to get this work with the CA0132 on my motherboard using the files in this post. It appears the AppleHDA is not loading. I can see this error message

sudo touch /Library/Extensions && sudo kextcache -u /

Password:

kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext USBInjectAll.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext NvidiaGraphicsFixup.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext NullCPUPowerManagement.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext IntelMausiEthernet.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext GenericUSBXHCI.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakeSMC_LPCSensors.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakeSMC_GPUSensors.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakeSMC_CPUSensors.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakeSMC_ACPISensors.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakeSMC.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakePCIID_XHCIMux.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakePCIID.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext AtherosE2200Ethernet.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext Lilu.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext CodecCommander.kext
kext-dev-mode allowing invalid signature -67013 0xFFFFFFFFFFFEFA3B for kext AppleMobileDevice.kext
kxld[com.apple.iokit.IOHDAFamily]: The following symbols are unresolved for this kext:
kxld[com.apple.iokit.IOHDAFamily]: ___strlcat_chk
Link failed (error code 5).
Prelink failed for com.apple.iokit.IOHDAFamily; omitting from prelinked kernel.
Can't use IOHDAFamily.kext - not linked.
Prelink failed for com.apple.driver.AppleHDAController; omitting from prelinked kernel.

KernelCache ID: B1B94C9C680E70A14CCC10BA891A1F26


Any ideas what I may need to check further or any more information I can provide to help troubleshoot?

Thanks
 
Joined
Nov 1, 2015
Messages
216
Motherboard
GA-Z270X-Gaming 7
CPU
i7-7700K
Graphics
RX 580 Nitro
Do not install the AppleHDA.kext to /Library/Extensions (only CodecCommander). Make a backup and replace the AppleHDA.kext from /System/Library/Extensions, rebuild the cache
 
Joined
Dec 29, 2016
Messages
4
Motherboard
Gigabyte Z170X . Gaming 7
CPU
Skylake 6700
Graphics
Asus 1060
There was indeed a copy of the AppleHDA.kext in the /L/E folder. I removed it and reinstalled the Kexts in the proper locations. Rebuilt the cache and rebooted the computer.

Still get this error in Dmege when loading AppleHDA. IO register does not show any applHDa loaded.

PTIDSensors: started

kxld[com.apple.iokit.IOHDAFamily]: The following symbols are unresolved for this kext:

kxld[com.apple.iokit.IOHDAFamily]: ___strlcat_chk

Can't load kext com.apple.iokit.IOHDAFamily - link failed.

Failed to load executable for kext com.apple.iokit.IOHDAFamily.

Kext com.apple.iokit.IOHDAFamily failed to load (0xdc008016).

Dependency com.apple.iokit.IOHDAFamily of kext com.apple.driver.AppleHDAController failed to load.

Kext com.apple.driver.AppleHDAController failed to load (0xdc008015).

Failed to load kext com.apple.driver.AppleHDAController (error 0xdc008015).
 
Joined
Dec 29, 2016
Messages
4
Motherboard
Gigabyte Z170X . Gaming 7
CPU
Skylake 6700
Graphics
Asus 1060
Upon further review it does not look like I have the IOHDAFamily.kext installed and it appears to be a dependency.

/System/Library/Extensions/AppleHDA.kext/Contents/PlugIns/IOHDAFamily.kext
 
Joined
Nov 1, 2015
Messages
216
Motherboard
GA-Z270X-Gaming 7
CPU
i7-7700K
Graphics
RX 580 Nitro
There was indeed a copy of the AppleHDA.kext in the /L/E folder. I removed it and reinstalled the Kexts in the proper locations. Rebuilt the cache and rebooted the computer.

Still get this error in Dmege when loading AppleHDA. IO register does not show any applHDa loaded.

PTIDSensors: started

kxld[com.apple.iokit.IOHDAFamily]: The following symbols are unresolved for this kext:

kxld[com.apple.iokit.IOHDAFamily]: ___strlcat_chk

Can't load kext com.apple.iokit.IOHDAFamily - link failed.

Failed to load executable for kext com.apple.iokit.IOHDAFamily.

Kext com.apple.iokit.IOHDAFamily failed to load (0xdc008016).

Dependency com.apple.iokit.IOHDAFamily of kext com.apple.driver.AppleHDAController failed to load.

Kext com.apple.driver.AppleHDAController failed to load (0xdc008015).

Failed to load kext com.apple.driver.AppleHDAController (error 0xdc008015).
I've never seen this unresolved symbols error. I assume you have somewhere, another AppleHDA.kext.
The IOHDAFamily kext is a AppleHDA plugin as you can see from the path, can you save and upload your IOReg?
 
Joined
Nov 21, 2017
Messages
8
Motherboard
Alienware 17 / HM87
CPU
Core i7-4980HQ
Graphics
Intel Iris Pro Graphics 5200
Mobile Phone
Android, iOS
Sir wern I have installed Sierra 10.12 into my Alienware 17 R2 which uses CA0132 codec.

In S/L/E there's untouched AppleHDA.kext right of the box.

Next, I have put latest AppleALC.kext, Lilu.kext and modded CodecCommander.kext in EFI/Clover/Kexts/Other.

The CodecCommander.kext is modded specially for CA0132 (modded by you. I have forgotten where did I found it)

Set my Audio ID to 1 since it is suitable for Alienware laptops.

I tried to follow your guide in insanelymac forum but i couldn't download the custom kexts you have created. I could not create an account for insanelymac forum. It says I don't have permission for that. Here is my config.plist. Please enlighten me.
 

Attachments

Joined
Nov 1, 2015
Messages
216
Motherboard
GA-Z270X-Gaming 7
CPU
i7-7700K
Graphics
RX 580 Nitro
If you want to use AppleALC + Lilu.kext you don't need a patched kext, it should work if the ACPI device name is HDEF.
If it does't work save and upload your IOReg, use version 2.1 if possible.
 
Joined
Nov 21, 2017
Messages
8
Motherboard
Alienware 17 / HM87
CPU
Core i7-4980HQ
Graphics
Intel Iris Pro Graphics 5200
Mobile Phone
Android, iOS
If you want to use AppleALC + Lilu.kext you don't need a patched kext, it should work if the ACPI device name is HDEF.
If it does't work save and upload your IOReg, use version 2.1 if possible.
I have tried both Azal>HDEF and HDAS>HDEF patches but nothing happened.

Should I use normal CodecCommander.kext instead the modded for CA0132?

For the IOReg thing, I have followed toleda's guide on how to get the ioreg file. I hope it's the correct one.
 

Attachments

Joined
Nov 21, 2017
Messages
8
Motherboard
Alienware 17 / HM87
CPU
Core i7-4980HQ
Graphics
Intel Iris Pro Graphics 5200
Mobile Phone
Android, iOS
I have tried both Azal>HDEF and HDAS>HDEF patches but nothing happened.

Should I use normal CodecCommander.kext instead the modded for CA0132?

For the IOReg thing, I have followed toleda's guide on how to get the ioreg file. I hope it's the correct one.
[Update]
1. Tried rename to HDEF patches failed.
2. Use RehabMan's CodecCommander.kext failed.
 

Attachments

Top