Contribute
Register

Creating Custom SSDT For add in cards

Joined
Nov 17, 2010
Messages
173
Motherboard
Asus X-99 A II
CPU
i7-6900K
Graphics
Titan X Maxwell
Mac
Mac Pro
Mobile Phone
iOS
I would like to create a couple of custom SSDT for my Decklink and Areca Raid cards. I' trying to correct a couple of odd ball things I am seeing . For Example the Areca card reports it's hooked up via ethernet, and the slot info is all goofed up on my X99 system. I have corrected my graphics card and it shows up in IO Reg correctly. I can find the sections in the Extracted DSDT but I can not find info on where to start from scratch

Kevin
 
Joined
Nov 17, 2010
Messages
173
Motherboard
Asus X-99 A II
CPU
i7-6900K
Graphics
Titan X Maxwell
Mac
Mac Pro
Mobile Phone
iOS
I would like to create a couple of custom SSDT for my Decklink and Areca Raid cards. I' trying to correct a couple of odd ball things I am seeing . For Example the Areca card reports it's hooked up via ethernet, and the slot info is all goofed up on my X99 system. I have corrected my graphics card and it shows up in IO Reg correctly. I can find the sections in the Extracted DSDT but I can not find info on where to start from scratch

Kevin
Is there no one who can help me with this?

Kevin
 
Joined
Jun 9, 2013
Messages
10,957
Motherboard
GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
MacBook, Mac mini
Mobile Phone
Android
I would like to create a couple of custom SSDT for my Decklink and Areca Raid cards. I' trying to correct a couple of odd ball things I am seeing . For Example the Areca card reports it's hooked up via ethernet, and the slot info is all goofed up on my X99 system. I have corrected my graphics card and it shows up in IO Reg correctly. I can find the sections in the Extracted DSDT but I can not find info on where to start from scratch

Kevin
Need to use ioreg to see which controller is which of course. But your saying this device connects to Ethernet?
 
Joined
Nov 17, 2010
Messages
173
Motherboard
Asus X-99 A II
CPU
i7-6900K
Graphics
Titan X Maxwell
Mac
Mac Pro
Mobile Phone
iOS
yeah checkout what the AAPL,slot-name is. It's definitely not attached to the ethernet. It is in slot PCIE X16_5 on my Asus Deluxe II motherboard.
Screen Shot 2017-03-13 at 9.45.08 AM.png
 
Joined
Jun 9, 2013
Messages
10,957
Motherboard
GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
MacBook, Mac mini
Mobile Phone
Android
yeah checkout what the AAPL,slot-name is. It's definitely not attached to the ethernet. It is in slot PCIE X16_5 on my Asus Deluxe II motherboard.
View attachment 241704
Probably not worth trying to get it working. Use onboard or buy a supported Ethernet Card.
 
Joined
Nov 17, 2010
Messages
173
Motherboard
Asus X-99 A II
CPU
i7-6900K
Graphics
Titan X Maxwell
Mac
Mac Pro
Mobile Phone
iOS
Probably not worth trying to get it working. Use onboard or buy a supported Ethernet Card.
I think you missed the point Everything works. This is not my Ethernet card. This is my Areca Raid card. It works perfectly. It just shows up as being attached to an Ethernet port. So maybe this is cosmetic? but one of my other cards that also works does not show up under PCI devices in system profiler at all.

Kevin
 
Joined
Jun 9, 2013
Messages
10,957
Motherboard
GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
MacBook, Mac mini
Mobile Phone
Android
I think you missed the point Everything works. This is not my Ethernet card. This is my Areca Raid card. It works perfectly. It just shows up as being attached to an Ethernet port. So maybe this is cosmetic? but one of my other cards that also works does not show up under PCI devices in system profiler at all.

Kevin
Possibly a Cosmetic problem. Look at SSDT-WIFI as an example. https://github.com/VoiletDragon/Z97-HD3-Patches
 
Joined
Apr 12, 2010
Messages
47
Motherboard
GA-X58A-OC
CPU
I7 950
Graphics
XFX ATI 5870
Mac
Mac Pro
Classic Mac
Mobile Phone
iOS
Kev, I've seen this issue with a pci usb card and also my graphics cards. I fixed my graphics cards but not my usb card. I think this was because my graphics cards are in my dsdt and the usb cards aren't.

Anyway, i fixed this by using clover configurator.

Under the SMBIOS section add your pci device under the Slots AAPL injections like below, and play around with the ID section. Here you can set it to ethernet, hdmi and others if its not mentioned in your dsdt (I think :) )
Screen Shot 2017-04-25 at 12.56.52.png


Screen Shot 2017-04-25 at 13.00.36.png
 
Joined
Jun 29, 2011
Messages
43
Motherboard
GA-Z270X-UD5
CPU
Core i7-7700K
Graphics
Nvidia 1080ti 11GB
Mac
MacBook Air, Mac mini
Mobile Phone
iOS
Kev, I've seen this issue with a pci usb card and also my graphics cards. I fixed my graphics cards but not my usb card. I think this was because my graphics cards are in my dsdt and the usb cards aren't.

Anyway, i fixed this by using clover configurator.

Under the SMBIOS section add your pci device under the Slots AAPL injections like below, and play around with the ID section. Here you can set it to ethernet, hdmi and others if its not mentioned in your dsdt (I think :) )
View attachment 250675

View attachment 250676
How do I know the correct ID for the device?
 
Joined
Jan 12, 2019
Messages
32
Motherboard
Asus X99-a II
CPU
6800k
Graphics
Radeon VII
@KevinAGI Sorry to resurrect such an old thread, I have a deckling mini monitor 4k and an LSI 9220 sas adapter and would love to make SSDTs for them, yet I've failed every time I tried. This is of course purely cosmetic, both cards function properly but I'd like to do it anyway. Did you succeed with yours?
 
Top