Contribute
Register

Create 10.14 usb installer from Snow leopard 10.6.8

Joined
Aug 17, 2012
Messages
45
Motherboard
ASUS UX31LA (clover)
CPU
Core i5 4200u
Graphics
Intel HD graphics 4400, 1920x1080
Mobile Phone
Android
Hi guys, anyone knows how to create the Mojave installer from a working 10.6.8 installation? I press the get button on appstore to download Mojave but nothing happens and also it is grey. I tried the Mojave patcher app and it downloads the mojave files (6.03GB) but I get an error in unibeast when I try to create the USB installer. I tried also from the command line to create the installer and I get a " segmentation fault" error. So what is the problem, I can't understand. Did anyone face the same problem?

I have no other more recent osx available now, I sold all my macs so thats why I am fighting with iboot+10.6.8
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
13,782
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
The newest OS you can download from the MAS when running SL is El Capitan. Download that first, then make a Unibeast installer. Install El Cap and then go back to the MAS to download Mojave without using the patcher app.
 
Joined
Aug 17, 2012
Messages
45
Motherboard
ASUS UX31LA (clover)
CPU
Core i5 4200u
Graphics
Intel HD graphics 4400, 1920x1080
Mobile Phone
Android
I just did the upgrade to El Capitan now, but now I get an error from appstore says this version 10.14 cannot be installed on this computer. So I am trying now with the Mojave patcher to download the installation of Mojave, still downloading, I hope this will work :)
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
21,026
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
I get an error from appstore says this version 10.14 cannot be installed on this computer
Check that you are using the SMBIOS of a Mac that qualifies for the upgrade to Mojave.
Early installations defaulted to MacPro3,1 which does not meet the minimum specifications.
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
13,782
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
I just did the upgrade to El Capitan now, but now I get an error from appstore says this version 10.14 cannot be installed on this computer. So I am trying now with the Mojave patcher to download the installation of Mojave, still downloading, I hope this will work :)
You don't need the patcher. Just use a newer sysdef instead. Then it will allow the Mojave download.
It would also be wise for you to start a new thread in Mojave Laptop Support as this is supposed to be
for desktops only. EDIT: moved thread to SL Laptop Support.
 
Last edited:
Top