Contribute
Register

Continuity and Handoff Capable Apple Mini Cards + PCIe and mini-PCIe Adapters

Joined
Dec 21, 2013
Messages
79
Motherboard
GA-Z97MX-Gaming-5
CPU
i7-4790K OC@ 4.2GHz
Graphics
RX 580
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Fenvi T919 worked out of the box for me as well (available on eBay).

I also had to log out of iCloud and log back in as mentioned by @Stompyy and @Douirc .

After that full Continuity, Handoff, Airdrop as well as unlocking with my Apple Watch works.

Despite reports I didn't need to put it in a 1x slot (and move my graphics card to another slot due to the motherboard layout) - it works fine in a 4x slot on my motherboard.
 
Joined
Nov 23, 2018
Messages
19
Motherboard
X299
CPU
İ9-7900X
Graphics
Zotac RTX 2080ti AMP
Hello guys. I plan to build my hackintosh. Any Bluetooth 5.0 cards in the market compatible with macOS? I see that Apple has moved on to Bluetooth 5.0 from MBP 2018 models.
 
Joined
Oct 31, 2018
Messages
38
Motherboard
ASUS Z170-AR
CPU
i7-6700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
So I have just upgraded to the Fenvi T919 from Newegg. Installed the card, Bluetooth and Wi-Fi work perfectly, my apple keyboard and mouse work 100% but no luck with handoff and continuity. Doing some research online it was said to add fox lan or fix airport if you’re using wireless and add some patches.. while trying to do so I noticed in my smbios I have a serial number for the iMac 17,1 but no board serial number or SMUUID. I also remember reading somewhere that you have to add some system perimeters also and mine are all black. For some reason chassis type is laptop also in smbios. Does any of this matter? If so what’s important and what’s not? What will happened if I generate a new serial and all that? Also I remember reading somewhere that the wireless or lan card has to be set as en0 or en1. Which one is it if I have both an Ethernet and wireless setup. What steps should I take to get this to work properly? I may be mixing some of this information I read about fixing iMessages but that seems to be working at the moment. It was in and out but it’s been fine lately. Any input is much appreciated! Thanks in advance.

Edit: This thread second post worked for me! Didn't have to do anything else, my SMBIOS was incomplete.. :rolleyes:
 
Last edited:
Joined
Apr 9, 2011
Messages
21
Motherboard
GA-H370N-WIFI
CPU
i7-8700K
Graphics
RX-580
Hello friends,

I have a BCM94360CS2 and it was working perfectly on my old Hackintosh (ga-h270n-wifi + i5). I now upgraded to the ga-h370n-wifi with the i7 (8700k) and moved the wifi card to the new board (replacing the default intel one). Now my MacOS Mojave 10.14.2 does not recognize the board, it looks like it is not even connected to the board. Is there any bios or config trick to make the MacOS see the wifi card? It was supposed to work OOB. :(

Any help will be great.
 
Joined
Apr 9, 2011
Messages
21
Motherboard
GA-H370N-WIFI
CPU
i7-8700K
Graphics
RX-580
Ok. After a small research:

The original wifi card is the Intel 9560NGW. https://ark.intel.com/products/99446/Intel-Wireless-AC-9560
According to Intel docs, it uses the M.2 CNVio interface that is different from the BCM94360CS2 with the M.2 A/E adapter that I was using.

Any suggestions to have BT/WiFi native back again?
 
Joined
Dec 2, 2018
Messages
19
Motherboard
ASUS Z390-I
CPU
i9-9900K
Graphics
RX 580
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
iOS
I am using GA-Z370N wifi with replacing the onboard intel wifi/Bluetooth card by Dell 1560 and apart from the kexts to make it work one special BT4LEContiunityFixup.kext solve the problem for handoff and continuity.
Hi. Where could I find the special BT4LEContiunityFixup.kext?
I am using an itx board (z390-i), so I can only use the dw1560 ... and I really want to make handoff/Contiunity works.
I really appreciate your help.
 
Last edited:
Joined
Aug 6, 2016
Messages
2
Hello All,

I recently purchased a BCM94360CD for my build. It's currently installed in my system and is detected, plug and play, but because I can not find the correct pigtails I can not use it properly.

Where can I find the correct pigtails?

From everything I've read on these forms, this card should use a u.fl MHF 4 connector. I don't think that is correct though, or I've purchased the wrong pigtails (https://www.amazon.com/gp/product/B07FPMC5NY/?tag=tonymacx86com-20)
My motherboard is a Asus Z270i which has an onboard WiFI card, model QCNFA364A. This WLAN card also used MHF4 pigtails and the ones I've purchased easily fit this card. The male receptacle looks much smaller on this card compared to BCM94360CD.

I'd appreciate anyones input, thank you!


Update:
I choose to buy MHF2 pigtails as those fit better than U.FL "MHF1". Purchased from https://www.data-alliance.net
 
Last edited:
Joined
Dec 8, 2013
Messages
15
Motherboard
Dell XPS 8500-NW73C
CPU
i5-3350P/H77
Graphics
RX 580
Mac
iMac, MacBook Air, MacBook Pro, Mac mini
Mobile Phone
iOS
So I have just upgraded to the Fenvi T919 from Newegg. Installed the card, Bluetooth and Wi-Fi work perfectly, my apple keyboard and mouse work 100% but no luck with handoff and continuity. Doing some research online it was said to add fox lan or fix airport if you’re using wireless and add some patches.. while trying to do so I noticed in my smbios I have a serial number for the iMac 17,1 but no board serial number or SMUUID. I also remember reading somewhere that you have to add some system perimeters also and mine are all black. For some reason chassis type is laptop also in smbios. Does any of this matter? If so what’s important and what’s not? What will happened if I generate a new serial and all that? Also I remember reading somewhere that the wireless or lan card has to be set as en0 or en1. Which one is it if I have both an Ethernet and wireless setup. What steps should I take to get this to work properly? I may be mixing some of this information I read about fixing iMessages but that seems to be working at the moment. It was in and out but it’s been fine lately. Any input is much appreciated! Thanks in advance.

Edit: This thread second post worked for me! Didn't have to do anything else, my SMBIOS was incomplete.. :rolleyes:
SORRY ahead of time for the dumb question. I have a fully functioning Dell XPS 8500 running Mojave. I'd love to add the Fenvi T919 to it to get native wifi and bluetooth 4.0. My question is regarding Bluetooth via USB. Do I simply need to have an open USB connection on the motherboard to get OSX to recognize BT? Or does the MB need to have a special "USB BT" connector? I've attached an image of my MB. I have USB connectors available currently. Thanks!
388108
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
9,907
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
SORRY ahead of time for the dumb question. I have a fully functioning Dell XPS 8500 running Mojave. I'd love to add the Fenvi T919 to it to get native wifi and bluetooth 4.0. My question is regarding Bluetooth via USB. Do I simply need to have an open USB connection on the motherboard to get OSX to recognize BT? Or does the MB need to have a special "USB BT" connector? I've attached an image of my MB. I have USB connectors available currently. Thanks!View attachment 388108
You can use the USB headers on the right edge of the motherboard for Bluetooth.

You also have an open Mini PCI-e connector. You can probably get an adaptor and use that with a BCM94360 based card for Wi-Fi/Bluetooth.
 
Top